Bug 279363 - dragging a menubar in Qt designer moves the entire designer window
Summary: dragging a menubar in Qt designer moves the entire designer window
Status: RESOLVED FIXED
Alias: None
Product: Oxygen
Classification: Unclassified
Component: style (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-04 10:25 UTC by Stephen Kelly
Modified: 2011-08-09 09:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Kelly 2011-08-04 10:25:04 UTC
Version:           unspecified (using KDE 4.7.0) 
OS:                Linux

dragging a menubar in Qt designer moves the entire designer window


Reproducible: Didn't try

Steps to Reproduce:
1. Start designer
2. Create a new form using the mainwindow template 
3. Click and drag the menubar in the form 


Actual Results:  

The entire designer window is moved.


Expected Results:  

I don't know if this is intentional/can be worked around.
Comment 1 Hugo Pereira Da Costa 2011-08-04 11:43:29 UTC
Hello Stephen,
Correct me if I'm wrong: the "normal behavior" (that is when window drag mode is disabled) is ... nothing happens. Right ?

So that there is no actual conflict, and just an annoyance.
I agree this is inconsistent since at best the expected behavior would be to drag the "subwindow" into its MDI frame.

I'll see if I can find a workaround.

(PS: no this is not "intended". Just an infortunate consequence from the code logic). 

(PPS: thanks for posting)
Comment 2 Stephen Kelly 2011-08-04 13:22:14 UTC
Ok, no worries if it can't be worked around in an easy way. It was just a surprise.
Comment 3 Hugo Pereira Da Costa 2011-08-09 09:01:09 UTC
Git commit 892059c761780f1ade97f0e703051e853d1ef52b by Hugo Pereira Da Costa.
Committed on 09/08/2011 at 10:56.
Pushed by hpereiradacosta into branch 'KDE/4.7'.

Added ::findParent method to check if a widget has a parent of a given type.
Do not drag from a menubar embedded into an Mdi Subwindow.
CCBUG: 279363

M  +15   -0    kstyles/oxygen/oxygenwindowmanager.h
M  +5    -2    kstyles/oxygen/oxygenwindowmanager.cpp

http://commits.kde.org/kde-workspace/892059c761780f1ade97f0e703051e853d1ef52b
Comment 4 Hugo Pereira Da Costa 2011-08-09 09:01:09 UTC
Git commit 793164db34473b1ab3623045a4468d6e1f8ef757 by Hugo Pereira Da Costa.
Committed on 09/08/2011 at 10:56.
Pushed by hpereiradacosta into branch 'master'.

Added ::findParent method to check if a widget has a parent of a given type.
Do not drag from a menubar embedded into an Mdi Subwindow.
CCBUG: 279363

M  +15   -0    kstyles/oxygen/oxygenwindowmanager.h
M  +5    -2    kstyles/oxygen/oxygenwindowmanager.cpp

http://commits.kde.org/kde-workspace/793164db34473b1ab3623045a4468d6e1f8ef757
Comment 5 Hugo Pereira Da Costa 2011-08-09 09:02:13 UTC
comments #3 and #4 fixes it.
No drag from Menubars in MdiSubwindow, which is the expected behavior and consistent with other empty areas in there.

Thanks for reporting !