Bug 279269 - Kopete history plugin escapes quote and ampersand characters
Summary: Kopete history plugin escapes quote and ampersand characters
Status: RESOLVED DUPLICATE of bug 269097
Alias: None
Product: kopete
Classification: Unclassified
Component: History Plugin (show other bugs)
Version: 1.0.80
Platform: Debian unstable Linux
: NOR normal with 71 votes (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-03 09:29 UTC by Vsevolod Krishchenko
Modified: 2016-08-14 22:02 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vsevolod Krishchenko 2011-08-03 09:29:09 UTC
Version:           1.0.80 (using KDE 4.6.5) 
OS:                Linux

History plugin escapes quote character (as """) and ampersand character as "&" when saving history. It affects both incoming and outcoming messages.


Reproducible: Always

Steps to Reproduce:
1. Open some Jabber or ICQ chat (I have not tested other protocols, but I think it works with any protocol plugin).
2. Send some message containing '"' or '&'. 
Let's send just two characters: "&
3. Close char window.
4. Reopen the same chat or open a contact history.
5. Saved message looks like: "&



Actual Results:  
Saved message looks like: 
"&

Expected Results:  
Saved message should look like: 
"&

It does not affect <, > or ' characters. So it is not full HTML escaping.
Comment 1 Mykola Krachkovsky 2012-05-30 09:46:25 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Mykola Krachkovsky 2012-05-30 09:49:54 UTC
Kopete 1.2.3 (KDE 4.8.3)

Bug still presents.

Also https://bugs.kde.org/show_bug.cgi?id=269097 exists with patch (maybe helpful).
Comment 3 Murz 2012-12-12 06:32:18 UTC
KDE 4.9.4 - bug is still exist too. It is not so hard to fix it, where is the problem?
Comment 4 Pali Rohár 2016-08-14 22:02:49 UTC

*** This bug has been marked as a duplicate of bug 269097 ***