Bug 278950 - Re-add generic support for the new shadow system.
Summary: Re-add generic support for the new shadow system.
Status: RESOLVED INTENTIONAL
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-31 16:42 UTC by Friedrich W. H. Kossebau
Modified: 2012-03-14 15:40 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Friedrich W. H. Kossebau 2011-07-31 16:42:56 UTC
Version:           unspecified (using KDE 4.7.0) 
OS:                Linux

With Oxygen as windowframe style I see nice shadows around windows.

Reproducible: Always

Steps to Reproduce:
If I switch to e.g. Skulpture or Bespin as windowframe style...

Actual Results:  
... the shadow for any normal windows disappears. Happens with any widget style.


Expected Results:  
... there is still a nice shadow around the windows :)

Similar with the widget style:
With Oxygen as widget style menus/tooltips have shadows. If I switch the widget style to something else, e.g. Skulpture or Bespin, there is no shadow for menus/tooltips, with any kind of windowframe style.

Happens with both XRender and OpenGL.
Comment 1 Thomas Lübking 2011-07-31 16:54:49 UTC
Bespin has suppoort for the new shadow system since r1382 - latest is r1385 which should improve few things.
You have to compile it against >= 4.7.0 (NO runtime check) since the new shadows were broken for decorations before.
(please try and report)

No idea whether there's support from QtCurve or skulpture.

So this ain't a bug, but maybe there should be an effect plugin to add shadow pixmaps to appearing windows to cover other/older widget styles.
-> altered the report in that regard.
Comment 2 Martin Flöser 2011-07-31 16:57:35 UTC
skulpture has AFAIK also support for at least deco shadow right now
Comment 3 Christoph Feck 2011-07-31 17:07:09 UTC
Yep, Skulpture window decoration has shadows in git/master.
Comment 4 Friedrich W. H. Kossebau 2011-07-31 17:28:05 UTC
Ah, okay, did not get to me from that blog post from March (or whatever my memory was based on). So I have to hope for new packages of Bespin and Skulpture for my production system arriving soon :)

Will try to schedule some time to compile and check Bespin, Thomas, but no promises.

BTW, you KWin coders owe me 5 min of my life. Those minutes, I have today already wobbled my windows around on my desktop, full of joy it finally works also for me! :)) Time in which I could have fetched and compiled Bespin! ;)
Comment 5 Thomas Lübking 2011-07-31 17:34:03 UTC
just FTR:
r1385 has a really stupid and pot. severe (segfaulting) bug which is fixed in r1386. -> so do NOT use r1385. (i probably was somehow sleeping while doing this ;-)
Comment 6 Martin Flöser 2012-03-14 15:40:28 UTC
After one year it looks like nobody is going to add generic shadows back and given the reactions from the userbase there seems to be no demand to add the generic support back.