Bug 278873 - Facebook Crash
Summary: Facebook Crash
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-30 17:41 UTC by KimD
Modified: 2011-07-30 17:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description KimD 2011-07-30 17:41:09 UTC
Application: kwin (4.6.00 (4.6.0) "release 6")
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: Was using Facebook application game Cafe World, went to close the browser when it crashed.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb74d229760 (LWP 9149))]

Thread 2 (Thread 0x7fb733fe5700 (LWP 9155)):
#0  0x00007fb748af638c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fb74b8f2044 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fb74bc0b180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fb74b8f2079 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fb74bc19254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fb748af1a3f in start_thread () from /lib64/libpthread.so.0
#4  0x00007fb74ca8467d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb74d229760 (LWP 9149)):
[KCrash Handler]
#6  0x00007fb734df0ab0 in ?? () from /usr/lib64/dri/i965_dri.so
#7  0x00007fb734de42d4 in ?? () from /usr/lib64/dri/i965_dri.so
#8  0x00007fb734de67da in ?? () from /usr/lib64/dri/i965_dri.so
#9  0x00007fb74cde9625 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:921
#10 0x00007fb74cde0d96 in KWin::Scene::paintGenericScreen (this=0x764640, orig_mask=40) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:188
#11 0x00007fb74cdddeea in KWin::Scene::finalPaintScreen (this=0x764640, mask=40, region=<value optimized out>, data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:178
#12 0x00007fb74cdfb38f in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:173
#13 0x00007fb734327d7b in KWin::StartupFeedbackEffect::paintScreen (this=0x1eb69c0, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#15 0x00007fb74aee0f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#16 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#17 0x00007fb7342cef3f in KWin::LogoutEffect::paintScreen (this=0x1e2e660, mask=40, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/logout/logout.cpp:207
#18 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#19 0x00007fb7342e9b72 in KWin::ShadowEffect::paintScreen (this=0x1906110, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/shadow/shadow.cpp:189
#20 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#21 0x00007fb7342fc4fe in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/blur/blur.cpp:230
#22 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#23 0x00007fb7342d39c2 in KWin::PresentWindowsEffect::paintScreen (this=0x18d83c0, mask=8, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#25 0x00007fb74aee0f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#26 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#27 0x00007fb74aee0f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#28 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#29 0x00007fb74aee0f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#30 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#31 0x00007fb74aee0f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#32 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#33 0x00007fb7342ba2a3 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#35 0x00007fb7342f034d in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/slide/slide.cpp:86
#36 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#37 0x00007fb7342b2e42 in KWin::BoxSwitchEffect::paintScreen (this=0x1ecbdd0, mask=8, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#39 0x00007fb74aee0f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#40 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#41 0x00007fb74aee0f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#42 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#43 0x00007fb74aee0f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#44 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#45 0x00007fb74aee0f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#46 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#47 0x00007fb74aee0f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#48 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#49 0x00007fb7342f9b7f in KWin::ZoomEffect::paintScreen (this=0x1af8230, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/zoom/zoom.cpp:341
#50 0x00007fb74cdfb41c in KWin::EffectsHandlerImpl::paintScreen (this=0xa8e340, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#51 0x00007fb74cddefa5 in KWin::Scene::paintScreen (this=0x764640, mask=0x7fff7b6e7a1c, region=0x7fff7b6e7b10) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:137
#52 0x00007fb74cdf34e9 in KWin::SceneOpenGL::paint (this=0x764640, damage=..., toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:772
#53 0x00007fb74cddb6c7 in KWin::Workspace::performCompositing (this=0xa990a0) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/composite.cpp:448
#54 0x00007fb748e7d799 in QObject::event (this=0xa990a0, e=<value optimized out>) at kernel/qobject.cpp:1175
#55 0x00007fb748018d14 in QApplicationPrivate::notify_helper (this=0x635580, receiver=0xa990a0, e=0x7fff7b6e8350) at kernel/qapplication.cpp:4445
#56 0x00007fb74802122a in QApplication::notify (this=<value optimized out>, receiver=0xa990a0, e=0x7fff7b6e8350) at kernel/qapplication.cpp:4324
#57 0x00007fb74c4fc9e6 in KApplication::notify (this=0x7fff7b6e8830, receiver=0xa990a0, event=0x7fff7b6e8350) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#58 0x00007fb748e69bfc in QCoreApplication::notifyInternal (this=0x7fff7b6e8830, receiver=0xa990a0, event=0x7fff7b6e8350) at kernel/qcoreapplication.cpp:732
#59 0x00007fb748e974d8 in sendEvent (this=0x635f90) at kernel/qcoreapplication.h:215
#60 QTimerInfoList::activateTimers (this=0x635f90) at kernel/qeventdispatcher_unix.cpp:618
#61 0x00007fb748e97be0 in QEventDispatcherUNIX::processEvents (this=0x612380, flags=...) at kernel/qeventdispatcher_unix.cpp:937
#62 0x00007fb7480bebac in QEventDispatcherX11::processEvents (this=0x612380, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#63 0x00007fb748e69052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#64 0x00007fb748e69265 in QEventLoop::exec (this=0x7fff7b6e8720, flags=...) at kernel/qeventloop.cpp:201
#65 0x00007fb748e6d6ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#66 0x00007fb74cd79c8a in kdemain (argc=<value optimized out>, argv=0x7fff7b6e8890) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/main.cpp:542
#67 0x00007fb74c9cfbfd in __libc_start_main () from /lib64/libc.so.6
#68 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 278796, bug 278595, bug 278496, bug 278470, bug 278310.

Reported using DrKonqi
Comment 1 Martin Flöser 2011-07-30 17:46:28 UTC
driver bug - debugging symbols are missing but I think it's our most loved driver bug.

*** This bug has been marked as a duplicate of bug 252817 ***