Bug 278652 - Wish -- show variable value in watch (without having to click)
Summary: Wish -- show variable value in watch (without having to click)
Status: RESOLVED FIXED
Alias: None
Product: kdevplatform
Classification: Unclassified
Component: debugger (show other bugs)
Version: git master
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-27 22:40 UTC by ustech
Modified: 2011-12-30 18:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ustech 2011-07-27 22:40:27 UTC
Version:           4.0.2 (using Devel) 
OS:                Linux

WISHLIST -- SHOW VARIABLE VALUES in the watch window without having to click them ...

also -- add VIEW IN MEMORY to SEE ENTIRE CONTENTS OF LONG STRINGS!

Reproducible: Always

Steps to Reproduce:
LOOK AT THE WATCH WINDOW -- NO VALUES - U HAVE TO CLICK TO SEE.

Actual Results:  
%(

Expected Results:  
%)

TRY XCODE ON MAC.
Comment 1 Niko Sams 2011-07-28 09:22:24 UTC
you mean the tree should be expanded by default?
that would make sense.

regarding the view in memory, please open another bug. But first fix your shift key, it seems to be hanging sometimes :D
Comment 2 Niko Sams 2011-12-30 18:58:21 UTC
Git commit 978a70d51f8d82867a33041d89630c5f639c58ad by Niko Sams.
Committed on 30/12/2011 at 19:30.
Pushed by nsams into branch '1.3'.

automatically expand watches after adding a watch

M  +6    -0    debugger/variable/variablecollection.cpp

http://commits.kde.org/kdevplatform/978a70d51f8d82867a33041d89630c5f639c58ad