Bug 278236 - Cannot drag file onto chromium upload form input
Summary: Cannot drag file onto chromium upload form input
Status: RESOLVED UPSTREAM
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 15.12.1
Platform: Ubuntu Packages Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 355761 358184 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-22 01:20 UTC by Kai Uwe Broulik
Modified: 2016-12-25 14:00 UTC (History)
23 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2011-07-22 01:20:37 UTC
Version:           unspecified (using KDE 4.6.4) 
OS:                Linux

Using Chromium, on webpages that allow uploading a file I cannot drag a file from Dolphin onto the “Select file” form input to upload that respective file.
Dragging pictures from Gwenview’s preview sidebar works just fine but in Dolphin all the files show the "Dnd" cursor when dragging over Chromium. And Rekonq doesn’t even handle a drag event on such items, it just opens that file.

Reproducible: Always

Steps to Reproduce:
.


Expected Results:  
.
Comment 1 Dave M 2011-10-31 03:35:49 UTC
Same here, cannot drag/drop from Dolphin to Chrome/Chromium for file upload (i.e. GMail).

Works with any other file browser (Krusader or a Gnome file browser).
Comment 2 Kai Uwe Broulik 2011-10-31 13:03:12 UTC
Also doesn’t work in Dolphin 2.0 with the new view-engine thing.
Comment 3 Peter Penz 2011-10-31 13:52:23 UTC
Dragging pictures into Google-Chrome with Dolphin 2.0 works fine here (tested with GMail and Google-Image-search and by dragging a .jpg image). I currently cannot test it with Dolphin 1.7 (KDE applications 4.7) but I remember that there was an issue with that version...
Comment 4 Jekyll Wu 2011-12-14 17:55:09 UTC
I just checked dolphin 1.99 and gmail in google chrome. It worked just fine :)
Comment 5 Kai Uwe Broulik 2011-12-14 18:13:26 UTC
Weird, neither with KDE 4.7.3 Dolphin, nor with a few days old git it worked :( No matter what kind of file I drag or what view mode is active, I always get that "Invalid" mouse pointer when dragging it over chromium; I tested it on various pages and using a simple html file with just an upload form. Didn’t work in all cases…
Comment 6 Peter Penz 2011-12-27 14:53:38 UTC
Git commit ab4353e2308ba6f2919b54d67d2a9408303ef76d by Peter Penz.
Committed on 27/12/2011 at 15:50.
Pushed by ppenz into branch 'KDE/4.8'.

Fix issue that dragging pictures/videos to Google-Search/YouTube fails
Related: bug 289917
Related: bug 278236
FIXED-IN: 4.8.0

M  +1    -1    dolphin/src/kitemviews/kitemlistcontroller.cpp

http://commits.kde.org/kde-baseapps/ab4353e2308ba6f2919b54d67d2a9408303ef76d
Comment 7 Peter Penz 2011-12-27 14:54:03 UTC
Git commit 7e4268535b66408ba6a649a4832ab47494e9e829 by Peter Penz.
Committed on 27/12/2011 at 15:50.
Pushed by ppenz into branch 'master'.

Fix issue that dragging pictures/videos to Google-Search/YouTube fails
Related: bug 289917
Related: bug 278236
FIXED-IN: 4.8.0

M  +1    -1    dolphin/src/kitemviews/kitemlistcontroller.cpp

http://commits.kde.org/kde-baseapps/7e4268535b66408ba6a649a4832ab47494e9e829
Comment 8 Vovochka 2016-01-21 00:45:16 UTC
This bug appears again plasma 5 desktop :(
Currently using
dolphin: 15.12.0
kf5: 5.16
qt: 5.5.1
Comment 9 Amrit 2016-02-01 05:24:58 UTC
I have encountered this bug again in plasma 5. Here are my version information:
Dolphin: 15.12.1
KDE Frameworks 5.16.0
Qt 5.5.1 (built against 5.5.0)
the xcb windowing system
Comment 10 Tete 2016-02-02 03:34:44 UTC
i can confirm the last comment, same here with plasma 5

info:
KDE Frameworks 5.18.0
Qt 5.5.1 (compilado con 5.5.1)
El sistema de ventanas xcb
Comment 11 Tete 2016-02-02 12:49:36 UTC
(In reply to Tete from comment #10)
> i can confirm the last comment, same here with plasma 5
> 
> info:
> KDE Frameworks 5.18.0
> Qt 5.5.1 (compilado con 5.5.1)
> El sistema de ventanas xcb

sorry i forget to put Dolphin Version: 15.12.1
Comment 12 Leszek Lesner 2016-02-10 10:08:20 UTC
I can confirm that with KF5 5.18
Qt 5.5.1 and Dolphin 15.12.1
Comment 13 Bhushan Shah 2016-02-12 08:48:31 UTC
Reopening based on last comments.
Comment 14 H.H. 2016-02-16 22:12:07 UTC
I can confirm that too. If you need some more info, I will try to help.
Comment 15 J Lee 2016-03-07 02:31:08 UTC
I also experience this behaviour.  Very frustrating as my employer uses google drive exclusively.  Temporarily switched to Gnome Files so can work.

Dolphin 15.12.2
KDE Plasma 5.5.5
Qt 5.5.1

kernel 4.4.3-1
Comment 16 J Lee 2016-03-07 02:31:49 UTC
I also experience this behaviour.  Very frustrating as my employer uses google drive exclusively.  Temporarily switched to Gnome Files so can work.

Dolphin 15.12.2
KDE Plasma 5.5.5
Qt 5.5.1

kernel 4.4.3-1
Comment 17 roman 2016-03-15 07:23:05 UTC
Please fix it!
Comment 18 Guido 2016-03-19 14:27:48 UTC
I confirm too
Comment 19 Guido 2016-03-21 21:38:49 UTC
I can add that Dolphin4 works well with Chrome/Chromium
Comment 20 H.H. 2016-03-22 14:07:23 UTC
I also noticed, that I could copy&paste links to file-urls from dolphin4 (urls like "file:///home/..." via ctrl+c) into other applications (like kwrite/..) as text, which does not work anymore. I have open klipper and select "edit content.." and copy the text from there.
Comment 21 mrcl 2016-04-01 01:45:42 UTC
I confirm this problem here as well.
Drag and drop from Dolphin doesn't work with emacs either.
Comment 22 Arseniy 2016-04-03 09:41:25 UTC
I also encountered this problem (cannot drag-n-drop files to Opera).
Comment 23 Roman Gilg 2016-04-03 14:44:36 UTC
This bug is Qt related.
I'm now on Qt5.6. The bug is still present. Here the bug is discussed upstreamed with a proposed solution: https://bugreports.qt.io/browse/QTBUG-45812

A duplicate is this bug:
https://bugs.kde.org/show_bug.cgi?id=355761
Comment 24 Emmanuel Pescosta 2016-04-03 14:50:17 UTC
Thanks, I'll set the status of this bug report to resolved upstream.
Comment 25 Emmanuel Pescosta 2016-04-03 14:51:48 UTC
*** Bug 355761 has been marked as a duplicate of this bug. ***
Comment 26 Jason Straight 2016-05-10 14:06:50 UTC
Not calling BS, but why does it work with FF if it's a QT issue?
Comment 27 Elvis Angelaccio 2016-12-25 14:00:36 UTC
*** Bug 358184 has been marked as a duplicate of this bug. ***