Bug 278125 - Investigating Konqueror Bugs, HTML/CSS problem section should use a doctype triggering web standards compliant rendering mode
Summary: Investigating Konqueror Bugs, HTML/CSS problem section should use a doctype t...
Status: RESOLVED DUPLICATE of bug 278123
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-20 05:16 UTC by Gérard Talbot (no longer involved)
Modified: 2012-01-20 01:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gérard Talbot (no longer involved) 2011-07-20 05:16:41 UTC
Version:           unspecified (using KDE 4.6.4) 
OS:                Linux

Investigating Konqueror Bugs, HTML/CSS problem
http://www.konqueror.org/investigatebug/#html

offers to use a doctype declaration which is going to trigger Konqueror into backward-compatible "quirks" rendering mode.

Now, by definition, backward-compatible "quirks" rendering mode is an intentional violation of standards and specifications where mainstream browsers (IE, Firefox, Safari, Chrome, Opera) rendering vary greatly. 

This is why web standards compliant rendering mode is always preferable: because the rendering is much more predictable, because the rendering is much more consistent across browsers and because the browser tries to follow the specification.

None of this happens in backward-compatible "quirks" rendering mode: the rendering simulates the bugs in IE4 and IE5. There is no official, authoritative specification of what happens or should happen in browsers when triggered into backward-compatible "quirks" rendering mode.

Basically, backward-compatible "quirks" rendering mode is a rendering mode where almost anything can happen in terms of page layout and there is no good or bad rendering, there is no correct or incorrect rendering in backward-compatible "quirks" rendering mode.

By definition, backward-compatible "quirks" rendering mode is a rendering mode that does not necessarly tries to follow web standards: in fact, it often does not and its quirks vary greatly from one browser to another. 

Also, the code section of item #6 suggests that the HTML code does not have to be valid when the first step of any testcase trying to demonstrate a bug, a problem of some sort would be to create a testcase using valid code.

Reproducible: Always

Steps to Reproduce:
Load 
http://www.konqueror.org/investigatebug/#html
and read item #6

Actual Results:  
{
The HTML does not have to be valid, however it is still recommended to use validator.w3.org (note that you can upload files there, they don't have to be online) to check the basic structure of your document. Here's an example of a minimal test case that's valid HTML:

 
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
}

Expected Results:  
{
The HTML code should be valid and you can use validator.w3.org (note that you can upload files there, they don't have to be online) to check the basic structure of your document. Here's an example of a minimal test case that's valid HTML:

 
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN">
}

Load the sample code example into a webpage and then do
View/View document informations Ctrl+I

and here, the "Rendering mode" should say "Strict".


Additional reading:
1- 
What happens in Quirks Mode?
http://www.cs.tut.fi/~jkorpela/quirks-mode.html

2-
Debugging CSS - HTML validation
"It is useless to start debugging a page when the HTML is not valid."
http://css.tests.free.fr/en/html_validation.php

Debugging CSS - CSS validation
"Once HTML is valid, we must validate the CSS as it is useless to start debugging a page when the HTML is valid but the style rules are not."
http://css.tests.free.fr/en/css_validation.php

With browsers (in particular IE8, IE9 and IE10 Platform previews) now following, complying with web standards, leniency with regards to HTML validation errors should be formally discouraged and using a best doctype declaration triggering web standards compliant rendering mode should be formally encouraged. Konqueror users and developers and bug reports will gain from this.

regards, Gérard
Comment 1 Christoph Feck 2011-07-20 16:25:13 UTC
Reported as bug 278123.
Comment 2 Gérard Talbot (no longer involved) 2012-01-20 01:31:11 UTC

*** This bug has been marked as a duplicate of bug 278123 ***