Bug 278046 - KMail freezes when replying to long messages in HTML
Summary: KMail freezes when replying to long messages in HTML
Status: REPORTED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.16.3
Platform: Ubuntu Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: efficiency, triaged
Depends on:
Blocks:
 
Reported: 2011-07-18 19:55 UTC by Ivan Tonchev
Modified: 2021-08-23 13:16 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Tonchev 2011-07-18 19:55:25 UTC
Version:           4.4.10 (using KDE 4.6.2) 
OS:                Linux

Hello everyone,

After i enabled HTML formating in Kmail composer replying to long messages has become a headache. Kmail hangs, interface is completely frozen, during which time CPU usage is high. After a period of time (depending on how long the message to which i reply is) the program recovers for a few seconds and i can type a few words then in hangs again and the cycle goes on. 

Reproducible: Always

Steps to Reproduce:
1. Enable HTML formating in Kmail's composer.
2. Exchange several emails by replying (keep quoting the original messages). Do it until the email becomes several hundred lines long.
3. As the email grows longer the responsiveness of Kmail will decrease until it becomes unusable. 


Actual Results:  
Kmail becomes unusable - frozen interface for both composer and main KMail window.

Expected Results:  
To let me type the message.

Never happened when i was writing plain text messages
Comment 1 Christophe Giboudeaux 2011-07-19 09:37:25 UTC
Please retry with Kontact 4.6.1
Comment 2 Ivan Tonchev 2011-07-20 04:15:55 UTC
(In reply to comment #1)
> Please retry with Kontact 4.6.1

I upgraded KDE to 4.6.5 but Kontact is still 4.4.10. Which version of KDE comes with Kontact 4.6.1?
Comment 3 Marcel Wiesweg 2011-10-07 17:27:14 UTC
*** Bug 283165 has been marked as a duplicate of this bug. ***
Comment 4 theodore 2016-01-14 09:56:53 UTC
I can confirm that this bug is still existent in kmail 15.12.1-1. It is really frustrating. If anyone needs some more info, please let me know.
Comment 5 theodore 2016-01-14 10:01:28 UTC
(In reply to theodore from comment #4)
> I can confirm that this bug is still existent in kmail 15.12.1-1. It is
> really frustrating. If anyone needs some more info, please let me know.

I forgot to mention that my system is archlinux with kde plasma 5.
Comment 6 Andrew Crouthamel 2018-09-25 21:40:03 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Andrew Crouthamel 2018-10-27 03:32:04 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!
Comment 8 Hadatko 2021-05-12 07:56:24 UTC
Hi, it is unbelievable that this bug is still present and not solved for such a time. 
current version kmail2 5.16.3 (20.12.3), cpu usage 100%, reproducible on kubuntu ..., 20.04, 20.10, 21.04

Messages when opening kmail:
kf.xmlgui: Index  23  is not within range (0 -  21 )
kf.xmlgui: Index  25  is not within range (0 -  21 )
kf.xmlgui: Index  27  is not within range (0 -  21 )
qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1473, resource id: 50331784, major code: 130 (Unknown), minor code: 3
qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1476, resource id: 50331784, major code: 130 (Unknown), minor code: 3
qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1479, resource id: 50331784, major code: 130 (Unknown), minor code: 3
qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1484, resource id: 50331784, major code: 130 (Unknown), minor code: 3
qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1506, resource id: 50331784, major code: 130 (Unknown), minor code: 3
qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1731, resource id: 50331784, major code: 130 (Unknown), minor code: 3
qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1767, resource id: 50331784, major code: 130 (Unknown), minor code: 3
qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1770, resource id: 50331784, major code: 130 (Unknown), minor code: 3

When replying to big message:
Opening in existing browser session.
qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 8852, resource id: 50332161, major code: 130 (Unknown), minor code: 3
qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 8888, resource id: 50332161, major code: 130 (Unknown), minor code: 3
qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 8891, resource id: 50332161, major code: 130 (Unknown), minor code: 3
 load big message 
 settings  true
org.kde.pim.messagecore: Adding image 0x561df2f61240
org.kde.pim.messagecore: Adding image 0x561df2ec2ad0
org.kde.pim.messagecore: Adding image 0x561df2d5df00
org.kde.pim.templateparser: Adding 0x561df2f61240 as an embedded image
org.kde.pim.templateparser: Adding 0x561df2ec2ad0 as an embedded image
org.kde.pim.templateparser: Adding 0x561df2d5df00 as an embedded image
Hspell: can't open /usr/share/hspell/hebrew.wgz.sizes.
kf.sonnet.clients.hspell: HSpellDict::HSpellDict: Init failed
Hspell: can't open /usr/share/hspell/hebrew.wgz.sizes.
kf.sonnet.clients.hspell: HSpellDict::HSpellDict: Init failed
Comment 9 Hadatko 2021-05-12 08:04:15 UTC
After installing(In reply to Hadatko from comment #8)
> Hi, it is unbelievable that this bug is still present and not solved for
> such a time. 
> current version kmail2 5.16.3 (20.12.3), cpu usage 100%, reproducible on
> kubuntu ..., 20.04, 20.10, 21.04
> 
> Messages when opening kmail:
> kf.xmlgui: Index  23  is not within range (0 -  21 )
> kf.xmlgui: Index  25  is not within range (0 -  21 )
> kf.xmlgui: Index  27  is not within range (0 -  21 )
> qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1473,
> resource id: 50331784, major code: 130 (Unknown), minor code: 3
> qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1476,
> resource id: 50331784, major code: 130 (Unknown), minor code: 3
> qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1479,
> resource id: 50331784, major code: 130 (Unknown), minor code: 3
> qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1484,
> resource id: 50331784, major code: 130 (Unknown), minor code: 3
> qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1506,
> resource id: 50331784, major code: 130 (Unknown), minor code: 3
> qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1731,
> resource id: 50331784, major code: 130 (Unknown), minor code: 3
> qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1767,
> resource id: 50331784, major code: 130 (Unknown), minor code: 3
> qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 1770,
> resource id: 50331784, major code: 130 (Unknown), minor code: 3
> 
> When replying to big message:
> Opening in existing browser session.
> qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 8852,
> resource id: 50332161, major code: 130 (Unknown), minor code: 3
> qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 8888,
> resource id: 50332161, major code: 130 (Unknown), minor code: 3
> qt.qpa.xcb: QXcbConnection: XCB error: 8 (BadMatch), sequence: 8891,
> resource id: 50332161, major code: 130 (Unknown), minor code: 3
>  load big message 
>  settings  true
> org.kde.pim.messagecore: Adding image 0x561df2f61240
> org.kde.pim.messagecore: Adding image 0x561df2ec2ad0
> org.kde.pim.messagecore: Adding image 0x561df2d5df00
> org.kde.pim.templateparser: Adding 0x561df2f61240 as an embedded image
> org.kde.pim.templateparser: Adding 0x561df2ec2ad0 as an embedded image
> org.kde.pim.templateparser: Adding 0x561df2d5df00 as an embedded image
> Hspell: can't open /usr/share/hspell/hebrew.wgz.sizes.
> kf.sonnet.clients.hspell: HSpellDict::HSpellDict: Init failed
> Hspell: can't open /usr/share/hspell/hebrew.wgz.sizes.
> kf.sonnet.clients.hspell: HSpellDict::HSpellDict: Init failed

After installing hspelldict. Init failed but freezing stayed.