Bug 278024 - Notifications interfere with fullscreen programs
Summary: Notifications interfere with fullscreen programs
Status: RESOLVED DUPLICATE of bug 177495
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-18 15:32 UTC by Dainius Masiliūnas
Modified: 2011-07-19 16:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dainius Masiliūnas 2011-07-18 15:32:52 UTC
Version:           2.4.1 (using KDE 4.6.0) 
OS:                Linux

Every time Amarok displays a notification, either using the OSD or KNotify, and the system is running a fullscreen program, the screen flickers for a while and the fullscreen program sometimes loses focus.

Reproducible: Always

Steps to Reproduce:
1. Enable Amarok's notification system, either OSD or KNotify.
2. Enter a fullscreen application, for example, a Flash video.
3. Change the track or wait for the current one to finish.

Actual Results:  
Depending on the fullscreen application, the screen might flicker in white or show graphics corruption for a short amount of time, sometimes followed by the fullscreen application losing focus. OSD makes this period of flickering or corruption longer than using KNotify. In the latter case, it happens only when the notification is about to disappear, never when it appears.

Expected Results:  
OSD and KNotify should be automatically disabled when a fullscreen program is being run.

Using openSUSE 11.4 with KWin compositing, graphics card ATI Radeon HD 4980 with Catalyst 11.5 drivers.
Comment 1 Myriam Schweingruber 2011-07-19 16:20:08 UTC
This is more likely a problem with the underlying graphical system, reassigning.
Comment 2 Myriam Schweingruber 2011-07-19 16:21:57 UTC
Oops, wrong element, sorry for the noise.
Comment 3 Martin Flöser 2011-07-19 16:47:43 UTC
disable unredirection of fullscreen windows in advanced compositing settings as a workaround. Will be the default in 4.7

*** This bug has been marked as a duplicate of bug 177495 ***