Bug 277879 - If I check opendesktop.org details in account details it complains about authentication
Summary: If I check opendesktop.org details in account details it complains about auth...
Status: RESOLVED DUPLICATE of bug 275033
Alias: None
Product: frameworks-attica
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal with 21 votes (vote)
Target Milestone: ---
Assignee: Frederik Gladhorn
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-16 08:32 UTC by Mark Fraser
Modified: 2011-10-27 16:12 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Fraser 2011-07-16 08:32:11 UTC
Version:           unspecified (using Devel) 
OS:                Linux

I have setup social desktop in System Settings > Account Details to work with opendesktop.org with a username and password. In KDE 4.6.4 this worked OK, but in 4.6.5 when I click on 'Test Login' it keeps telling me that:
You are about to log in to the site "api.opendesktop.org" with the username "mfraser", but the website does not require authentication. This may be an attempt to trick you.
Is "api.opendesktop.org" the site you want to visit?



Reproducible: Always

Steps to Reproduce:
Go to System Settings > Account Details and select social desktop. Enter your username and password for openDesktop.org. Click 'test login'

Actual Results:  
I get the pop up as mentioned above

Expected Results:  
It would log me in without complaining.
Comment 1 Mark Fraser 2011-07-31 08:54:10 UTC
Also opens up the "are you sure" query box when logging into "Get hot new stuff" and is still there after upgrading to KDE 4.7.00.
Comment 2 Paulo Dias 2011-09-01 14:03:09 UTC
Same problem and behaviour here, kubuntu 11.04, kde 4.7.0, having this since 4.6.5 and now in 4.7.

happens with everything thats related to opendesktop.org (social plasmoids, choqok (that acesses opendesktop).
Comment 3 Tommi Tervo 2011-10-26 13:18:25 UTC

*** This bug has been marked as a duplicate of bug 275033 ***
Comment 4 Sebastian Kügler 2011-10-26 13:44:36 UTC
It only happens once, that's acceptable IMO.
Comment 5 Mark Fraser 2011-10-27 16:12:52 UTC
It only happens once when you log in each time you log in! That isn't acceptable IMO.