Bug 277752 - Active startup starts plasma-desktop, then kills it, then starts the Active shell
Summary: Active startup starts plasma-desktop, then kills it, then starts the Active s...
Status: RESOLVED FIXED
Alias: None
Product: Active
Classification: Unclassified
Component: Plasma mobile shell (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: unscheduled
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-14 10:00 UTC by Sebastian Kügler
Modified: 2011-09-19 13:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Kügler 2011-07-14 10:00:48 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Active's startup process is very slow, one reason is that too complicated startup sequence, which essentially goes like this:

plasma-desktop ; killall plasma-desktop ; plasma-tablet -graphicssystem raster

Only the last part should be necessary, but without starting and killing plasma-desktop first, plasma-tablet has problems finding the dbus and fails to start. "Something with dbus-launch" seems to be required, but I haven't found out what this would be.



Reproducible: Didn't try

Steps to Reproduce:
log in to Plasma Active

Actual Results:  
slow because it starts plasma-desktop first

Expected Results:  
fast :)

This is done in the plasma-tablet-config and plasma-contour-config packages, in the plasma-tablet.desktop and plasma-contour.desktop files in the Exec= line.
Comment 1 Aaron J. Seigo 2011-07-14 12:27:33 UTC
Git commit 32dc24e08d54cd466e06cc41c703f68e936d207d by Aaron Seigo.
Committed on 14/07/2011 at 14:26.
Pushed by aseigo into branch 'master'.

notify that startup has completed

CCBUG:277752

M  +4    -0    shell/plasmaapp.cpp     

http://commits.kde.org/plasma-mobile/32dc24e08d54cd466e06cc41c703f68e936d207d
Comment 2 Sebastian Kügler 2011-09-19 13:03:53 UTC
Fixed looooooooong ago.