Bug 277741 - Amarok 2.4.1.90 has visual glitch at the bottom (light purple boxes)
Summary: Amarok 2.4.1.90 has visual glitch at the bottom (light purple boxes)
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.4.1.90
Platform: Gentoo Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: 2.4.2
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-14 08:34 UTC by Nikos Chantziaras
Modified: 2011-12-08 10:03 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.5


Attachments
Screenshot (188.25 KB, image/png)
2011-07-14 08:34 UTC, Nikos Chantziaras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos Chantziaras 2011-07-14 08:34:03 UTC
Created attachment 61866 [details]
Screenshot

Version:           2.4.1.90 (using Devel) 
OS:                Linux

Attaching a screenshot that shows a visual glitch at the bottom of the Amarok window (there are light purple boxes).

Reproducible: Always

Steps to Reproduce:
No steps needed

Actual Results:  
See above

Expected Results:  
See above

I'm using KDE 4.7 RC2, Qt 4.7.3, Gentoo AMD64.
Comment 1 Myriam Schweingruber 2011-07-15 07:04:36 UTC
Confirmed, the box should not overlap the browser entries.
Comment 2 Nikos Chantziaras 2011-07-15 07:11:42 UTC
(In reply to comment #1)
> Confirmed, the box should not overlap the browser entries.

Wait, you mean that box is actually intended? It look monstrous and sticks out. It really looks like a graphics glitch. Even if it wouldn't overlap the browser entries.
Comment 3 Bart Cerneels 2011-07-15 07:53:09 UTC
There is no overlap, the box is in a vertical layout. What you see as overlap is actually just the last visible entry in the browser being cut of.

I guess a shadow at the bottom of the browser can improve it.
Comment 4 Nikos Chantziaras 2011-07-15 09:15:51 UTC
Is there a way to get rid of this purple thing entirely?  To me, it really looks like a bug.  It might be intended, but it still looks like a bug.  As if someone is drawing stuff to look like graphics glitches on purpose.
Comment 5 Myriam Schweingruber 2011-07-15 13:08:49 UTC
Does your screen have a red shift? It certainly is not purple here, but somewhere between light blue and teal. Try KColorChooser and pick it to compare :)
Comment 6 Bart Cerneels 2011-12-08 10:03:56 UTC
Git commit 51819dfdaf381ab8fbfb0d790e54ad6e2610d198 by Bart Cerneels.
Committed on 25/11/2011 at 17:34.
Pushed by shanachie into branch 'master'.

Visual changes to bottom toolbars.

Changes:
- Align the dockwindow toolbars in all situations.
- Make all bottom toolbars 36 px high.
- Refactor MessageArea.
- Put a border around the bottom toolbars. Using QPalette::Shadow for border color.

BUG:277741
FIXED-IN:2.5

M  +3    -0    ChangeLog
M  +11   -9    src/browsers/BrowserDock.cpp
M  +1    -1    src/browsers/BrowserDock.h
M  +2    -0    src/browsers/BrowserMessageArea.cpp
M  +2    -1    src/context/ContextDock.cpp
M  +35   -41   src/context/ToolbarView.cpp
M  +0    -3    src/context/ToolbarView.h
M  +3    -22   src/context/toolbar/AppletToolbar.cpp
M  +0    -2    src/context/toolbar/AppletToolbar.h
M  +1    -1    src/context/toolbar/AppletToolbarBase.cpp
M  +16   -17   src/playlist/PlaylistDock.cpp
M  +1    -1    src/playlist/PlaylistDock.h
M  +1    -0    src/widgets/PrettyTreeView.cpp

http://commits.kde.org/amarok/51819dfdaf381ab8fbfb0d790e54ad6e2610d198