Bug 277654 - some messages are blank after running out of disk space
Summary: some messages are blank after running out of disk space
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 2.1.0
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-12 21:24 UTC by Ivan D Vasin
Modified: 2017-01-07 22:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan D Vasin 2011-07-12 21:24:55 UTC
Version:           2.1.0
OS:                Linux

this is with KDE 4.6.5 (not available in the dropdown).

i ran out of disk space today, which triggered about a dozen KDE bugs.  around the time that i ran out of disk space, all of the following applications became nearly or completely unresponsive: Konsole, Kopete, Kontact, and Amarok.  it took me a while to realize what was happening (about 10-15 minutes passed before i finally saw a "low disk space" notification), so i kept using some applications.  one of the bugs i noticed is described herein.

before becoming totally unresponsive, Kontact was slightly sluggish but still usable.  i viewed some messages in KMail, but some others showed up as blank.  by "blank" i mean the following:

  * the message list shows the subject, the sender, the date, and all associated status icons.

  * after clicking on the message, the preview pane shows the subject, the sender, the sender's KAddressBook icon, the recipients, and the date.

  * the body of the message is empty, even if it actually isn't (as viewed in another mail client).

  * "View --> View Source" produces a window with a single tab "Raw Source" that contains a text area with two blank lines and nothing else.

the worst part is that after i cleared up some disk space, logged out, and logged back in, the same messages still produce the same symptoms.  while this bug certainly calls for a permanent solution, i would also very much appreciate a workaround that would cause KMail to refresh the affected messages.

Reproducible: Didn't try

Steps to Reproduce:
1. run out of disk space.
2. view some messages.
3. clear some disk space.

Actual Results:  
* after running out of disk space, messages show up as blank, as described above.
* after clearing disk space, the same messages still show up as blank, as described above.

Expected Results:  
* after running out of disk space, messages show up normally, or an error message is shown indicating that low disk space is causing a problem.
* after clearing disk space, messages show up normally.

OS: Linux (x86_64) release 2.6.38-10-generic
Compiler: cc
Comment 1 Boris 2011-08-02 22:17:27 UTC
I believe I had a similar problem. Messages were being expired to a mailbox on a network drive (sshfs) that was not spectacularly reliable. At least some messages were lost (blank body) that were expired when the drive was unavailable. I've since arranged things differently, but in general I wonder whether safe arrival is checked before deletion? If not, would it be possible to do? Losing email you intend to keep can cause problems.
Comment 2 Wolfgang Rohdewald 2014-08-03 12:47:21 UTC
Looks like the same bug:

if disk is full, whenever kmail fetches pop3 mails, it generates a new local copy in incoming folder without body. So after 10 mail fetches, I have 10 copies of the same new mail without body.

It seems the transition between "mail not fetched" and "mail fetched" is unclear. A third state "headers only received" might help. Or just remove all traces of that message if it cannot be saved fully.
Comment 3 Denis Kurz 2016-09-24 18:10:26 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 4 Denis Kurz 2017-01-07 22:00:04 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.