Bug 277611 - Unicode 6.0 Devanagari characters are not shown even when they are in the font
Summary: Unicode 6.0 Devanagari characters are not shown even when they are in the font
Status: RESOLVED FIXED
Alias: None
Product: kcharselect
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Daniel Laidig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-12 11:13 UTC by Mohd Asif Ali Rizwaan
Modified: 2011-08-26 08:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.1


Attachments
Devanagari font with unicode 6.0 devanagri characters (125.34 KB, application/x-font-ttf)
2011-07-12 11:13 UTC, Mohd Asif Ali Rizwaan
Details
KCharmap doesn't display all the characters (134.22 KB, image/jpeg)
2011-07-12 11:14 UTC, Mohd Asif Ali Rizwaan
Details
gucharmap shows all the available characters; but it has a bug "no with circle with vowels/matras" in unicode 6 chars (224.01 KB, image/jpeg)
2011-07-12 11:16 UTC, Mohd Asif Ali Rizwaan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mohd Asif Ali Rizwaan 2011-07-12 11:13:38 UTC
Created attachment 61799 [details]
Devanagari font with unicode 6.0 devanagri characters

Version:           unspecified (using Devel) 
OS:                Linux

The new kashmiri, sanskrit, etc. characters which are part of unicode 6.0; are not shown in kcharselect;

Please see the Unicode 6.0 devanagari character range here:
http://www.unicode.org/charts/PDF/U0900.pdf

Reproducible: Didn't try

Steps to Reproduce:
1. install nithyananda-1.4991.ttf
2. run kcharselect
3. choose south asian scripts, devanagari, and nithyanananda-1.4991 


Actual Results:  
4. we can that many of the unicode 6.0 devanagari characters are just shown as empty boxes; please see attachment kcharselect_devanagari_characters.jpg

Expected Results:  
5. please see gucharmap_devanagari_characters.jpg (which properly shows the characters albeit with a bug of not using circle with matras)



OS: Linux (i686) release 2.6.39-ARCH
Compiler: gcc
Comment 1 Mohd Asif Ali Rizwaan 2011-07-12 11:14:42 UTC
Created attachment 61800 [details]
KCharmap doesn't display all the characters
Comment 2 Mohd Asif Ali Rizwaan 2011-07-12 11:16:08 UTC
Created attachment 61801 [details]
gucharmap shows all the available characters; but it has a bug "no with circle with vowels/matras" in unicode 6 chars
Comment 3 Christoph Feck 2011-07-15 00:15:04 UTC
Qt has no support for Unicode 6.0 yet.
Comment 4 Daniel Laidig 2011-08-25 20:05:27 UTC
Git commit 62aa40e6e07595bcda9e13b23ce0e79bfa92ae99 by Daniel Laidig.
Committed on 25/08/2011 at 21:33.
Pushed by laidig into branch 'KDE/4.7'.

add support for Unicode 6.0

in addition to updated data files the category of characters is now
stored in the data file as well. this is because the database in Qt is
quite outdated which has lead to weird bugs

BUG: 277611
FIXED-IN: 4.7.1

M  +43   -4    kdeui/widgets/kcharselectdata.cpp
M  +3    -0    kdeui/widgets/kcharselect-translation.cpp
M  +-    --    kdeui/widgets/kcharselect-data
M  +7    -7    kdeui/widgets/kcharselect.cpp
M  +2    -0    kdeui/widgets/kcharselectdata_p.h

http://commits.kde.org/kdelibs/62aa40e6e07595bcda9e13b23ce0e79bfa92ae99
Comment 5 Daniel Laidig 2011-08-25 20:08:14 UTC
as soon as you have 4.7.1, can you please check if everything is displayed correctly now?
Comment 6 Christoph Feck 2011-08-25 20:20:05 UTC
Not sure if this commit makes it to KDE 4.7.1, because kdelibs already has the 4.7.1 tag since yesterday.
Comment 7 Daniel Laidig 2011-08-26 08:17:09 UTC
Git commit a21ef9d6f56fbdb32524c32240f3767ffd34b6ea by Daniel Laidig.
Committed on 25/08/2011 at 21:33.
Pushed by laidig into branch 'frameworks'.

add support for Unicode 6.0

in addition to updated data files the category of characters is now
stored in the data file as well. this is because the database in Qt is
quite outdated which has lead to weird bugs

CCBUG: 277611
(cherry picked from commit 62aa40e6e07595bcda9e13b23ce0e79bfa92ae99)

M  +43   -4    kdeui/widgets/kcharselectdata.cpp
M  +3    -0    kdeui/widgets/kcharselect-translation.cpp
M  +-    --    kdeui/widgets/kcharselect-data
M  +7    -7    kdeui/widgets/kcharselect.cpp
M  +2    -0    kdeui/widgets/kcharselectdata_p.h

http://commits.kde.org/kdelibs/a21ef9d6f56fbdb32524c32240f3767ffd34b6ea