Bug 277594 - Knotify crash
Summary: Knotify crash
Status: RESOLVED DUPLICATE of bug 259269
Alias: None
Product: phonon-backend-vlc
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-12 03:23 UTC by HelixiR
Modified: 2011-07-26 10:54 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description HelixiR 2011-07-12 03:23:10 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.6.95 (4.7 RC2) "release 1"
Qt Version: 4.7.3
Operating System: Linux 2.6.39-2-default i686
Distribution: "openSUSE 12.1 Milestone 2 (i586)"

-- Information about the crash:
Knotify crash when show error about VLC Phonon Backend

The crash can be reproduced some of the time.

-- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb530f710 (LWP 4879))]

Thread 2 (Thread 0xb38f3b70 (LWP 4880)):
#0  0xb5ad2b2d in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0xb605b0b4 in pthread_mutex_lock () from /lib/libc.so.6
#2  0xb5971c3b in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#3  0xb5972860 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb5972b9a in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb6376277 in QEventDispatcherGlib::processEvents (this=0x817b1b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6346dcd in QEventLoop::processEvents (this=0xb38f32b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6347011 in QEventLoop::exec (this=0xb38f32b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6249d8b in QThread::exec (this=0x815f0e0) at thread/qthread.cpp:492
#9  0xb632797d in QInotifyFileSystemWatcherEngine::run (this=0x815f0e0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb624cc43 in QThreadPrivate::start (arg=0x815f0e0) at thread/qthread_unix.cpp:320
#11 0xb5ad0be7 in start_thread () from /lib/libpthread.so.0
#12 0xb604d5be in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb530f710 (LWP 4879)):
[KCrash Handler]
#7  0xb2d3ccac in module_list_get (n=0x0) at modules/modules.c:357
#8  0xb394e9de in libvlc_audio_output_list_get (p_instance=0x0) at control/audio.c:72
#9  0xb398eda6 in Phonon::VLC::DeviceManager::updateDeviceList (this=0x81b83f8) at /usr/src/debug/phonon-vlc-0.4.55.git.1310111781/src/devicemanager.cpp:188
#10 0xb3983bc0 in Phonon::VLC::Backend::Backend (this=0x8197f98, parent=0x0) at /usr/src/debug/phonon-vlc-0.4.55.git.1310111781/src/backend.cpp:110
#11 0xb398404b in qt_plugin_instance () at /usr/src/debug/phonon-vlc-0.4.55.git.1310111781/src/backend.cpp:59
#12 0xb632da46 in QPluginLoader::instance (this=0xbfae27b0) at plugin/qpluginloader.cpp:204
#13 0xb3c2a50c in Phonon::KdePlatformPlugin::createBackend (this=0x8153498, newService=...) at /usr/src/debug/kde-runtime-4.6.95/phonon/platform_kde/kdeplatformplugin.cpp:149
#14 0xb3c2b128 in Phonon::KdePlatformPlugin::createBackend (this=0x8153498) at /usr/src/debug/kde-runtime-4.6.95/phonon/platform_kde/kdeplatformplugin.cpp:202
#15 0xb737608e in Phonon::FactoryPrivate::createBackend (this=0x8210a48) at /usr/src/debug/phonon-4.5.0/phonon/factory.cpp:119
#16 0xb7376a5b in Phonon::Factory::backend (createWhenNull=true) at /usr/src/debug/phonon-4.5.0/phonon/factory.cpp:460
#17 0xb7376e68 in Phonon::Factory::createAudioOutput (parent=0x8246028) at /usr/src/debug/phonon-4.5.0/phonon/factory.cpp:356
#18 0xb736ec2b in createBackendObject (this=0x8259748) at /usr/src/debug/phonon-4.5.0/phonon/audiooutput.cpp:134
#19 Phonon::AudioOutputPrivate::createBackendObject (this=0x8259748) at /usr/src/debug/phonon-4.5.0/phonon/audiooutput.cpp:129
#20 0xb736ba2c in Phonon::AudioOutputPrivate::init (this=0x8259748, c=Phonon::NotificationCategory) at /usr/src/debug/phonon-4.5.0/phonon/audiooutput.cpp:107
#21 0x08054f04 in Player (this=0x819dae8) at /usr/src/debug/kde-runtime-4.6.95/knotify/notifybysound.cpp:58
#22 PlayerPool::getPlayer (this=0x815932c) at /usr/src/debug/kde-runtime-4.6.95/knotify/notifybysound.cpp:98
#23 0x08055393 in notify (config=0x81f5908, eventId=618, this=0x80bb060) at /usr/src/debug/kde-runtime-4.6.95/knotify/notifybysound.cpp:242
#24 NotifyBySound::notify (this=0x80bb060, eventId=618, config=0x81f5908) at /usr/src/debug/kde-runtime-4.6.95/knotify/notifybysound.cpp:197
#25 0x08051ed1 in KNotify::emitEvent (this=0xbfae38b8, e=0x81f5900) at /usr/src/debug/kde-runtime-4.6.95/knotify/knotify.cpp:230
#26 0x08052d5c in KNotify::event (this=0xbfae38b8, event=..., appname=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=0) at /usr/src/debug/kde-runtime-4.6.95/knotify/knotify.cpp:149
#27 0x0805326a in KNotifyAdaptor::event (this=0x815f190, event=..., fromApp=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=0) at /usr/src/debug/kde-runtime-4.6.95/knotify/knotify.cpp:289
#28 0x0805371a in KNotifyAdaptor::qt_metacall (this=0x815f190, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfae2f2c) at /usr/src/debug/kde-runtime-4.6.95/build/knotify/knotify.moc:227
#29 0xb649fe60 in QDBusConnectionPrivate::deliverCall (this=0x8089e08, object=0x815f190, msg=..., metaTypes=..., slotIdx=0) at qdbusintegrator.cpp:941
#30 0xb64a1130 in QDBusConnectionPrivate::activateCall (this=0x8089e08, object=0x815f190, flags=273, msg=...) at qdbusintegrator.cpp:851
#31 0xb64a19c4 in QDBusConnectionPrivate::activateObject (this=0x8089e08, node=..., msg=..., pathStartPos=-1079103360) at qdbusintegrator.cpp:1429
#32 0xb64a1be8 in QDBusActivateObjectEvent::placeMetaCall (this=0x81b17c8) at qdbusintegrator.cpp:1523
#33 0xb636017f in QObject::event (this=0xbfae38b8, e=0x81b17c8) at kernel/qobject.cpp:1217
#34 0xb690eb84 in notify_helper (e=0x81b17c8, receiver=0xbfae38b8, this=0x8098538) at kernel/qapplication.cpp:4462
#35 QApplicationPrivate::notify_helper (this=0x8098538, receiver=0xbfae38b8, e=0x81b17c8) at kernel/qapplication.cpp:4434
#36 0xb6913f12 in QApplication::notify (this=0x81b17c8, receiver=0xbfae38b8, e=0x81b17c8) at kernel/qapplication.cpp:4209
#37 0xb75adf61 in KApplication::notify (this=0xbfae38cc, receiver=0xbfae38b8, event=0x81b17c8) at /usr/src/debug/kdelibs-4.6.95/kdeui/kernel/kapplication.cpp:311
#38 0xb6347dae in QCoreApplication::notifyInternal (this=0xbfae38cc, receiver=0xbfae38b8, event=0x81b17c8) at kernel/qcoreapplication.cpp:731
#39 0xb634b508 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:215
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8075568) at kernel/qcoreapplication.cpp:1372
#41 0xb634b6cc in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#42 0xb6375de4 in sendPostedEvents () at kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=0x8093eb8) at kernel/qeventdispatcher_glib.cpp:277
#44 0xb59721cf in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#45 0xb5972900 in ?? () from /usr/lib/libglib-2.0.so.0
#46 0xb5972b9a in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#47 0xb6376217 in QEventDispatcherGlib::processEvents (this=0x8090778, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#48 0xb69c21fa in QGuiEventDispatcherGlib::processEvents (this=0x8090778, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#49 0xb6346dcd in QEventLoop::processEvents (this=0xbfae3814, flags=...) at kernel/qeventloop.cpp:149
#50 0xb6347011 in QEventLoop::exec (this=0xbfae3814, flags=...) at kernel/qeventloop.cpp:201
#51 0xb634b77a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#52 0xb690c9e4 in QApplication::exec () at kernel/qapplication.cpp:3736
#53 0x0804ff5a in main (argc=1, argv=0x8215928) at /usr/src/debug/kde-runtime-4.6.95/knotify/main.cpp:73

This bug may be a duplicate of or related to bug 201767.

Possible duplicates by query: bug 232467.

Reported using DrKonqi
Comment 1 Harald Sitter 2011-07-26 10:54:52 UTC

*** This bug has been marked as a duplicate of bug 259269 ***