Bug 277494 - kded crash
Summary: kded crash
Status: RESOLVED DUPLICATE of bug 275450
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-10 19:02 UTC by Tore Anderson
Modified: 2011-07-10 19:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tore Anderson 2011-07-10 19:02:04 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.6.3 (4.6.3)
Qt Version: 4.7.3
Operating System: Linux 2.6.38.8-32.fc15.x86_64 x86_64
Distribution: "Fedora release 15 (Lovelock)"

-- Information about the crash:
- What I was doing when the application crashed:

I was away from the computer. It had Firefox running, and was attempting to connect to the network.

-- Backtrace:
Application: KDE Daemon (kded4), signal: Aborted
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f9c62d42840 (LWP 2222))]

Thread 2 (Thread 0x7f9c4f2cf700 (LWP 2268)):
#0  0x00000036724d7293 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003674442d24 in g_main_context_poll (n_fds=3, fds=0x7f9c48001110, priority=<optimized out>, timeout=-1, context=0x233bfe0) at gmain.c:3405
#2  g_main_context_iterate (context=0x233bfe0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3087
#3  0x000000367444360d in g_main_loop_run (loop=0x233bfc0) at gmain.c:3300
#4  0x000000367a4b4564 in gdbus_shared_thread_func (data=<optimized out>) at gdbusprivate.c:276
#5  0x00000036744683a6 in g_thread_create_proxy (data=0x233c0d0) at gthread.c:1955
#6  0x0000003672807af1 in start_thread (arg=0x7f9c4f2cf700) at pthread_create.c:305
#7  0x00000036724dfb7d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f9c62d42840 (LWP 2222)):
[KCrash Handler]
#6  0x00000036724352d5 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x0000003672436beb in __GI_abort () at abort.c:93
#8  0x000000367444b5ee in g_logv (log_domain=0x36744adc06 "GLib", log_level=<optimized out>, format=0x36744b41c8 "Cannot create pipe main loop wake-up: %s\n", args1=0x7fff41f7ed88) at gmessages.c:557
#9  0x000000367444b682 in g_log (log_domain=<optimized out>, log_level=<optimized out>, format=<optimized out>) at gmessages.c:577
#10 0x000000367443f101 in g_main_context_init_pipe (context=0x222f130) at gmain.c:530
#11 0x000000367443f5e8 in g_main_context_init_pipe (context=0x222f130) at gmain.c:520
#12 g_main_context_new () at gmain.c:626
#13 0x0000003683608463 in call_sync_new () at polkitauthority.c:591
#14 0x000000368360a885 in polkit_authority_check_authorization_sync (authority=0x22a1c40 [PolkitAuthority], subject=0x7f9c48005400, action_id=0x2218fc8 "org.kde.powerdevil.backlighthelper.brightness", details=0x0, flags=POLKIT_CHECK_AUTHORIZATION_FLAGS_NONE, cancellable=0x0, error=0x7fff41f7ef68) at polkitauthority.c:1019
#15 0x00007f9c4f2ddfd3 in PolkitQt1::Authority::checkAuthorizationSync (this=0x232d800, actionId=<optimized out>, subject=..., flags=<optimized out>) at /usr/src/debug/polkit-qt-1-0.99.0/core/polkitqt1-authority.cpp:327
#16 0x00007f9c4f4edcaf in KAuth::Polkit1Backend::actionStatus (this=<optimized out>, action=<optimized out>) at /usr/src/debug/kdelibs-4.6.3/kdecore/auth/backends/polkit-1/Polkit1Backend.cpp:149
#17 0x00007f9c4f4ee080 in KAuth::Polkit1Backend::setupAction (this=0x22c35c0, action=...) at /usr/src/debug/kdelibs-4.6.3/kdecore/auth/backends/polkit-1/Polkit1Backend.cpp:142
#18 0x00007f9c56c87036 in PowerDevilUPowerBackend::brightness (this=0x22ccc10, type=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.3/powerdevil/daemon/backends/upower/powerdevilupowerbackend.cpp:189
#19 0x00007f9c56a6f193 in PowerDevil::BundledActions::DimDisplay::onIdleTimeout (this=0x23c1480, msec=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.3/powerdevil/daemon/actions/bundled/dimdisplay.cpp:59
#20 0x00007f9c56a5a2a0 in PowerDevil::Core::onKIdleTimeoutReached (this=0x22d48a0, identifier=2, msec=300000) at /usr/src/debug/kdebase-workspace-4.6.3/powerdevil/daemon/powerdevilcore.cpp:545
#21 0x00007f9c56a5efc5 in PowerDevil::Core::qt_metacall (this=0x22d48a0, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0x7fff41f7f430) at /usr/src/debug/kdebase-workspace-4.6.3/x86_64-redhat-linux-gnu/powerdevil/daemon/powerdevilcore.moc:174
#22 0x000000345c56ceba in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#23 0x000000346a20697f in KIdleTime::timeoutReached (this=<optimized out>, _t1=2, _t2=300000) at /usr/src/debug/kdelibs-4.6.3/x86_64-redhat-linux-gnu/kutils/kidletime.moc:124
#24 0x000000346a206e12 in KIdleTimePrivate::_k_timeoutReached (this=<optimized out>, msec=300000) at /usr/src/debug/kdelibs-4.6.3/kutils/kidletime/kidletime.cpp:243
#25 0x000000346a2073f0 in KIdleTime::qt_metacall (this=0x2304480, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0x7fff41f7f5d0) at /usr/src/debug/kdelibs-4.6.3/x86_64-redhat-linux-gnu/kutils/kidletime.moc:99
#26 0x000000345c56ceba in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#27 0x000000346a207b31 in AbstractSystemPoller::timeoutReached (this=<optimized out>, _t1=300000) at /usr/src/debug/kdelibs-4.6.3/x86_64-redhat-linux-gnu/kutils/abstractsystempoller.moc:115
#28 0x000000346a20a793 in x11Event (event=0x7fff41f7fbe0, this=0x2353ae0) at /usr/src/debug/kdelibs-4.6.3/kutils/kidletime/xsyncbasedpoller.cpp:235
#29 XSyncBasedPoller::x11Event (this=0x2353ae0, event=0x7fff41f7fbe0) at /usr/src/debug/kdelibs-4.6.3/kutils/kidletime/xsyncbasedpoller.cpp:218
#30 0x000000346124471e in publicx11Event (e=0x7fff41f7fbe0, this=<optimized out>) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:918
#31 KApplication::x11EventFilter (this=<optimized out>, _event=0x7fff41f7fbe0) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:969
#32 0x000000345de25575 in ?? () from /usr/lib64/libQtGui.so.4
#33 0x000000345de323f8 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
#34 0x000000345de5a2ec in ?? () from /usr/lib64/libQtGui.so.4
#35 0x00000036744427ed in g_main_dispatch (context=0x21c3de0) at gmain.c:2441
#36 g_main_context_dispatch (context=0x21c3de0) at gmain.c:3014
#37 0x0000003674442fc8 in g_main_context_iterate (context=0x21c3de0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3092
#38 0x000000367444325c in g_main_context_iteration (context=0x21c3de0, may_block=1) at gmain.c:3155
#39 0x000000345c584d0f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#40 0x000000345de59fde in ?? () from /usr/lib64/libQtGui.so.4
#41 0x000000345c5596c2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#42 0x000000345c5598bf in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#43 0x000000345c55da07 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#44 0x000000345f208a95 in kdemain (argc=1, argv=0x7fff41f803f8) at /usr/src/debug/kdelibs-4.6.3/kded/kded.cpp:925
#45 0x000000367242139d in __libc_start_main (main=0x400710 <main(int, char**)>, argc=1, ubp_av=0x7fff41f803f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff41f803e8) at libc-start.c:226
#46 0x0000000000400741 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2011-07-10 19:28:35 UTC

*** This bug has been marked as a duplicate of bug 275450 ***