Bug 277454 - new messages in ignored thread sometimes not marked as ignored
Summary: new messages in ignored thread sometimes not marked as ignored
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 2.0.95
Platform: Gentoo Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-10 07:20 UTC by Stefano Crocco
Modified: 2016-10-12 08:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefano Crocco 2011-07-10 07:20:29 UTC
Version:           2.0.95
OS:                Linux

If there's a thread marked as ignored, when I download new mail, any new messages belonging to it should be marked as ignored as well. Usually this happens. Sometimes, however, the new messages, while being correctly inserted in the thread, are not marked as ignored. When this happens, the thread seems to loose its "ignored" status, since any message later added to it aren't marked as ignored. When this happens, I have to toggle the "ignored" status on the thread twice to get it back to the current status: the first time, the thread becomes "not ignored", the second time it becomes correctly "ignored" again

Reproducible: Sometimes

Steps to Reproduce:
Mark a thread as ignored, then download new mail containing messages which belong to the ignored thread

Actual Results:  
Sometimes, the new messages in the thread are not marked as ignored

Expected Results:  
The new messages in the thread should be marked as ignored
Comment 1 Graeme Hewson 2012-05-15 11:25:34 UTC
I confirm this in 4.8.2.
Comment 2 Graeme Hewson 2012-10-19 11:57:05 UTC
And I confirm in 4.9.2.

Seems to be load-related. While upgrading from Kubuntu 12.04 to 12.10 just now, with Kontact still running, I had many more messages than usual not marked as ignored in previously ignored threads. The disk drive was being used heavily.
Comment 3 Graeme Hewson 2013-03-08 17:00:49 UTC
Still happening in 4.10.1.
Comment 4 Graeme Hewson 2014-01-08 06:50:14 UTC
Frequency of occurrence is much reduced in recent releases. However, following a kernel crash several new messages in ignored threads were not marked as ignored. Using Kmail 4.12 and POP3. I'm wondering if the problem only happens now after a kernel crash.
Comment 5 Graeme Hewson 2014-05-23 12:06:19 UTC
Problem occurred in 4.13.

(No kernel crash involved, so my comment 4 is not relevant.)
Comment 6 Denis Kurz 2016-09-24 18:10:04 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 7 Graeme Hewson 2016-10-04 10:31:00 UTC
I'm not currently experiencing the problem in 5.1.3.
Comment 8 Denis Kurz 2016-10-12 08:56:28 UTC
Thanks for reporting back, Greame