Bug 277451 - Ramdom crash after sleeping
Summary: Ramdom crash after sleeping
Status: RESOLVED FIXED
Alias: None
Product: solid
Classification: Unclassified
Component: bluetooth-daemon (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Alex Fiestas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-10 06:41 UTC by Alejandro Diaz Caro
Modified: 2011-07-16 17:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro Diaz Caro 2011-07-10 06:41:29 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.3
Operating System: Linux 2.6.39-ck i686
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:
Weak up my laptop by opening the lid.
- Unusual behavior I noticed:
KDE-plasma uses to crash at that moment also (however not both, kded4 and kde-plasma, at the same time)

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Dæmon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb57d9b60 (LWP 1236))]

Thread 3 (Thread 0xb0326b70 (LWP 1237)):
#0  0xb612e4b0 in ?? () from /lib/libc.so.6
#1  0xb6115d37 in poll () from /lib/libc.so.6
#2  0xb5bb7e6b in g_poll () from /usr/lib/libglib-2.0.so.0
#3  0xb5ba92b6 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb5ba9aeb in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#5  0xb0561ae1 in ?? () from /usr/lib/libgio-2.0.so.0
#6  0xb5bd02e4 in ?? () from /usr/lib/libglib-2.0.so.0
#7  0xb6d2fc77 in start_thread () from /lib/libpthread.so.0
#8  0xb612043e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xac96ab70 (LWP 1252)):
#0  0xb7818424 in __kernel_vsyscall ()
#1  0xb6115d4e in poll () from /lib/libc.so.6
#2  0xb5bb7e6b in g_poll () from /usr/lib/libglib-2.0.so.0
#3  0xb5ba92b6 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb5ba96da in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb6ece4a7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6e9f1fd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb6e9f441 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb6da2abb in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0xb6e7fd9d in ?? () from /usr/lib/libQtCore.so.4
#10 0xb6da5913 in ?? () from /usr/lib/libQtCore.so.4
#11 0xb6d2fc77 in start_thread () from /lib/libpthread.so.0
#12 0xb612043e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb57d9b60 (LWP 1236)):
[KCrash Handler]
#7  0xb6ec1a5b in QVariant::QVariant(QVariant const&) () from /usr/lib/libQtCore.so.4
#8  0xb5d78285 in QDBusPendingReplyData::argumentAt(int) const () from /usr/lib/libQtDBus.so.4
#9  0xad2944aa in BlueDevilDaemon::isServiceStarted() () from /usr/lib/kde4/kded_bluedevil.so
#10 0xad2947ee in BlueDevilDaemon::offlineMode() () from /usr/lib/kde4/kded_bluedevil.so
#11 0xad2954f2 in BlueDevilDaemon::defaultAdapterChanged(BlueDevil::Adapter*) () from /usr/lib/kde4/kded_bluedevil.so
#12 0xad2937e9 in BlueDevilDaemon::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/kded_bluedevil.so
#13 0xb6ea65ad in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#14 0xb6eb535a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#15 0xad2436c3 in BlueDevil::Manager::defaultAdapterChanged(BlueDevil::Adapter*) () from /usr/lib/libbluedevil.so.1
#16 0xad244cf3 in BlueDevil::Manager::Private::_k_adapterRemoved(QDBusObjectPath const&) () from /usr/lib/libbluedevil.so.1
#17 0xad247b78 in BlueDevil::Manager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libbluedevil.so.1
#18 0xb6ea65ad in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#19 0xb6eb535a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#20 0xad25d023 in OrgBluezManagerInterface::AdapterRemoved(QDBusObjectPath const&) () from /usr/lib/libbluedevil.so.1
#21 0xad25d69a in OrgBluezManagerInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libbluedevil.so.1
#22 0xb5d37b35 in ?? () from /usr/lib/libQtDBus.so.4
#23 0xb5d42056 in ?? () from /usr/lib/libQtDBus.so.4
#24 0xb6eb8442 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#25 0xb63d1084 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#26 0xb63d6433 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#27 0xb75af321 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#28 0xb6ea01be in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#29 0xb6ea39a3 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#30 0xb6ea3afc in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#31 0xb6ece014 in ?? () from /usr/lib/libQtCore.so.4
#32 0xb5ba8c4f in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0xb5ba93b0 in ?? () from /usr/lib/libglib-2.0.so.0
#34 0xb5ba96da in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0xb6ece44a in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#36 0xb64846ba in ?? () from /usr/lib/libQtGui.so.4
#37 0xb6e9f1fd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#38 0xb6e9f441 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0xb6ea3bad in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#40 0xb63ceed4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#41 0xb5331609 in kdemain () from /usr/lib/libkdeinit4_kded4.so
#42 0x0804f24a in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2011-07-10 10:53:29 UTC
Thanks for the bug report! Looks like it's related to BlueDevil.
Comment 2 Alex Fiestas 2011-07-10 14:57:15 UTC
I'm testing a fix locally, if it works well I will commit it and release it with the incoming 1.0.5 and 1.1.1 versions.

Thanks!
Comment 3 Alejandro Diaz Caro 2011-07-11 08:13:30 UTC
Thanks for answering that fast!

If you need any test from my part, please do not hesitate to ask.
Comment 4 Alex Fiestas 2011-07-16 14:36:42 UTC
Are you able to compile your own bluedevil?
Comment 5 Alex Fiestas 2011-07-16 15:47:43 UTC
Git commit b769654963f41775b475b658019580fbc59825fa by Alex Fiestas.
Committed on 16/07/2011 at 16:57.
Pushed by afiestas into branch '1.1'.

Don't assume that bluedevil-helper is responding our dbus requests

If the helper doesn't answer, just return false

BUG: 277451
FIX-IN: 1.1.1
FIX-IN: 1.0.5

M  +6    -1    src/daemon/kded/BlueDevilDaemon.cpp

http://commits.kde.org/bluedevil/b769654963f41775b475b658019580fbc59825fa
Comment 6 Alex Fiestas 2011-07-16 15:48:44 UTC
Git commit eac4bc99e72312f7e54ee941f20359daa0f01138 by Alex Fiestas.
Committed on 16/07/2011 at 16:57.
Pushed by afiestas into branch '1.0'.

Don't assume that bluedevil-helper is responding our dbus requests

If the helper doesn't answer, just return false

BUG: 277451
FIX-IN: 1.1.1
FIX-IN: 1.0.5
(cherry picked from commit b769654963f41775b475b658019580fbc59825fa)

M  +6    -1    src/daemon/kded/BlueDevilDaemon.cpp

http://commits.kde.org/bluedevil/eac4bc99e72312f7e54ee941f20359daa0f01138
Comment 7 Alejandro Diaz Caro 2011-07-16 17:40:46 UTC
> Are you able to compile your own bluedevil?

No problem. I can do it, however I see you already commit the fix. Do you still need I compile it and provide any information or it is enough with the commit you just did?