Bug 277020 - Numbers doesn't work in kcalc
Summary: Numbers doesn't work in kcalc
Status: RESOLVED FIXED
Alias: None
Product: kcalc
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Evan Teran
URL:
Keywords:
: 277358 277616 277673 277700 277916 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-03 17:32 UTC by Ojec Borec
Modified: 2015-04-21 09:19 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ojec Borec 2011-07-03 17:32:08 UTC
Version:           4.7 (using Devel) 
OS:                Linux

Hi

When I start kcalc and want to type numbers on keyboard, nothing happens.

Reproducible: Didn't try

Steps to Reproduce:
Start kcalc and type any number on keyboard.

Actual Results:  
Nothing happens.

Expected Results:  
Number 1 should appears if I press key 1.
Comment 1 Christoph Feck 2011-07-04 01:53:39 UTC
Is the window active? Do you use the numeric keypad on the keyboard? If yes, is Num Lock activated on the keyboard?
Comment 2 Ojec Borec 2011-07-04 07:23:41 UTC
Window is active. Num Lock is activated. I also tried keys above q,w,e,r,t,y,... keys without success.
Comment 3 Simonas 2011-07-05 17:33:03 UTC
I can confirm exactly same issue is happening here in 4.7 rc1.
Comment 4 Evan Teran 2011-07-06 18:18:31 UTC
I can confirm this too, I have no idea what happened. I'll have to check what has happened in previous commits :-/
Comment 5 Evan Teran 2011-07-06 18:20:29 UTC
I am guessing it is this commit:


------------------------------------------------------------------------
r1235446 | rkcosta | 2011-06-05 14:25:18 -0400 (Sun, 05 Jun 2011) | 8 lines

Make the 0..9 buttons untranslatable.

I don't think any language actually translates them, but it doesn't
hurt, given the issues we faced in the related bug.

CCBUG: 256591
Comment 6 Evan Teran 2011-07-06 18:26:43 UTC
confirmed, that commit broke the key bindings. I am going to roll it back. We still need to figure out the German translation issue with the number 2, but at least the key bindings will work no worse than before. I will apply the rollback on 4.7 and trunk.
Comment 7 Evan Teran 2011-07-06 18:27:38 UTC
SVN commit 1240129 by teran:

rolling back change made by r1235446, it broke keybindings entirely.

BUG: 277020



 M  +10 -10    kcalc.ui  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1240129
Comment 8 Evan Teran 2011-07-06 18:27:59 UTC
SVN commit 1240130 by teran:

rolling back change made by r1235446, it broke keybindings entirely.

BUG: 277020



 M  +10 -10    kcalc.ui  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1240130
Comment 9 Raphael Kubo da Costa 2011-07-06 18:29:53 UTC
Can you add a comment to bug 256591 mentioning this as well?
Comment 10 Burkhard Lück 2011-07-08 14:00:07 UTC
*** Bug 277358 has been marked as a duplicate of this bug. ***
Comment 11 Ojec Borec 2011-07-11 14:00:05 UTC
I've got version 4.6.95 and I'm able to enter digits via keyboard.
Comment 12 Raphael Kubo da Costa 2011-07-11 14:07:27 UTC
4.6.95 was tagged after r1240129, so the fix is already present.
Comment 13 Raphael Kubo da Costa 2011-07-11 14:08:10 UTC
... or you are just confirming the fix is present :-)
Comment 14 Ojec Borec 2011-07-11 14:39:37 UTC
It is a commit.
Comment 15 Ojec Borec 2011-07-11 15:11:29 UTC
Sorry, confirmation. Everything works as expected. :-)
Comment 16 Christoph Feck 2011-07-12 13:33:18 UTC
*** Bug 277616 has been marked as a duplicate of this bug. ***
Comment 17 Christoph Feck 2011-07-13 11:49:27 UTC
*** Bug 277673 has been marked as a duplicate of this bug. ***
Comment 18 Fabio Bas 2011-07-13 15:18:33 UTC
*** Bug 277700 has been marked as a duplicate of this bug. ***
Comment 19 Evan Teran 2011-07-17 01:30:39 UTC
*** Bug 277916 has been marked as a duplicate of this bug. ***
Comment 20 vanboxem.ruben 2015-04-21 09:02:59 UTC
I cannot get the numpad keys to register. I have verified that the ones above my (azerty) keys work, but regardless the numlock state kcalc won't register the numpad keys. My keyboard works fine in other applications as expected. Version: 2.13 on Arch Linux. Can this be reopened or should I report a new bug?
Comment 21 Christoph Feck 2015-04-21 09:19:30 UTC
See bug 344638.