Bug 276996 - Gradinent has discrete lines on Chihuahua style background for MediaWiki (TechBase and UserBase).
Summary: Gradinent has discrete lines on Chihuahua style background for MediaWiki (Tec...
Status: RESOLVED FIXED
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-03 11:52 UTC by Nikita Skovoroda
Modified: 2012-08-08 15:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The lines. (135.37 KB, image/png)
2011-07-03 11:52 UTC, Nikita Skovoroda
Details
Bad gradient demo. (987 bytes, image/png)
2011-07-06 14:51 UTC, Nikita Skovoroda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Skovoroda 2011-07-03 11:52:13 UTC
Version:           unspecified
OS:                Linux

The gradient in background image is discrete. It has thick lines of the same color, followed by lines of different color, that is clearly distinguishable from the first one. And so on.

Reproducible: Always

Steps to Reproduce:
Open http://techbase.kde.org/ or http://userbase.kde.org main page. Look at the background right side, near the letter «n» in the big word «information».

Actual Results:  
I can see the lines, they are distinguishable.

Expected Results:  
The lines should be indistinguishable, the gradient should be smooth.

Dell U2211H, xf86-video-ati, default settings.
Comment 1 Nikita Skovoroda 2011-07-03 11:52:45 UTC
Created attachment 61572 [details]
The lines.
Comment 2 Eugene Trounev 2011-07-05 13:49:54 UTC
This is not a bug, but unfortunately a JPEG artifact. There is no way to remove it, unless the background is removed and replaced with a single color. Converting to any other format is not an option as well, since JPEG is by far the least in file size. An equivalent PNG would easily go over a few MB in size, which is unacceptable.
Comment 3 Nikita Skovoroda 2011-07-06 14:47:40 UTC
That does not look like jpeg artifact. But if it is, it is still possible to play with compression level.

Jpeg artifacts generally produce squares. But this looks like just gradinent with wide stripes.

The stripes are caused by the fact that the colors are limited (see attached image, the colors are as close as they could be), and the gradient just can't be smooth because of that (it is wider than the number of colors between the start color and the end color). 

Tere are different techniques to avoid such lines when making gradinents, like so: http://groundice.com/notes/gradient.php (russian, but just looking at the images should be enough).

The first two images are the example of the problem (1-st is with slighly raised contrast, the second with largely raised contrast).

The third one it dithering workaround (not so good).

Next images show noise+blur workaround (the better one, but still not ideal).
Comment 4 Nikita Skovoroda 2011-07-06 14:51:38 UTC
Created attachment 61644 [details]
Bad gradient demo.

This gradient is striped as a result of limited colors.

No artifacts, just simple 900px wide „gradient“ from #808080 to #858585, producing 6 stripes each 150 px wide.

The stripes are visible for human eye.
Comment 5 Eugene Trounev 2011-07-06 15:10:35 UTC
I speak, read, and write Russian very well :) I am also well acquainted with different diffusion techniques. Problem here however is that we are not dealing with a simple gradient, we are dealing with a gradient in a webpage background, where the file size is a paramount. Any sort of diffusion I could choose will greatly reduce the efficiency of JPEG compression based on similarities in tint and luminosity (and that's where those broken gradient stripes come from - they are of the same luminosity and therefore get extrapolated).
The background is 1597 × 1053 in physical size and that's a LOT of pixel mass. At this size with given compression it is a whooping 105KB in size. Making it any sharper will jump the file size up to 300KB and over which is unacceptable for a webpage background.
Hope this answers your questions.
Comment 6 Nikita Skovoroda 2012-08-08 15:02:36 UTC
The default theme was changed to Neverland.