Bug 276911 - bluedevil PIN never appears when adding device
Summary: bluedevil PIN never appears when adding device
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: bluetooth (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR normal
Target Milestone: ---
Assignee: Alex Fiestas
Depends on:
Reported: 2011-07-01 19:24 UTC by Marc Haber
Modified: 2015-11-13 04:03 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Marc Haber 2011-07-01 19:24:11 UTC
Version:           4.6 (using KDE 4.6.4) 
OS:                Linux

When trying to pair a bluetooth device (here: a keyboard), the Bluetooth Device Wizard seems to hang at the "Please introduce the PIN in your keyboard when it appears and press enter" stage. The PIN never appears, it sits there with a spinner in the part of the window where the PIN used to appear in earlier versions.

I have also noticed that a scan for new devices just never finishes. One can select a device to pair while the scan is still running, but it'll never stop saying "Scanning..."

Reproducible: Always

Steps to Reproduce:
Left click on bluetooth symbol in system tray. Select "add device". Select "Bluetoth Keyboard" and select "Next".

Actual Results:  
"Please introduce the PIN in your keyboard when it appears and press enter" with a spinner above.

Expected Results:  
A PIN that I could enter on the bluetooth keyboard to actually finish the pairing.

Kernel is, but this has been broken for a while. hcitool scan will see the keyboard just fine, so I believe that the hardware is OK, and the kernel drivers are working in order as well.

If somebody explains to me how to manually pair the keyboard with command line tools, I can try finding out whether this is a bluedevil or a driver issue.
Comment 1 Alex Fiestas 2011-07-16 14:36:12 UTC

Can you provide:
1-BlueDevil version (check your distribution package)
2-the terminal output of bluedevil-wizard

Comment 2 Alex Fiestas 2011-07-16 15:34:20 UTC
*be sure to enable all bluedevil things in kdebugdialog
Comment 3 Philip Allen 2011-08-12 17:57:23 UTC
I have the same problem; and when I run bluedevil-wizard from the console, I eventually get a message in the console saying: Error response:  "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 

KDE Platform Version 4.6.5 (4.6.5)
Comment 4 Philip Allen 2011-08-12 18:17:02 UTC
For the avoidance of doubt I should confirm that my device is a keyboard.  When I try to pair with a phone it works perfectly.
Comment 5 Alex Fiestas 2011-09-18 02:09:20 UTC
Maybe I'm pointing the obvious but, is your keyboard accepting connections?
Comment 6 Alex Fiestas 2011-10-08 13:32:43 UTC
Also, is your keyboard a Microsoft elite?
Comment 7 Philip Allen 2011-11-01 19:01:47 UTC
To answer the second question first, it's an Apple Wireless Keyboard (104 key model).  It has new batteries and was turned on - I'm not sure there's anything I can do to demonstrate that it's accepting connections.
Comment 8 Philip Allen 2011-11-01 19:26:38 UTC
I have tested the keyboard by booting into the Apple partition.  It works fine.  Under kde it recognises the keyboard but gives the screen output as described in the Description above.
Comment 9 Alex Fiestas 2012-04-28 01:40:45 UTC
Git commit d402a834efe994f74fe8feb64e2dee02b4fa9a92 by Alex Fiestas.
Committed on 28/04/2012 at 03:36.
Pushed by afiestas into branch '1.1'.

If the device is a Keyboard, move to the keyboard page.

Thanks to rbelem for lettimg me steal his bt keyboard at UDS xD

M  +6    -5    src/wizard/pages/discoverpage.cpp

Comment 10 accountlostin 2015-01-16 21:24:22 UTC
this does not seem to be resolved. same problem as in the original bug report.
(happens with the 'Microsoft Wedge Mobile Keyboard 7C:1E:52:1A:07:DE).
Comment 12 marnell 2015-07-26 04:59:55 UTC
I am having the same issues with a Logitech K810. Same exact symptoms on a fresh install of OpenSUSE 13.2 w/ KDE 4.14.9. This does not appear to be fixed.
Comment 13 marnell 2015-07-26 05:06:57 UTC
I should note that this same keyboard+bluetooth+system combination works just fine OOTB with Gnome. All I have to do to make it work is open a parallel session in Gnome, and use the Gnome bluetooth setup to complete pairing.
Comment 14 Gerald Hofer 2015-11-13 04:03:10 UTC
I just ran into the same issue when I tried to connect a bluetooth keyboard to KDE/OpenSuse 13.2. 

The device gets discovered without issues correctly, but the password is never displayed in the KDE GUI.

I connected a HCI sniffer to the data stream (hcidump -at) and found that the keyboard is correctly sending back the password. I was able to find the passkey in the data stream:

2015-11-13 13:14:36.823350 > HCI Event: User Passkey Notification (0x3b) plen 10
    bdaddr 28:18:78:FA:13:03 passkey 235802

I then typed in the passkey 235802 on the keyboard and the keyboard then connected without problems to the KDE session.

So the problem is really in KDE that does not show the passkey that gets sent back to the user. All the logic works as expected. The HCI sniffer is the workaround for everyone who finds this bug.