Bug 276894 - Crash on very long artist names [@ Meta::SqlArtist::SqlArtist]
Summary: Crash on very long artist names [@ Meta::SqlArtist::SqlArtist]
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/Local (show other bugs)
Version: 2.6-git
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.8
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-01 15:18 UTC by Myriam Schweingruber
Modified: 2013-03-18 11:26 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.8


Attachments
New crash information added by DrKonqi (49.95 KB, text/plain)
2011-07-11 12:23 UTC, Myriam Schweingruber
Details
File generated on crash (357.89 KB, application/xml)
2011-07-11 12:28 UTC, Myriam Schweingruber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Myriam Schweingruber 2011-07-01 15:18:33 UTC
Version:           2.4-GIT (using KDE 4.6.4) 
OS:                Linux

Application: Amarok (amarok), signal: Aborted
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S
[Current thread is 1 (Thread 0x7ff91aa1e7a0 (LWP 12649))]

...

Thread 12 (Thread 0x7ff8e5197700 (LWP 12662)):
[KCrash Handler]
#6  0x00007ff917425d05 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007ff917429ab6 in abort () at abort.c:92
#8  0x00007ff917d0cad4 in qt_message_output (msgType=<value optimized out>, buf=<value optimized out>) at global/qglobal.cpp:2282
#9  0x00007ff917d0cc8f in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x7ff917e5c0a8 "ASSERT: \"%s\" in file %s, line %d", ap=0x7ff8e5196160) at global/qglobal.cpp:2328
#10 0x00007ff917d0ce31 in qFatal (msg=<value optimized out>) at global/qglobal.cpp:2511
#11 0x00007ff8eaf4e304 in Meta::SqlArtist::SqlArtist (this=0x7ff8ca7ddde0, collection=0x1c641d0, id=0, name=...) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlMeta.cpp:1374
#12 0x00007ff8eaf2f1d2 in SqlRegistry::getArtist (this=0x1c62e20, name=...) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlRegistry.cpp:370
#13 0x00007ff8eaf308d0 in SqlRegistry::getAlbum (this=0x1c62e20, name=..., artist=...) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlRegistry.cpp:591
#14 0x00007ff8eaf10d03 in Collections::SqlCollection::getAlbum (this=0x1c641d0, album=..., artist=...) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlCollection.cpp:379
#15 0x00007ff8eaf58f7d in SqlScanResultProcessor::commitAlbum (this=0x7ff8f24b3310, album=0x7ff8c95a9490) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlScanResultProcessor.cpp:116
#16 0x00007ff8eaf0b34e in ScanResultProcessor::commit (this=0x7ff8f24b3310) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/ScanResultProcessor.cpp:166
#17 0x00007ff8eaf58d57 in SqlScanResultProcessor::commit (this=0x7ff8f24b3310) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlScanResultProcessor.cpp:79
#18 0x00007ff8eaf0566f in ScannerJob::run (this=0x5bebaa0) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/ScanManager.cpp:593
#19 0x00007ff915282c21 in ThreadWeaver::JobRunHelper::runTheJob (this=0x7ff8e5196d80, th=0x29fbac0, job=0x5bebaa0) at ../../../threadweaver/Weaver/Job.cpp:106
#20 0x00007ff915282d4c in ThreadWeaver::Job::execute (this=0x5bebaa0, th=0x29fbac0) at ../../../threadweaver/Weaver/Job.cpp:135
#21 0x00007ff91528250f in ThreadWeaver::ThreadRunHelper::run (this=0x7ff8e5196e00, parent=0x2a1c5f0, th=0x29fbac0) at ../../../threadweaver/Weaver/Thread.cpp:95
#22 0x00007ff9152825cb in ThreadWeaver::Thread::run (this=0x29fbac0) at ../../../threadweaver/Weaver/Thread.cpp:142
#23 0x00007ff917d16175 in QThreadPrivate::start (arg=0x29fbac0) at thread/qthread_unix.cpp:320
#24 0x00007ff913ce4d8c in start_thread (arg=0x7ff8e5197700) at pthread_create.c:304
#25 0x00007ff9174d804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#26 0x0000000000000000 in ?? ()

... 

Thread 1 (Thread 0x7ff91aa1e7a0 (LWP 12649)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ff917d1682b in wait (this=<value optimized out>, mutex=0x1c73b00, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1c73b00, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ff917d15910 in QThread::wait (this=<value optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:722
#4  0x00007ff917dd25d0 in QFileSystemWatcher::~QFileSystemWatcher (this=0x1c332f0, __in_chrg=<value optimized out>) at io/qfilesystemwatcher.cpp:446
#5  0x00007ff917dd26a9 in QFileSystemWatcher::~QFileSystemWatcher (this=0x1c332f0, __in_chrg=<value optimized out>) at io/qfilesystemwatcher.cpp:462
#6  0x00007ff917e0fc14 in QObjectPrivate::deleteChildren (this=0x1c736d0) at kernel/qobject.cpp:1964
#7  0x00007ff917e145f4 in QObject::~QObject (this=0x1c332c0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#8  0x00007ff915535799 in Solid::Backends::Fstab::FstabWatcher::~FstabWatcher (this=0x1c332c0, __in_chrg=<value optimized out>) at ../../../solid/solid/backends/fstab/fstabwatcher.cpp:51
#9  0x00007ff91742b961 in __run_exit_handlers (status=1) at exit.c:78
#10 exit (status=1) at exit.c:100
#11 0x00007ff918828fb8 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:781
#12 0x00007ff91a44b4e8 in KApplication::xioErrhandler (this=0x7ffff5970bf0, dpy=0x1443bc0) at ../../kdeui/kernel/kapplication.cpp:419
#13 0x00007ff9192e6dee in _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#14 0x00007ff9192e462d in _XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#15 0x00007ff9192d4f1f in XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#16 0x00007ff91886632c in x11EventSourceCheck (s=0x1422300) at kernel/qguieventdispatcher_glib.cpp:85
#17 0x00007ff911193854 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007ff911194122 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007ff911194639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007ff917e28446 in QEventDispatcherGlib::processEvents (this=0x12734c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#21 0x00007ff9188664de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#22 0x00007ff917dfc882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#23 0x00007ff917dfcabc in QEventLoop::exec (this=0x7ffff5970b70, flags=...) at kernel/qeventloop.cpp:201
#24 0x00007ff917e00ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#25 0x000000000040c9ae in main (argc=3, argv=0x7ffff59731e8) at /home/myriam/kde/src/amarok/src/main.cpp:289


Reproducible: Didn't try

Steps to Reproduce:
Listening to a playlist made of downloaded podcast episodes. The crash happened at the end of an episode.

Actual Results:  
Crashes on track change.

Expected Results:  
...
Comment 1 Myriam Schweingruber 2011-07-11 12:23:58 UTC
Created attachment 61776 [details]
New crash information added by DrKonqi

amarok (2.4-GIT) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.2

I happens whn trying to rescan the db, the console output produces this:

It happens when it rescans the db, this is the console output:

amarok:       BEGIN: virtual BookmarkTriangle::~BookmarkTriangle() 
QCoreApplication::postEvent: Unexpected null receiver
amarok:       END__: virtual BookmarkTriangle::~BookmarkTriangle() [Took: 0s] 
amarok:       BEGIN: virtual BookmarkTriangle::~BookmarkTriangle() 
QCoreApplication::postEvent: Unexpected null receiver
amarok:       END__: virtual BookmarkTriangle::~BookmarkTriangle() [Took: 0s] 
amarok:       BEGIN: TimecodeLoadCapabilityPodcastImpl::TimecodeLoadCapabilityPodcastImpl(Podcasts::PodcastEpisode*) 
amarok:         episode:  "Kritik am MSC-Fischlabel" 
amarok:       END__: TimecodeLoadCapabilityPodcastImpl::TimecodeLoadCapabilityPodcastImpl(Podcasts::PodcastEpisode*) [Took: 0s] 
amarok:       BEGIN: virtual BookmarkList TimecodeLoadCapabilityPodcastImpl::loadTimecodes() 
amarok:         argument:  "pos=239.465"  unescaped:  "239.465" 
amarok:         argument:  "pos=240.143"  unescaped:  "240.143" 
amarok:       END__: virtual BookmarkList TimecodeLoadCapabilityPodcastImpl::loadTimecodes() [Took: 0.01s] 
amarok:       [MainToolbar] showing timecode:  "Kritik am MSC-Fischlabel - 3:59"  at  239465 
amarok:       BEGIN: void Amarok::TimeSlider::drawTriangle(const QString&, int, bool) 
amarok:         drawing triangle at  109 
amarok:       END__: void Amarok::TimeSlider::drawTriangle(const QString&, int, bool) [Took: 0s] 
amarok:       [MainToolbar] showing timecode:  "Kritik am MSC-Fischlabel - Stopped 01.07.2011"  at  240143 
amarok:       BEGIN: void Amarok::TimeSlider::drawTriangle(const QString&, int, bool) 
amarok:         drawing triangle at  109 
amarok:       END__: void Amarok::TimeSlider::drawTriangle(const QString&, int, bool) [Took: 0s] 
amarok:       BEGIN: virtual BookmarkViewItem::~BookmarkViewItem() 
amarok:       END__: virtual BookmarkViewItem::~BookmarkViewItem() [Took: 0s] 
amarok:       BEGIN: virtual BookmarkViewItem::~BookmarkViewItem() 
amarok:       END__: virtual BookmarkViewItem::~BookmarkViewItem() [Took: 0s] 
amarok:     END__: void EngineController::slotTrackLengthChanged(qint64) [Took: 0.024s] 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/People Under The Stairs/The Om Years (Disc 1)/07_-_Youth Explosion.mp3" with uid "amarok-sqltrackuid://6e3ae009a9cb127c0f75894a012883e6" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Skunk Anansi/Skunk Anansie - Stoosh/11-Glorious Pop Song.mp3" with uid "amarok-sqltrackuid://9f3d8d10e0088c1b9f17358a58931694" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Skunk Anansi/Skunk Anansie - Stoosh/10-Milk Is My Sugar.mp3" with uid "amarok-sqltrackuid://ab0ab4a908eb9e23eee05db32e27bbb4" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Skunk Anansi/Skunk Anansie - Stoosh/09-Pickin On Me.mp3" with uid "amarok-sqltrackuid://b353a49a6a060c345fea1ac541037168" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Skunk Anansi/Skunk Anansie - Stoosh/08-Brazen (Weep).mp3" with uid "amarok-sqltrackuid://e4fd90e4c54290cbe1155457d2624d62" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Skunk Anansi/Skunk Anansie - Stoosh/07-We Love Your Apathy.mp3" with uid "amarok-sqltrackuid://11c4a444dbf467a4a1aca83f87d9e6c7" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Skunk Anansi/Skunk Anansie - Stoosh/06-Twisted (Everyday Hurts).mp3" with uid "amarok-sqltrackuid://adfd082f1e9a594f7d1727b51e6315e4" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Skunk Anansi/Skunk Anansie - Stoosh/05-Hedonism (Just Because You Feel Good).mp3" with uid "amarok-sqltrackuid://8e4b958aaa849a4322f934e454453150" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Skunk Anansi/Skunk Anansie - Stoosh/04-Infidelity (Only You).mp3" with uid "amarok-sqltrackuid://a6bfc30972d834b71bd80776cf8e8754" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Skunk Anansi/Skunk Anansie - Stoosh/03-She's My Heroine.mp3" with uid "amarok-sqltrackuid://5502a7074ed07d0c9f27f366e2003f64" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Skunk Anansi/Skunk Anansie - Stoosh/02-All I Want.mp3" with uid "amarok-sqltrackuid://aa39d5c68756f4528bf660d63bd84e50" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Skunk Anansi/Skunk Anansie - Stoosh/01-Yes It's Fucking Political.mp3" with uid "amarok-sqltrackuid://5cbbba179d14ee7cfd87225db674da36" already committed. There seems to be a duplicate uid. 
amarok:     SCRIPT "SkypeMood" :  "Checking for metadata changes "Schweizer Radio DRS" ; "Kritik am MSC-Fischlabel" ; "Wissenschaft DRS 2"" 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Solists/Jascha Heifetz/The Heifetz Collection/Vol 03 1934-1937/The Heifetz Collection Vol 3 CD2/09 - Bach- Sonata No. 3, BWV 1005 in C Adagio.flac" with uid "amarok-sqltrackuid://1f4fa7b99485717cc756be535ace507f" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Solists/Jascha Heifetz/The Heifetz Collection/Vol 03 1934-1937/The Heifetz Collection Vol 3 CD2/08 - -- Presto.flac" with uid "amarok-sqltrackuid://da849e4c8af8b1d2621d64b5c5f7a153" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Solists/Jascha Heifetz/The Heifetz Collection/Vol 03 1934-1937/The Heifetz Collection Vol 3 CD2/07 - -- Siciliano.flac" with uid "amarok-sqltrackuid://7be71d857196f186b1e1fd9386f06aef" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Solists/Jascha Heifetz/The Heifetz Collection/Vol 03 1934-1937/The Heifetz Collection Vol 3 CD2/06 - -- Fugue Allegro.flac" with uid "amarok-sqltrackuid://a18603e63a474d35a0341f87dbcd37d8" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Solists/Jascha Heifetz/The Heifetz Collection/Vol 03 1934-1937/The Heifetz Collection Vol 3 CD2/05 - Bach- Sonata No. 1, BWV 1001 in G minor Adagio.flac" with uid "amarok-sqltrackuid://4f6f1860f08041db2ac06f314b3d7437" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Solists/Jascha Heifetz/The Heifetz Collection/Vol 03 1934-1937/The Heifetz Collection Vol 3 CD2/04 - de Falla- Danza espanola No. 1.flac" with uid "amarok-sqltrackuid://f4fa851886feda545b901f412d0e799e" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Solists/Jascha Heifetz/The Heifetz Collection/Vol 03 1934-1937/The Heifetz Collection Vol 3 CD2/03 - -- Air et Danse negre.flac" with uid "amarok-sqltrackuid://89181713627bcd5b8a103a4a674fbb2b" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Solists/Jascha Heifetz/The Heifetz Collection/Vol 03 1934-1937/The Heifetz Collection Vol 3 CD2/02 - -- After Sundown.flac" with uid "amarok-sqltrackuid://c560f26301ff3d215f6c378328ec6599" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Solists/Jascha Heifetz/The Heifetz Collection/Vol 03 1934-1937/The Heifetz Collection Vol 3 CD2/01 - Scott- Tallahassee Suite Bygone Memories.flac" with uid "amarok-sqltrackuid://b406d2ac9c840bfb651312f09712d801" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Beethoven/Symphonies 7 & 8/Chicago Symphony Orchestra/Beethoven Symphonies 7 & 8/02_-_Symphony No.7 in A Major Op.92 - II. Allegretto.ogg" with uid "amarok-sqltrackuid://189a7a2b2fa5f5dfbf008e8d025723c7" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Elgar/Elgar Violin Concerto - Kennedy/03 - Elgar - Violin Concerto in B minor Op. 61- 3. Allegro molto.ogg" with uid "amarok-sqltrackuid://b4ee853fd80b5b1bd88d83f8dc0e50ed" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Elgar/Elgar Violin Concerto - Kennedy/02 - Elgar - Violin Concerto in B minor Op. 61- 2. Andante.ogg" with uid "amarok-sqltrackuid://1e7d9f46c4ee5d011d617d4a68ac9d33" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Elgar/Elgar Violin Concerto - Kennedy/01 - Elgar - Violin Concerto in B minor Op. 61- 1. Allegro.ogg" with uid "amarok-sqltrackuid://200bc0764589fe36af51e96b4c53f76d" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/10_-_No 3 in G Major, BWV1048.flac" with uid "amarok-sqltrackuid://aa5ecdb0e248dcab2369e8b6f71f030d" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/09_-_No 6 in B Flat Major, BWV1051.flac" with uid "amarok-sqltrackuid://3e972341c9762e50c034fa61e12cb328" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/09_-_No 3 in G Major, BWV1048.flac" with uid "amarok-sqltrackuid://70eff3e6ab375434a68d75219bb5c7aa" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/08_-_No 6 in B Flat Major, BWV1051.flac" with uid "amarok-sqltrackuid://b37690d904fa1aeb33d3bd6eddd491bb" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/08_-_No 3 in G Major, BWV1048.flac" with uid "amarok-sqltrackuid://2d9c14fa8572591bf714e9ccdbc614dd" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/07_-_No 6 in B Flat Major, BWV1051.flac" with uid "amarok-sqltrackuid://5f84a2fe0be64ecf5e1778c559607c9d" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/07_-_No 2 in F Major, BWV1047.flac" with uid "amarok-sqltrackuid://ab240d304c7c046d49e1ea4812fe6c53" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/06_-_No 5 in D Major, BWV1050.flac" with uid "amarok-sqltrackuid://8c98c975bba274f1041dde0302f5e493" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/06_-_No 2 in F Major, BWV1047.flac" with uid "amarok-sqltrackuid://fce9a1099d496851a968d2c8acf1536b" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/05_-_No 5 in D Major, BWV1050.flac" with uid "amarok-sqltrackuid://a702933ac772388fc893d7da273ef11b" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/05_-_No 2 in F Major, BWV1047.flac" with uid "amarok-sqltrackuid://2d614c88e0160acbeecb356c066be921" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/04_-_No 5 in D Major, BWV1050.flac" with uid "amarok-sqltrackuid://2cd785a0c97e569f5141202b65f2f8cb" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/04_-_No 1 in F Major, BWV 1046.flac" with uid "amarok-sqltrackuid://18029df8969dd0d89731ef792f0717e6" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/03_-_No 4 in G Major, BWV1049.flac" with uid "amarok-sqltrackuid://a65c68f65d3344c680513d1acd17c43f" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/03_-_No 1 in F Major, BWV 1046.flac" with uid "amarok-sqltrackuid://616044851757ffe43d0389fed3b3fec6" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/02_-_No 4 in G Major, BWV1049.flac" with uid "amarok-sqltrackuid://652234bc908dc29bca0f3b9780835c72" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/02_-_No 1 in F Major, BWV 1046.flac" with uid "amarok-sqltrackuid://ed184c3c61c873bda6b012468ab7b61d" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/01_-_No 4 in G Major, BWV1049.flac" with uid "amarok-sqltrackuid://9541fae0f19832da6ac0c0f90770c6eb" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Bach - The Brandenburg Concertos - Goodman, Brandenburg Consort - 1991/The Brandenburg Concertos/01_-_No 1 in F Major, BWV 1046.flac" with uid "amarok-sqltrackuid://cdc3b1618b6916f757be021d58c51c0a" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Kevin MacLeod/Wikimedia/_-_Danse Macabre (computer generated).mp3" with uid "amarok-sqltrackuid://140ff1b87a0fd1b4351a920cf06d78cb" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Silbermond/German Top100 Single Charts/_-_Unendlich.mp3" with uid "amarok-sqltrackuid://878174e1522921154ab0420d2dabfb76" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Various/08_cmere.mp3" with uid "amarok-sqltrackuid://70d196ed34df92ff5f281c4aa71217ed" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Clannad/The Ultimate Collection/12 - Clannad - Robin (The Hooded Man).ogg" with uid "amarok-sqltrackuid://c146444da05ca2b6de061a735c34ad05" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Brandenburg Concertos/06_-_Concerto No.2 in F major, BWV1047 I , Allegro.flac" with uid "amarok-sqltrackuid://f16c40eed520c07c38d7d6bbe73c006e" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Brandenburg Concertos/05_-_Concerto No.1 in F major, BWV1046 V , Polacca Trio II.flac" with uid "amarok-sqltrackuid://13e1a0ff04e2e4c15ed9a4315ca21b85" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Brandenburg Concertos/04_-_Concerto No.1 in F major, BWV1046 IV , Menuetto Trio I.flac" with uid "amarok-sqltrackuid://96ba9cb56df3ed385cea4d78feae55df" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/Classical/Composers/Bach/Brandenburg Concertos/03_-_Concerto No.1 in F major, BWV1046 III , Allegro.flac" with uid "amarok-sqltrackuid://58f350a6ed92a10de2efc1ca566e7a65" already committed. There seems to be a duplicate uid. 
amarok:     BEGIN: void EngineController::slotTrackLengthChanged(qint64) 
amarok:       BEGIN: void ProgressWidget::redrawBookmarks(const QString*) 
amarok:         BEGIN: virtual BookmarkTriangle::~BookmarkTriangle() 
QCoreApplication::postEvent: Unexpected null receiver
amarok:         END__: virtual BookmarkTriangle::~BookmarkTriangle() [Took: 0s] 
amarok:         BEGIN: virtual BookmarkTriangle::~BookmarkTriangle() 
QCoreApplication::postEvent: Unexpected null receiver
amarok:         END__: virtual BookmarkTriangle::~BookmarkTriangle() [Took: 0s] 
amarok:         BEGIN: TimecodeLoadCapabilityPodcastImpl::TimecodeLoadCapabilityPodcastImpl(Podcasts::PodcastEpisode*) 
amarok:           episode:  "Kritik am MSC-Fischlabel" 
amarok:         END__: TimecodeLoadCapabilityPodcastImpl::TimecodeLoadCapabilityPodcastImpl(Podcasts::PodcastEpisode*) [Took: 0s] 
amarok:         BEGIN: virtual BookmarkList TimecodeLoadCapabilityPodcastImpl::loadTimecodes() 
amarok:           argument:  "pos=239.465"  unescaped:  "239.465" 
amarok:           argument:  "pos=240.143"  unescaped:  "240.143" 
amarok:         END__: virtual BookmarkList TimecodeLoadCapabilityPodcastImpl::loadTimecodes() [Took: 0.002s] 
amarok:         found  2  timecodes on this track 
amarok:         showing timecode:  "Kritik am MSC-Fischlabel - 3:59"  at  239465 
amarok:         BEGIN: void ProgressWidget::addBookmark(const QString&, int, bool) 
amarok:           BEGIN: void Amarok::TimeSlider::drawTriangle(const QString&, int, bool) 
amarok:             drawing triangle at  46 
amarok:           END__: void Amarok::TimeSlider::drawTriangle(const QString&, int, bool) [Took: 0s] 
amarok:         END__: void ProgressWidget::addBookmark(const QString&, int, bool) [Took: 0s] 
amarok:         showing timecode:  "Kritik am MSC-Fischlabel - Stopped 01.07.2011"  at  240143 
amarok:         BEGIN: void ProgressWidget::addBookmark(const QString&, int, bool) 
amarok:           BEGIN: void Amarok::TimeSlider::drawTriangle(const QString&, int, bool) 
amarok:             drawing triangle at  47 
amarok:           END__: void Amarok::TimeSlider::drawTriangle(const QString&, int, bool) [Took: 0s] 
amarok:         END__: void ProgressWidget::addBookmark(const QString&, int, bool) [Took: 0s] 
amarok:         BEGIN: virtual BookmarkViewItem::~BookmarkViewItem() 
amarok:         END__: virtual BookmarkViewItem::~BookmarkViewItem() [Took: 0s] 
amarok:         BEGIN: virtual BookmarkViewItem::~BookmarkViewItem() 
amarok:         END__: virtual BookmarkViewItem::~BookmarkViewItem() [Took: 0s] 
amarok:       END__: void ProgressWidget::redrawBookmarks(const QString*) [Took: 0.004s] 
amarok:       BEGIN: virtual BookmarkTriangle::~BookmarkTriangle() 
QCoreApplication::postEvent: Unexpected null receiver
amarok:       END__: virtual BookmarkTriangle::~BookmarkTriangle() [Took: 0s] 
amarok:       BEGIN: virtual BookmarkTriangle::~BookmarkTriangle() 
QCoreApplication::postEvent: Unexpected null receiver
amarok:       END__: virtual BookmarkTriangle::~BookmarkTriangle() [Took: 0s] 
amarok:       BEGIN: TimecodeLoadCapabilityPodcastImpl::TimecodeLoadCapabilityPodcastImpl(Podcasts::PodcastEpisode*) 
amarok:         episode:  "Kritik am MSC-Fischlabel" 
amarok:       END__: TimecodeLoadCapabilityPodcastImpl::TimecodeLoadCapabilityPodcastImpl(Podcasts::PodcastEpisode*) [Took: 0.002s] 
amarok:       BEGIN: virtual BookmarkList TimecodeLoadCapabilityPodcastImpl::loadTimecodes() 
amarok:         argument:  "pos=239.465"  unescaped:  "239.465" 
amarok:         argument:  "pos=240.143"  unescaped:  "240.143" 
amarok:       END__: virtual BookmarkList TimecodeLoadCapabilityPodcastImpl::loadTimecodes() [Took: 0.01s] 
amarok:       [MainToolbar] showing timecode:  "Kritik am MSC-Fischlabel - 3:59"  at  239465 
amarok:       BEGIN: void Amarok::TimeSlider::drawTriangle(const QString&, int, bool) 
amarok:         drawing triangle at  109 
amarok:       END__: void Amarok::TimeSlider::drawTriangle(const QString&, int, bool) [Took: 0s] 
amarok:       [MainToolbar] showing timecode:  "Kritik am MSC-Fischlabel - Stopped 01.07.2011"  at  240143 
amarok:       BEGIN: void Amarok::TimeSlider::drawTriangle(const QString&, int, bool) 
amarok:         drawing triangle at  109 
amarok:       END__: void Amarok::TimeSlider::drawTriangle(const QString&, int, bool) [Took: 0s] 
amarok:       BEGIN: virtual BookmarkViewItem::~BookmarkViewItem() 
amarok:       END__: virtual BookmarkViewItem::~BookmarkViewItem() [Took: 0s] 
amarok:       BEGIN: virtual BookmarkViewItem::~BookmarkViewItem() 
amarok:       END__: virtual BookmarkViewItem::~BookmarkViewItem() [Took: 0s] 
amarok:     END__: void EngineController::slotTrackLengthChanged(qint64) [Took: 0.031s] 
amarok:     [WARNING] [SqlScanResultProcessor] track "/home/myriam/Music/06. The Rock Show.mp3" with uid "amarok-sqltrackuid://74a7045bbb4e7d853ce4ea97085f65a6" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/media/Elements3/Music/James Last/James Last - Best Of Polka Party - 01 - Trompeten-Muckl.mp3" with uid "amarok-sqltrackuid://8f5a6d0652ee7d2a99b882b8f1907d19" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/home/myriam/Music/Xandria/Kill The Sun/10_-_Calyx Virago.mp3" with uid "amarok-sqltrackuid://d908f7c536c1eab913bc475142f9b94c" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/home/myriam/Music/Xandria/Kill The Sun/09_-_Isis-Osiris.mp3" with uid "amarok-sqltrackuid://0c2eb8cb3292f01a72f48327ae3d9e90" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/home/myriam/Music/Xandria/Kill The Sun/08_-_Wisdom.mp3" with uid "amarok-sqltrackuid://1167ee1b430b4ff34ac4ef60a1bafca0" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/home/myriam/Music/Xandria/Kill The Sun/07_-_So You Disappear.mp3" with uid "amarok-sqltrackuid://b2831c775a7f904980f2016f2e9a8d30" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/home/myriam/Music/Xandria/Kill The Sun/06_-_Casablanca.mp3" with uid "amarok-sqltrackuid://3604cb087059c9e2af912ab77b9bf55e" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/home/myriam/Music/Xandria/Kill The Sun/05_-_Forever Yours.mp3" with uid "amarok-sqltrackuid://3c5e7af8f35ea6de59a0cb8a65145ec4" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/home/myriam/Music/Xandria/Kill The Sun/04_-_She's Nirvana.mp3" with uid "amarok-sqltrackuid://06906431c51a1d9187ac70a77061039b" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/home/myriam/Music/Xandria/Kill The Sun/03_-_Ginger.mp3" with uid "amarok-sqltrackuid://d70809ae42cb2c62126e94061a406227" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/home/myriam/Music/Xandria/Kill The Sun/02_-_Mermaids.mp3" with uid "amarok-sqltrackuid://278810e49c9441cf691b694026e9e375" already committed. There seems to be a duplicate uid. 
amarok:     [WARNING] [SqlScanResultProcessor] track "/home/myriam/Music/Xandria/Kill The Sun/01_-_Kill The Sun.mp3" with uid "amarok-sqltrackuid://8797fc400997e9ddbc7063984a44c773" already committed. There seems to be a duplicate uid. 
amarok:     [ERROR__] [MySqlStorage] "GREPME MySQLe query failed! (1062) Duplicate entry 'Veryveryveryveryveryveryveryveryveryveryveryveryveryveryveryvery' for key 'artists_name' on INSERT INTO artists( name ) VALUES ('VeryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryBigArtistName');" 
ASSERT: "m_id > 0" in file /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlMeta.cpp, line 1374
QSocketNotifier: Invalid socket 5 and type 'Read', disabling...
amarok: Fatal IO error: client killed
amarok: BEGIN: virtual LabelsEngine::~LabelsEngine() 
amarok: END__: virtual LabelsEngine::~LabelsEngine() [Took: 0s] 
amarok: BEGIN: virtual ContextObserver::~ContextObserver() 
amarok: BEGIN: void ContextSubject::detach(ContextObserver*) 
amarok: END__: void ContextSubject::detach(ContextObserver*) [Took: 0s] 
amarok: END__: virtual ContextObserver::~ContextObserver() [Took: 0.001s] 
QSocketNotifier: Invalid socket 33 and type 'Read', disabling...
KCrash: Application 'amarok' crashing...


I also noticed that it starts writing files named "amarokcollectionscanner_batchscan.xml_" to $HOME/.kde/share/apps/amarok/ on every crash. I will attach the last of these

-- Backtrace (Reduced):
#11 0x00007f2f556b6884 in Meta::SqlArtist::SqlArtist (this=0x7f2f476269f0, collection=0x2b156f0, id=0, name=...) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlMeta.cpp:1374
#12 0x00007f2f55697752 in SqlRegistry::getArtist (this=0x2b256c0, name=...) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlRegistry.cpp:370
#13 0x00007f2f55698e50 in SqlRegistry::getAlbum (this=0x2b256c0, name=..., artist=...) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlRegistry.cpp:591
#14 0x00007f2f5567bc43 in Collections::SqlCollection::getAlbum (this=0x2b156f0, album=..., artist=...) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlCollection.cpp:379
#15 0x00007f2f556c13d1 in SqlScanResultProcessor::commitAlbum (this=0x7f2f448df450, album=0x7f2f299e1e60) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlScanResultProcessor.cpp:116
Comment 2 Myriam Schweingruber 2011-07-11 12:28:10 UTC
Created attachment 61778 [details]
File generated on crash

Each crash produces a new file
Comment 3 Ralf Engels 2011-07-11 12:40:41 UTC
What is that for an artist?

Veryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryveryver

That might explain the crash. Could be the same problem that we had with the UIDs. A limited length in the database but our duplicate check does not verify that before writing to the database.

Is this a release_blocker?
Comment 4 Myriam Schweingruber 2011-07-14 13:51:38 UTC
It was indeed the test file, it should not have been in the folders to scan in the first place, my bad and sorry for the noise.
Comment 5 Ralf Engels 2011-07-16 09:34:55 UTC
Git commit e2f25ea9e4cffac3ed5c753b00890a8cd86cdaac by Ralf Engels.
Committed on 16/07/2011 at 10:10.
Pushed by rengels into branch 'master'.

Crash on track change when listening to downloaded podcasts

BUG:276894

M  +1    -0    ChangeLog
M  +8    -5    utilities/collectionscanner/Track.cpp

http://commits.kde.org/amarok/e2f25ea9e4cffac3ed5c753b00890a8cd86cdaac
Comment 6 Myriam Schweingruber 2012-01-25 09:23:10 UTC
BTW, this still crashes on very long filenames, should I reopen the report?

BT below:


ASSERT: "m_id > 0" in file /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlMeta.cpp, line 1374

Program received signal SIGABRT, Aborted.
[Switching to Thread 0x7fff91262700 (LWP 10081)]
0x00007ffff4bb73a5 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64      ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
        in ../nptl/sysdeps/unix/sysv/linux/raise.c
(gdb) bt
#0  0x00007ffff4bb73a5 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00007ffff4bbab0b in __GI_abort () at abort.c:92
#2  0x00007ffff54b943b in qt_message_output (msgType=<optimized out>, 
    buf=0x7fffa3cbb178 "ASSERT: \"m_id > 0\" in file /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlMeta.cpp, line 1374") at global/qglobal.cpp:2315
#3  0x00007ffff54b97ef in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (
    msgType=QtFatalMsg, msg=0x7ffff5608a58 "ASSERT: \"%s\" in file %s, line %d", ap=0x7fff91261178)
    at global/qglobal.cpp:2361
#4  0x00007ffff54b9994 in qFatal (msg=<optimized out>) at global/qglobal.cpp:2544
#5  0x00007fffa463e0af in Meta::SqlArtist::SqlArtist (this=0x7fffa3ce5650, collection=0xcff5f0, id=0, 
    name=...) at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlMeta.cpp:1374
#6  0x00007fffa461f1aa in SqlRegistry::getArtist (this=0xd0f170, name=...)
    at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlRegistry.cpp:370
#7  0x00007fffa4620876 in SqlRegistry::getAlbum (this=0xd0f170, name=..., artist=...)
    at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlRegistry.cpp:590
#8  0x00007fffa46038d6 in Collections::SqlCollection::getAlbum (this=0xcff5f0, album=..., artist=...)
    at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlCollection.cpp:398
#9  0x00007fffa4648b1b in SqlScanResultProcessor::commitAlbum (this=0x7fff8c9fd010, album=0x7fff34104a10)
    at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlScanResultProcessor.cpp:116
#10 0x00007fffa45fe6ca in ScanResultProcessor::commit (this=0x7fff8c9fd010)
    at /home/myriam/kde/src/amarok/src/core-impl/collections/db/ScanResultProcessor.cpp:158
#11 0x00007fffa46488df in SqlScanResultProcessor::commit (this=0x7fff8c9fd010)
    at /home/myriam/kde/src/amarok/src/core-impl/collections/db/sql/SqlScanResultProcessor.cpp:79
#12 0x00007fffa45f8a94 in ScannerJob::run (this=0x3fadb60)
    at /home/myriam/kde/src/amarok/src/core-impl/collections/db/ScanManager.cpp:591
#13 0x00007ffff29f5491 in ThreadWeaver::JobRunHelper::runTheJob (this=0x7fff91261d80, th=0x7fff940093c0, 
    job=0x3fadb60) at ../../../threadweaver/Weaver/Job.cpp:106
#14 0x00007ffff29f55bc in ThreadWeaver::Job::execute (this=0x3fadb60, th=0x7fff940093c0)
    at ../../../threadweaver/Weaver/Job.cpp:135
#15 0x00007ffff29f4c9f in ThreadWeaver::ThreadRunHelper::run (this=0x7fff91261e00, parent=0xd56090, 
    th=0x7fff940093c0) at ../../../threadweaver/Weaver/Thread.cpp:95
#16 0x00007ffff29f4d5b in ThreadWeaver::Thread::run (this=0x7fff940093c0)
    at ../../../threadweaver/Weaver/Thread.cpp:142
#17 0x00007ffff54c2d05 in QThreadPrivate::start (arg=0x7fff940093c0) at thread/qthread_unix.cpp:331
#18 0x00007ffff1464efc in start_thread (arg=0x7fff91262700) at pthread_create.c:304
#19 0x00007ffff4c6289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#20 0x0000000000000000 in ?? ()
Comment 7 Ralf Engels 2012-01-25 09:59:47 UTC
Yes,
please do.

How long is the filename in this case?
Comment 8 Myriam Schweingruber 2012-01-25 10:37:35 UTC
Well, still the same testfile as previously, the Veryvervyveryvery..(repeated)...BigArtistName tag is causing it
Comment 9 Matěj Laitl 2012-10-01 14:20:59 UTC
This problem seems to be fixed, Myriam, have you opened an another bug (with more accurate title)?
Comment 10 Myriam Schweingruber 2012-10-03 09:14:17 UTC
(In reply to comment #9)
> This problem seems to be fixed, Myriam, have you opened an another bug (with
> more accurate title)?
No, why?
Comment 11 Matěj Laitl 2012-10-03 12:20:37 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > This problem seems to be fixed, Myriam, have you opened an another bug (with
> > more accurate title)?
> 
> No, why?

Oh, I've misread. Can you please change the bug title to reflect it is caused by very long filenames and reopen?
Comment 12 Myriam Schweingruber 2012-10-03 20:47:23 UTC
Just tested, it still crashes on that test file.
Comment 13 Ralf Engels 2012-12-18 18:38:43 UTC
Just tested it with a filename near the limit for most file systems (256) and it worked.
Myriam, what is the test file that you used?
Comment 14 Myriam Schweingruber 2012-12-19 18:35:06 UTC
Ralf, please see comment #9, it is the artist tag that causes the problem, and I gave you that file already
Comment 15 Matěj Laitl 2013-03-18 10:07:09 UTC
Changed title per comment #8. For very long *file* names see bug 298413.
Comment 16 Myriam Schweingruber 2013-03-18 11:26:47 UTC
Git commit b310ae91879339a0d020ff70bf590d1c197a7c9b by Ralf Engels.
Committed on 18/03/2013 at 10:50.
Pushed by rengels into branch 'master'.

Fix issue with very long artists

Should improve on the problem with very long tags. At least I don't
have any sql errors any longer.

I just can't find the bug entry for this issue right now.

M  +11   -6    src/core-impl/collections/db/sql/SqlRegistry.cpp