Bug 276865 - plasma crashes watching flash
Summary: plasma crashes watching flash
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 285614 289613 289813 300603 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-01 05:10 UTC by scott
Modified: 2012-06-22 08:54 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description scott 2011-07-01 05:10:49 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:I was viewing flash content on youtube when plasma crashed using chrome

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7769720 (LWP 1396))]

Thread 4 (Thread 0xb556cb70 (LWP 1397)):
#0  0x00e08416 in __kernel_vsyscall ()
#1  0x004a4f76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x023b184b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x023a11af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x023a1524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0485c577 in QEventDispatcherGlib::processEvents (this=0x8e1b398, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x0482e289 in QEventLoop::processEvents (this=0xb556c280, flags=...) at kernel/qeventloop.cpp:149
#7  0x0482e522 in QEventLoop::exec (this=0xb556c280, flags=...) at kernel/qeventloop.cpp:201
#8  0x047382a0 in QThread::exec (this=0x8e26ab8) at thread/qthread.cpp:492
#9  0x0480ffdb in QInotifyFileSystemWatcherEngine::run (this=0x8e26ab8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0473ada2 in QThreadPrivate::start (arg=0x8e26ab8) at thread/qthread_unix.cpp:320
#11 0x07c1de99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x004b373e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xae6c2b70 (LWP 1399)):
#0  0x0485cc2d in timerSourceCheck (source=0x8e82700) at kernel/qeventdispatcher_glib.cpp:175
#1  0x023a071d in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x023a103a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x023a1524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0485c577 in QEventDispatcherGlib::processEvents (this=0x8e81190, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x0482e289 in QEventLoop::processEvents (this=0xae6c2280, flags=...) at kernel/qeventloop.cpp:149
#6  0x0482e522 in QEventLoop::exec (this=0xae6c2280, flags=...) at kernel/qeventloop.cpp:201
#7  0x047382a0 in QThread::exec (this=0x8e74880) at thread/qthread.cpp:492
#8  0x0480ffdb in QInotifyFileSystemWatcherEngine::run (this=0x8e74880) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x0473ada2 in QThreadPrivate::start (arg=0x8e74880) at thread/qthread_unix.cpp:320
#10 0x07c1de99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x004b373e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xad6c0b70 (LWP 1404)):
#0  0x00bfcd75 in ?? () from /usr/lib/i386-linux-gnu/libgthread-2.0.so.0
#1  0x023cb482 in g_thread_self () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x0239f572 in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x023a0dde in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x023a192b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x03d35304 in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0x023ca2df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0x07c1de99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x004b373e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7769720 (LWP 1396)):
[KCrash Handler]
#7  QCoreApplication::postEvent (receiver=0x96a1d48, event=0x96b7170, priority=0) at kernel/qcoreapplication.cpp:1132
#8  0x048324cc in QCoreApplication::postEvent (receiver=0x96a1d48, event=0x96b7170) at kernel/qcoreapplication.cpp:1093
#9  0x048412a4 in QObject::deleteLater (this=0x96a1d48) at kernel/qobject.cpp:2138
#10 0x07eddefc in KJob::emitResult (this=0x96a1d48) at ../../kdecore/jobs/kjob.cpp:315
#11 0x006b32a7 in Plasma::ServiceJob::setResult (this=0x96a1d48, result=...) at ../../plasma/servicejob.cpp:80
#12 0x0361190d in StatusNotifierItemJob::contextMenuReady (this=0x96a1d48, menu=0x9476160) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#13 0x0361198d in StatusNotifierItemJob::qt_metacall (this=0x96a1d48, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd952e8) at ./statusnotifieritemjob.moc:75
#14 0x048356ba in QMetaObject::metacall (object=0x96a1d48, cl=QMetaObject::InvokeMetaMethod, idx=28, argv=0xbfd952e8) at kernel/qmetaobject.cpp:237
#15 0x048454ff in QMetaObject::activate (sender=0x9469060, m=0x3618c40, local_signal_index=0, argv=0xbfd952e8) at kernel/qobject.cpp:3287
#16 0x0360c7d3 in StatusNotifierItemSource::contextMenuReady (this=0x9469060, _t1=0x9476160) at ./statusnotifieritemsource.moc:109
#17 0x0360c811 in StatusNotifierItemSource::contextMenuReady (this=0x9469060) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:363
#18 0x0361025b in StatusNotifierItemSource::qt_metacall (this=0x9469060, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd953fc) at ./statusnotifieritemsource.moc:90
#19 0x048356ba in QMetaObject::metacall (object=0x9469060, cl=QMetaObject::InvokeMetaMethod, idx=15, argv=0xbfd953fc) at kernel/qmetaobject.cpp:237
#20 0x048454ff in QMetaObject::activate (sender=0x9475508, m=0x64b4de4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3287
#21 0x064966b7 in DBusMenuImporter::menuUpdated() () from /usr/lib/libdbusmenu-qt.so.2
#22 0x06496e94 in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#23 0x064a1e7b in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#24 0x048356ba in QMetaObject::metacall (object=0x9475508, cl=QMetaObject::InvokeMetaMethod, idx=10, argv=0xbfd9562c) at kernel/qmetaobject.cpp:237
#25 0x048454ff in QMetaObject::activate (sender=0x9476160, m=0x1d54328, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3287
#26 0x018a7567 in QMenu::aboutToShow (this=0x9476160) at .moc/release-shared/moc_qmenu.cpp:151
#27 0x018ad90b in QMenu::qt_metacall (this=0x9476160, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd9575c) at .moc/release-shared/moc_qmenu.cpp:97
#28 0x048356ba in QMetaObject::metacall (object=0x9476160, cl=QMetaObject::InvokeMetaMethod, idx=27, argv=0xbfd9575c) at kernel/qmetaobject.cpp:237
#29 0x04838641 in QMetaMethod::invoke (this=0xbfd958ec, object=0x9476160, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1578
#30 0x0483936d in QMetaObject::invokeMethod (obj=0x9476160, member=0x64a836a "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1151
#31 0x0649666e in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#32 0x0360c42f in StatusNotifierItemSource::contextMenu (this=0x9469060, x=787, y=751) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:466
#33 0x03612263 in StatusNotifierItemJob::start (this=0x96a1d48) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#34 0x006b311c in slotStart (this=0x96a1d48, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x9433430) at ../../plasma/servicejob.cpp:37
#35 Plasma::ServiceJob::qt_metacall (this=0x96a1d48, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x9433430) at ./servicejob.moc:82
#36 0x0361196a in StatusNotifierItemJob::qt_metacall (this=0x96a1d48, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x9433430) at ./statusnotifieritemjob.moc:70
#37 0x048356ba in QMetaObject::metacall (object=0x96a1d48, cl=QMetaObject::InvokeMetaMethod, idx=26, argv=0x9433430) at kernel/qmetaobject.cpp:237
#38 0x0483fe16 in QMetaCallEvent::placeMetaCall (this=0x96a1b40, object=0x96a1d48) at kernel/qobject.cpp:535
#39 0x048443b7 in QObject::event (this=0x96a1d48, e=0x96a1b40) at kernel/qobject.cpp:1226
#40 0x0141cd24 in QApplicationPrivate::notify_helper (this=0x8b10b30, receiver=0x96a1d48, e=0x96a1b40) at kernel/qapplication.cpp:4462
#41 0x014218ce in QApplication::notify (this=0x8b06cf0, receiver=0x96a1d48, e=0x96a1b40) at kernel/qapplication.cpp:3862
#42 0x00fea3ca in KApplication::notify (this=0x8b06cf0, receiver=0x96a1d48, event=0x96a1b40) at ../../kdeui/kernel/kapplication.cpp:311
#43 0x0482f0bb in QCoreApplication::notifyInternal (this=0x8b06cf0, receiver=0x96a1d48, event=0x96a1b40) at kernel/qcoreapplication.cpp:731
#44 0x04832c79 in sendEvent (receiver=0x0, event_type=0, data=0x8ab7f50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#45 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8ab7f50) at kernel/qcoreapplication.cpp:1372
#46 0x04832e0d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#47 0x0485c3c4 in sendPostedEvents (s=0x8b14300) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#48 postEventSourceDispatch (s=0x8b14300) at kernel/qeventdispatcher_glib.cpp:277
#49 0x023a0aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#50 0x023a1270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#51 0x023a1524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#52 0x0485c53c in QEventDispatcherGlib::processEvents (this=0x8ab7aa8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#53 0x014d0775 in QGuiEventDispatcherGlib::processEvents (this=0x8ab7aa8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#54 0x0482e289 in QEventLoop::processEvents (this=0xbfd96634, flags=...) at kernel/qeventloop.cpp:149
#55 0x0482e522 in QEventLoop::exec (this=0xbfd96634, flags=...) at kernel/qeventloop.cpp:201
#56 0x04832ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#57 0x0141a8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#58 0x002e55a5 in kdemain (argc=1, argv=0xbfd96844) at ../../../../plasma/desktop/shell/main.cpp:118
#59 0x080485cb in main (argc=1, argv=0xbfd96844) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 276844, bug 276112, bug 276005, bug 275038, bug 271539.

Reported using DrKonqi
Comment 1 Beat Wolf 2011-11-24 08:19:57 UTC
*** Bug 285614 has been marked as a duplicate of this bug. ***
Comment 2 Anne-Marie Mahfouf 2011-12-23 11:36:46 UTC
*** Bug 289613 has been marked as a duplicate of this bug. ***
Comment 3 Anne-Marie Mahfouf 2011-12-26 10:55:05 UTC
*** Bug 289813 has been marked as a duplicate of this bug. ***
Comment 4 Anne-Marie Mahfouf 2012-05-25 13:24:27 UTC
*** Bug 300603 has been marked as a duplicate of this bug. ***
Comment 5 Myriam Schweingruber 2012-05-26 00:57:00 UTC
Bump version from duplicate, change status.
Comment 6 Thijs 2012-06-22 08:54:44 UTC

*** This bug has been marked as a duplicate of bug 241562 ***