Bug 276695 - Bug
Summary: Bug
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-28 14:20 UTC by Franklin
Modified: 2011-06-28 15:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Franklin 2011-06-28 14:20:49 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed: This error occurs every time I leave a game in full screen. Has come to hang around the computer and reboot. The name of the game Tibia.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb786f720 (LWP 1386))]

Thread 3 (Thread 0xb2c35b70 (LWP 1391)):
#0  0x06cafd41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x07a42dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x07b0f4f2 in updateCurrentTime (this=0x99fe0a0, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x99fe0a0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x07b113a3 in QEventDispatcherUNIX::processEvents (this=0x9c6b798, flags=...) at kernel/qeventdispatcher_unix.cpp:906
#6  0x07ae0289 in QEventLoop::processEvents (this=0xb2c35280, flags=...) at kernel/qeventloop.cpp:149
#7  0x07ae0522 in QEventLoop::exec (this=0xb2c35280, flags=...) at kernel/qeventloop.cpp:201
#8  0x079ea2a0 in QThread::exec (this=0x9c61690) at thread/qthread.cpp:492
#9  0x07ac1fdb in QInotifyFileSystemWatcherEngine::run (this=0x9c61690) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x079ecda2 in QThreadPrivate::start (arg=0x9c61690) at thread/qthread_unix.cpp:320
#11 0x06a87e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb242cb70 (LWP 1392)):
#0  0x00614416 in __kernel_vsyscall ()
#1  0x06a8c48c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x001ee3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x0079c817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x8b01c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x0079c851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x8b01c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x06a87e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb786f720 (LWP 1386)):
[KCrash Handler]
#7  intel_region_buffer (intel=0x963b840, region=0x0, flag=2) at intel_regions.c:514
#8  0x025e7ce2 in intelClearWithBlit (ctx=0x963b840, mask=2) at intel_blit.c:262
#9  0x025ea4c0 in intelClear (ctx=0x963b840, mask=2) at intel_clear.c:177
#10 0x05a17512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0x00c8c84b in KWin::SceneOpenGL::paintBackground (this=0x9667278, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x00c83562 in KWin::Scene::paintGenericScreen (this=0x9667278, orig_mask=40) at ../../kwin/scene.cpp:188
#13 0x00c8ca31 in KWin::SceneOpenGL::paintGenericScreen (this=0x9667278, mask=40, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x00c807c0 in KWin::Scene::finalPaintScreen (this=0x9667278, mask=40, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x00ca20fc in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=40, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x085d30e9 in KWin::StartupFeedbackEffect::paintScreen (this=0x9beb438, mask=40, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x005aa256 in KWin::Effect::paintScreen (this=0x99aae18, mask=40, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x0857507f in KWin::LogoutEffect::paintScreen (this=0x9a65aa8, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x08590b10 in KWin::ShadowEffect::paintScreen (this=0x9b999b0, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x085a5013 in KWin::BlurEffect::paintScreen (this=0x99d0e00, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x08579e6f in KWin::PresentWindowsEffect::paintScreen (this=0x9b3bf40, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x005aa256 in KWin::Effect::paintScreen (this=0x9abc450, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x005aa256 in KWin::Effect::paintScreen (this=0x9b593c8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x005aa256 in KWin::Effect::paintScreen (this=0x9b3c5f0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x005aa256 in KWin::Effect::paintScreen (this=0x9a25e80, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x085607e9 in KWin::DesktopGridEffect::paintScreen (this=0x99d5eb0, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#37 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x08597ce2 in KWin::SlideEffect::paintScreen (this=0x9b9a440, mask=8, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#39 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x08559799 in KWin::BoxSwitchEffect::paintScreen (this=0x9b85a20, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#41 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x085b3bcc in KWin::CubeEffect::paintScreen (this=0x9ad40d8, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#43 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x005aa256 in KWin::Effect::paintScreen (this=0x9b0d6f8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#45 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x005aa256 in KWin::Effect::paintScreen (this=0x9a9cca0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x005aa256 in KWin::Effect::paintScreen (this=0x99d2ba0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x085aca0c in KWin::CoverSwitchEffect::paintScreen (this=0x9ad46b8, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#51 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x005aa256 in KWin::Effect::paintScreen (this=0x99aa970, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#53 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x005aa256 in KWin::Effect::paintScreen (this=0x9ae50d8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0x085a20c1 in KWin::ZoomEffect::paintScreen (this=0x9b0d3d8, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#57 0x00ca2172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9961130, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0x00c8198c in KWin::Scene::paintScreen (this=0x9667278, mask=0xbfe27db8, region=0xbfe27e40) at ../../kwin/scene.cpp:137
#59 0x00c98962 in KWin::SceneOpenGL::paint (this=0x9667278, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#60 0x00c7d886 in KWin::Workspace::performCompositing (this=0x996b8b0) at ../../kwin/composite.cpp:448
#61 0x07af6214 in QObject::event (this=0x996b8b0, e=0xbfe2836c) at kernel/qobject.cpp:1190
#62 0x03260d24 in QApplicationPrivate::notify_helper (this=0x9586208, receiver=0x996b8b0, e=0xbfe2836c) at kernel/qapplication.cpp:4462
#63 0x032658ce in QApplication::notify (this=0xbfe28684, receiver=0x996b8b0, e=0xbfe2836c) at kernel/qapplication.cpp:3862
#64 0x00eb83ca in KApplication::notify (this=0xbfe28684, receiver=0x996b8b0, event=0xbfe2836c) at ../../kdeui/kernel/kapplication.cpp:311
#65 0x00c0cabf in KWin::Application::notify (this=0xbfe28684, o=0x996b8b0, e=0xbfe2836c) at ../../kwin/main.cpp:376
#66 0x07ae10bb in QCoreApplication::notifyInternal (this=0xbfe28684, receiver=0x996b8b0, event=0xbfe2836c) at kernel/qcoreapplication.cpp:731
#67 0x07b111e4 in sendEvent (this=0x95880a8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0x95880a8) at kernel/qeventdispatcher_unix.cpp:604
#69 0x07b11338 in QEventDispatcherUNIX::processEvents (this=0x9545aa8, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#70 0x033157ea in QEventDispatcherX11::processEvents (this=0x9545aa8, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#71 0x07ae0289 in QEventLoop::processEvents (this=0xbfe285c4, flags=...) at kernel/qeventloop.cpp:149
#72 0x07ae0522 in QEventLoop::exec (this=0xbfe285c4, flags=...) at kernel/qeventloop.cpp:201
#73 0x07ae4ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#74 0x0325e8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#75 0x00c0f5b2 in kdemain (argc=3, argv=0xbfe28904) at ../../kwin/main.cpp:542
#76 0x080485bb in main (argc=3, argv=0xbfe28904) at kwin_dummy.cpp:3

Possible duplicates by query: bug 276588, bug 276484, bug 276152, bug 275741, bug 275525.

Reported using DrKonqi
Comment 1 Martin Flöser 2011-06-28 15:23:34 UTC
driver bug, for workaround see duplicate

*** This bug has been marked as a duplicate of bug 252817 ***