Bug 276594 - plasma crash when i kill amarok
Summary: plasma crash when i kill amarok
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-27 08:13 UTC by Raúl A V
Modified: 2011-11-21 12:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raúl A V 2011-06-27 08:13:58 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
plasma crash when i kill amarok
- Unusual behavior I noticed:
plasma crash when i kill amarok
plasma crash when i kill amarok

-- Backtrace:
Application: Shell de escritorio Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f04e57f87c0 (LWP 1645))]

Thread 4 (Thread 0x7f04c3ddc700 (LWP 1646)):
#0  0x00007f04da3d4d9d in __pthread_mutex_unlock_usercnt (mutex=0x2184e38) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x2184e38) at pthread_mutex_unlock.c:290
#2  0x00007f04d9acc094 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f04d9accf9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f04d9acd639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f04e22f9446 in QEventDispatcherGlib::processEvents (this=0x2661500, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f04e22cd882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f04e22cdabc in QEventLoop::exec (this=0x7f04c3ddbcd0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007f04e21e4924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#9  0x00007f04e22afc2f in QInotifyFileSystemWatcherEngine::run (this=0x2660f00) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f04e21e7175 in QThreadPrivate::start (arg=0x2660f00) at thread/qthread_unix.cpp:320
#11 0x00007f04d7b52853 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#12 0x00007f04da3d0d8c in start_thread (arg=0x7f04c3ddc700) at pthread_create.c:304
#13 0x00007f04e50f804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f04bafbf700 (LWP 1648)):
#0  0x00007f04d9acd1aa in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f04d9acd639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f04e22f9446 in QEventDispatcherGlib::processEvents (this=0x2920510, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#3  0x00007f04e22cd882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007f04e22cdabc in QEventLoop::exec (this=0x7f04bafbecd0, flags=...) at kernel/qeventloop.cpp:201
#5  0x00007f04e21e4924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#6  0x00007f04e22afc2f in QInotifyFileSystemWatcherEngine::run (this=0x291fbf0) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00007f04e21e7175 in QThreadPrivate::start (arg=0x291fbf0) at thread/qthread_unix.cpp:320
#8  0x00007f04d7b52853 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f04da3d0d8c in start_thread (arg=0x7f04bafbf700) at pthread_create.c:304
#10 0x00007f04e50f804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f04b899f700 (LWP 1653)):
#0  0x00007f04e50eaf03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f04d9acd104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f04d9acd9f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f04b9ab6c44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f04d9af43e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f04d7b52853 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#6  0x00007f04da3d0d8c in start_thread (arg=0x7f04b899f700) at pthread_create.c:304
#7  0x00007f04e50f804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f04e57f87c0 (LWP 1645)):
[KCrash Handler]
#6  QCoreApplication::postEvent (receiver=0x3238290, event=0x2d76830, priority=0) at kernel/qcoreapplication.cpp:1132
#7  0x00007f04c9c37b0c in StatusNotifierItemJob::contextMenuReady (this=0x3238290, menu=0x310f980) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#8  0x00007f04c9c37b70 in StatusNotifierItemJob::qt_metacall (this=0x3238290, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff96e74680) at ./statusnotifieritemjob.moc:75
#9  0x00007f04e22e35f8 in QMetaObject::activate (sender=0x2efb860, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff96e74680) at kernel/qobject.cpp:3287
#10 0x00007f04c9c334bf in StatusNotifierItemSource::contextMenuReady (this=<value optimized out>, _t1=0x310f980) at ./statusnotifieritemsource.moc:109
#11 0x00007f04c9c369dc in StatusNotifierItemSource::qt_metacall (this=0x2efb860, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff96e74740) at ./statusnotifieritemsource.moc:90
#12 0x00007f04e22e35f8 in QMetaObject::activate (sender=0x30e34e0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3287
#13 0x00007f04dac46f4c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#14 0x00007f04dac51bf4 in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#15 0x00007f04e22e35f8 in QMetaObject::activate (sender=0x310f980, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3287
#16 0x00007f04e1ad0ac8 in QMenu::qt_metacall (this=0x310f980, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff96e74b00) at .moc/release-shared/moc_qmenu.cpp:97
#17 0x00007f04e22d6f4b in QMetaMethod::invoke (this=0x7fff96e74d50, object=0x310f980, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1578
#18 0x00007f04e22d7ba8 in QMetaObject::invokeMethod (obj=0x310f980, member=<value optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1151
#19 0x00007f04dac46751 in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#20 0x00007f04c9c330cb in StatusNotifierItemSource::contextMenu (this=0x2efb860, x=849, y=1014) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:466
#21 0x00007f04c9c384bd in StatusNotifierItemJob::start (this=0x3238290) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#22 0x00007f04e4cb2fe5 in slotStart (this=0x3238290, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x33effe0) at ../../plasma/servicejob.cpp:37
#23 Plasma::ServiceJob::qt_metacall (this=0x3238290, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x33effe0) at ./servicejob.moc:82
#24 0x00007f04c9c37b50 in StatusNotifierItemJob::qt_metacall (this=0x3238290, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x33effe0) at ./statusnotifieritemjob.moc:70
#25 0x00007f04e22e249a in QObject::event (this=0x3238290, e=<value optimized out>) at kernel/qobject.cpp:1226
#26 0x00007f04e168f9e4 in QApplicationPrivate::notify_helper (this=0x2076220, receiver=0x3238290, e=0x33eb7d0) at kernel/qapplication.cpp:4462
#27 0x00007f04e16943aa in QApplication::notify (this=<value optimized out>, receiver=0x3238290, e=0x33eb7d0) at kernel/qapplication.cpp:4341
#28 0x00007f04e2f86866 in KApplication::notify (this=0x2044200, receiver=0x3238290, event=0x33eb7d0) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007f04e22ce49c in QCoreApplication::notifyInternal (this=0x2044200, receiver=0x3238290, event=0x33eb7d0) at kernel/qcoreapplication.cpp:731
#30 0x00007f04e22d1c25 in sendEvent (receiver=0x0, event_type=0, data=0x1fb4b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1fb4b60) at kernel/qcoreapplication.cpp:1372
#32 0x00007f04e22f9253 in sendPostedEvents (s=0x2078d60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0x2078d60) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f04d9accbcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007f04d9acd3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007f04d9acd639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007f04e22f93ef in QEventDispatcherGlib::processEvents (this=0x1fb4340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#38 0x00007f04e1736dfe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f04e22cd882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#40 0x00007f04e22cdabc in QEventLoop::exec (this=0x7fff96e75ee0, flags=...) at kernel/qeventloop.cpp:201
#41 0x00007f04e22d1ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#42 0x00007f04e53e4897 in kdemain (argc=1, argv=0x7fff96e762a8) at ../../../../plasma/desktop/shell/main.cpp:118
#43 0x00007f04e5030eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=1, ubp_av=0x7fff96e762a8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff96e76298) at libc-start.c:226
#44 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 270197.

Possible duplicates by query: bug 276112, bug 275038, bug 270912, bug 270898, bug 270197.

Reported using DrKonqi
Comment 1 Beat Wolf 2011-11-21 12:56:24 UTC

*** This bug has been marked as a duplicate of bug 241562 ***