Bug 276450 - Versioning cuts image filenames after the first '.'
Summary: Versioning cuts image filenames after the first '.'
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Albums-Versioning (show other bugs)
Version: 2.0.0
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-25 10:34 UTC by barsanuphe
Modified: 2022-02-02 04:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 2.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description barsanuphe 2011-06-25 10:34:27 UTC
Version:           2.0.0 (using Devel) 
OS:                Linux

The automatic names generated by the versioning features assumes the first '.' in the filename is the end of the basename. All subsequent characters are lost in the new versions.

Reproducible: Always

Steps to Reproduce:
Edit a file called test.with.several.dots.jpg.
Save a new version. 


Actual Results:  
The new version is called test.JPG.

Expected Results:  
The new version should be called something like test.with.several.dots_v2.jpg

This may not be an issue with standard filenames (ie "IMG_XXXX.JPG") but arises with custom filenames. For instance, I like to have the lens model with aperture in the filename, all pictures taken with a lens opening at f/2.8 are affected.

Using the Archlinux AUR package digikam-git with kipi-plugins-git.
Comment 1 caulier.gilles 2011-06-26 13:19:23 UTC
Which versionning file naming logic is used in other photo-management program ?

Gilles Caulier
Comment 2 barsanuphe 2011-06-26 13:55:58 UTC
I'm not sure since I only use Digikam. 

I'd settle for any that doesn't eat part of the filename :).
A simple _v1.jpg, _v2.jpg suffix would be fine in my book.
Comment 3 Marcel Wiesweg 2011-07-14 17:41:25 UTC
The precise observation is that for each newly generated filename, the part to the next '.' is cut
Comment 4 Marcel Wiesweg 2011-07-14 17:43:35 UTC
Git commit 481858207256d7eecc9d5a4ff93ad77ad2984844 by Marcel Wiesweg.
Committed on 14/07/2011 at 19:42.
Pushed by mwiesweg into branch 'master'.

When we have the basename and not a full filename, we should not replace
the suffix, but add the suffix.

BUG: 276450

M  +2    -1    NEWS     
M  +25   -1    libs/versionmanager/versionmanager.cpp     

http://commits.kde.org/digikam/481858207256d7eecc9d5a4ff93ad77ad2984844