Bug 276429 - clicked-on menus should stay open longer
Summary: clicked-on menus should stay open longer
Status: RESOLVED DUPLICATE of bug 179267
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: 4.6
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-25 00:53 UTC by missive
Modified: 2011-09-20 15:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description missive 2011-06-25 00:53:44 UTC
Version:           4.6 (using KDE 4.6.2) 
OS:                Linux

I am not sure where to report this, but it is a KDE-wide problem. Fixing it would add enormously to KDE's usability and remove a serious source of frustration.

When a menu is clicked on, it should be a bit more likely to stay open, even if the mouse pointer happens to wander across another entry that would pop up a different menu.

For instance, in Konqueror, clicking on the Bookmarks menu but then wandering across the Tools menu on your way down to the Bookmarks dropdown should probably not bring up the Tools menu. If you were to hover over the Tools menu for a while (maybe a half second or more?) then yes, the Tools menu should open, but not for a brief flit across the Tools menu.

One place where this is especially annoying is in menus with submenus. Clicking on a menu item that opens up a submenu means that you intend to select something in that submenu. The submenu should be more likely to stay open.

The way it is now, you have to navigate the mouse cursor very precisely out the edge of that submenu, otherwise the submenu above or below will spring open instead.

Allowing more time means that you can open a submenu, then go diagonally across other submenus directly to the item that you want. For instance, if you have many folders in your Bookmarks menu, you could click on the Bookmarks folder submenu, then go across other submenus directly to the bookmark you want, instead of having to go painstakingly over to the edge of the submenu list item and only then down to the bookmark you want.

It looks like in other environments, clicking on the menu is not even necessary. There is just a longer grace period once a menu has opened allowing for some degree of mouse wandering while heading towards the open menu. (On further study, this does not seem to be the case for the top-level menus, but for submenus only).

I think (if it is possible) clicking on a menu should make it more likely to stay open longer. If that is not possible, I think that all open menus in KDE should allow a bit more of a delay before responding to a mouseover.


Reproducible: Always

Steps to Reproduce:
Click on menu that has submenu items.
Click on a submenu that has several entries.
Try to go directly to one of the entries near the bottom of the list.

Actual Results:  
Any submenu crossed will pop open, no matter how quickly you move your mouse across it.

Expected Results:  
Moving quickly across a submenu entry should not pop up a different menu.

OS: Linux (i686) release 2.6.38-8-generic
Compiler: cc
Comment 1 Christoph Feck 2011-06-25 13:32:38 UTC

*** This bug has been marked as a duplicate of bug 179267 ***