Bug 276385 - crash when loading a document with tables.
Summary: crash when loading a document with tables.
Status: RESOLVED FIXED
Alias: None
Product: calligrawords
Classification: Unclassified
Component: general (show other bugs)
Version: Git
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Matus Uzak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-24 11:43 UTC by Halla Rempt
Modified: 2011-09-20 15:07 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Halla Rempt 2011-06-24 11:43:08 UTC
Application: calligrawords (2.4 Alpha 2)
KDE Platform Version: 4.6.4 (4.6.4)
Qt Version: 4.7.4
Operating System: Linux 2.6.37.6-0.5-pae i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
This crash occurs when loading a document with tables. Please contact me privately (boud@valdyas.org) if you want to test with the document because I cannot properly anonymize it.

The crash can be reproduced every time.

-- Backtrace:
Application: Words (calligrawords), signal: Segmentation fault
[KCrash Handler]
#7  0xaecaafa3 in WordsTableHandler::tableCellEnd() () from /home/boud/kde/master/lib/kde4/mswordodf_import.so
#8  0xaebc980b in wvWare::Parser9x::processParagraph(unsigned int) () from /home/boud/kde/inst/lib/libkowv2.so.4
#9  0xaebcce62 in void wvWare::Parser9x::processPiece<unsigned char>(unsigned char*, unsigned int, unsigned int, wvWare::Parser9x::Position const&) () from /home/boud/kde/inst/lib/libkowv2.so.4
#10 0xaebca409 in wvWare::Parser9x::parseHelper(wvWare::Parser9x::Position) () from /home/boud/kde/inst/lib/libkowv2.so.4
#11 0xaebcbcfa in wvWare::Parser9x::parseTableRow(wvWare::TableRowData const&) () from /home/boud/kde/inst/lib/libkowv2.so.4
#12 0xaec9a464 in wvWare::Functor<wvWare::Parser9x, wvWare::TableRowData>::operator()() const () from /home/boud/kde/master/lib/kde4/mswordodf_import.so
#13 0xaec7e302 in Document::slotTableFound(Words::Table*) () from /home/boud/kde/master/lib/kde4/mswordodf_import.so
#14 0xaec7e7f7 in Document::qt_metacall(QMetaObject::Call, int, void**) () from /home/boud/kde/master/lib/kde4/mswordodf_import.so
#15 0xb573c0ed in QMetaObject::metacall (object=0x81e9168, cl=QMetaObject::InvokeMetaMethod, idx=10, argv=0xbfe903b8) at kernel/qmetaobject.cpp:237
#16 0xb574b5fc in QMetaObject::activate (sender=0x8689d18, m=0xaee3f03c, local_signal_index=6, argv=0xbfe903b8) at kernel/qobject.cpp:3278
#17 0xaec8a563 in WordsTextHandler::tableFound(Words::Table*) () from /home/boud/kde/master/lib/kde4/mswordodf_import.so
#18 0xaec959e3 in WordsTextHandler::tableEndFound() () from /home/boud/kde/master/lib/kde4/mswordodf_import.so
#19 0xaebc8feb in wvWare::Parser9x::processParagraph(unsigned int) () from /home/boud/kde/inst/lib/libkowv2.so.4
#20 0xaebcce62 in void wvWare::Parser9x::processPiece<unsigned char>(unsigned char*, unsigned int, unsigned int, wvWare::Parser9x::Position const&) () from /home/boud/kde/inst/lib/libkowv2.so.4
#21 0xaebca409 in wvWare::Parser9x::parseHelper(wvWare::Parser9x::Position) () from /home/boud/kde/inst/lib/libkowv2.so.4
#22 0xaebcb818 in wvWare::Parser9x::parseBody() () from /home/boud/kde/inst/lib/libkowv2.so.4
#23 0xaebcb9c7 in wvWare::Parser9x::parse() () from /home/boud/kde/inst/lib/libkowv2.so.4
#24 0xaec752bc in Document::parse() () from /home/boud/kde/master/lib/kde4/mswordodf_import.so
#25 0xaec713cf in MSWordOdfImport::convert(QByteArray const&, QByteArray const&) () from /home/boud/kde/master/lib/kde4/mswordodf_import.so
#26 0xb77edc38 in CalligraFilter::ChainLink::invokeFilter(CalligraFilter::ChainLink const*) () from /home/boud/kde/inst/lib/libkomain.so.8
#27 0xb77e507d in KoFilterChain::invokeChain() () from /home/boud/kde/inst/lib/libkomain.so.8
#28 0xb77e36bb in KoFilterManager::importDocument(QString const&, QString const&, KoFilter::ConversionStatus&) () from /home/boud/kde/inst/lib/libkomain.so.8
#29 0xb77945fe in KoDocument::openFile() () from /home/boud/kde/inst/lib/libkomain.so.8
#30 0xb7138760 in ?? () from /usr/lib/libkparts.so.4
#31 0xb7138e29 in KParts::ReadOnlyPart::openUrl(KUrl const&) () from /usr/lib/libkparts.so.4
#32 0xb7797981 in KoDocument::openUrl(KUrl const&) () from /home/boud/kde/inst/lib/libkomain.so.8
#33 0xb77b38ff in KoMainWindow::openDocumentInternal(KUrl const&, KoDocument*) () from /home/boud/kde/inst/lib/libkomain.so.8
#34 0xb77b2586 in KoMainWindow::openDocument(KoDocument*, KUrl const&) () from /home/boud/kde/inst/lib/libkomain.so.8
#35 0xb778380b in KoApplication::start() () from /home/boud/kde/inst/lib/libkomain.so.8
#36 0xb7869b66 in kdemain () from /home/boud/kde/inst/lib/libkdeinit4_calligrawords.so
#37 0x080487eb in main ()

Reported using DrKonqi
Comment 1 Sebastian Sauer 2011-07-02 12:28:33 UTC
Fixed with 873b9867bb9ce5b4d4e59ff93258a44bb16a99ea
Comment 2 Matus Uzak 2011-07-04 09:18:08 UTC
I think there's some problem deeper, the removed assert wasn't there for fun.  Assigning to not forget about it.
Comment 3 Matus Uzak 2011-08-01 13:19:15 UTC
Git commit b2c0774dc32d5be551c5fd97a34515967ab5919f by Matus Uzak.
Committed on 01/08/2011 at 14:59.
Pushed by uzak into branch 'master'.

DOC: Put back an assert for table cell styles.

The assert was removed by:
commit	873b9867bb9ce5b4d4e59ff93258a44bb16a99ea

Let's keep the assert to detect broken files, which can't
be handled at the moment.  The assert started to cause problems
because of changes of mine, which didn't consider covered table cells.

CCBUG:276385

M  +0    -1    filters/words/msword-odf/texthandler.cpp
M  +18   -16   filters/words/msword-odf/tablehandler.cpp

http://commits.kde.org/calligra/b2c0774dc32d5be551c5fd97a34515967ab5919f