Bug 276288 - Popup message kopete
Summary: Popup message kopete
Status: RESOLVED DUPLICATE of bug 259269
Alias: None
Product: phonon-backend-vlc
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-22 21:54 UTC by Alberto
Modified: 2011-07-26 10:55 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto 2011-06-22 21:54:34 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.6.4 (4.6.4) "release 8"
Qt Version: 4.7.3
Operating System: Linux 2.6.37.6-0.5-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
After upgrade 4.6.4 from openSUSE repository always when recived a message kopete knotify crash

The crash can be reproduced every time.

-- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f317bd62760 (LWP 7223))]

Thread 2 (Thread 0x7f3169b28700 (LWP 7226)):
#0  0x00007f3178ff1503 in poll () from /lib64/libc.so.6
#1  0x00007f3176591114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007f3176591650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f317972b286 in QEventDispatcherGlib::processEvents (this=0x72f240, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f31796ff8d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f31796ffae5 in QEventLoop::exec (this=0x7f3169b27de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f31796147a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f31796e1008 in QInotifyFileSystemWatcherEngine::run (this=0x72b6a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f3179617095 in QThreadPrivate::start (arg=0x72b6a0) at thread/qthread_unix.cpp:320
#9  0x00007f31770f2a3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f3178ffa67d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f317bd62760 (LWP 7223)):
[KCrash Handler]
#6  0x00000000000009ee in ?? ()
#7  0x00007f31465e311e in vlc_entry__1_1_0g (p_module=0xb1da80) at avio.c:40
#8  0x00007f3168497441 in module_Call (obj=0x7ea590, p_module=<value optimized out>) at modules/os.c:119
#9  0x00007f3168490c19 in AllocatePlugin (p_this=0x7ea590, psz_file=0xb1da10 "/usr/lib64/vlc/plugins/access/libaccess_avio_plugin.so") at modules/modules.c:1032
#10 0x00007f3168490ef7 in AllocatePluginFile (p_this=0x7ea590, p_bank=0x7576f0, psz_dir=0x957310 "/usr/lib64/vlc/plugins/access", i_maxdepth=<value optimized out>) at modules/modules.c:960
#11 AllocatePluginDir (p_this=0x7ea590, p_bank=0x7576f0, psz_dir=0x957310 "/usr/lib64/vlc/plugins/access", i_maxdepth=<value optimized out>) at modules/modules.c:912
#12 0x00007f3168490e1c in AllocatePluginDir (p_this=0x7ea590, p_bank=0x7576f0, psz_dir=0xa661a0 "/usr/lib64/vlc/plugins", i_maxdepth=<value optimized out>) at modules/modules.c:904
#13 0x00007f3168490e1c in AllocatePluginDir (p_this=0x7ea590, p_bank=0x7576f0, psz_dir=0x80b120 "/usr/lib64/vlc", i_maxdepth=<value optimized out>) at modules/modules.c:904
#14 0x00007f3168491453 in AllocateAllPlugins (p_this=0x7ea590) at modules/modules.c:854
#15 module_LoadPlugins (p_this=0x7ea590) at modules/modules.c:217
#16 0x00007f3168425175 in libvlc_InternalInit (p_libvlc=0x7ea590, i_argc=13, ppsz_argv=0x7fff58d2b2f0) at libvlc.c:453
#17 0x00007f316890462d in libvlc_new () from /usr/lib64/libvlc.so.5
#18 0x00007f3168b38e59 in Phonon::VLC::vlcInit (debugLevl=<value optimized out>) at /usr/src/debug/phonon-backend-vlc-0.3.2/vlc/vlcloader.cpp:94
#19 0x00007f3168b2816d in Phonon::VLC::Backend::Backend (this=0x7d9e80, parent=<value optimized out>) at /usr/src/debug/phonon-backend-vlc-0.3.2/vlc/backend.cpp:84
#20 0x00007f3168b286cb in qt_plugin_instance () at /usr/src/debug/phonon-backend-vlc-0.3.2/vlc/backend.cpp:49
#21 0x00007f3169b35622 in Phonon::KdePlatformPlugin::createBackend (this=<value optimized out>, newService=...) at /usr/src/debug/kdebase-runtime-4.6.4/phonon/platform_kde/kdeplatformplugin.cpp:149
#22 0x00007f3169b3612b in Phonon::KdePlatformPlugin::createBackend (this=0x6dd170) at /usr/src/debug/kdebase-runtime-4.6.4/phonon/platform_kde/kdeplatformplugin.cpp:200
#23 0x00007f317b303046 in ?? () from /usr/lib64/libphonon.so.4
#24 0x00007f317b30398f in Phonon::Factory::backend(bool) () from /usr/lib64/libphonon.so.4
#25 0x00007f317b303d60 in ?? () from /usr/lib64/libphonon.so.4
#26 0x00007f317b2fca76 in ?? () from /usr/lib64/libphonon.so.4
#27 0x00007f317b2f9cf8 in ?? () from /usr/lib64/libphonon.so.4
#28 0x000000000040e821 in Player (this=0x71c5f8) at /usr/src/debug/kdebase-runtime-4.6.4/knotify/notifybysound.cpp:58
#29 PlayerPool::getPlayer (this=0x71c5f8) at /usr/src/debug/kdebase-runtime-4.6.4/knotify/notifybysound.cpp:98
#30 0x000000000040ed9e in NotifyBySound::notify (this=0x6e4670, eventId=66, config=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.6.4/knotify/notifybysound.cpp:242
#31 0x000000000040ba51 in KNotify::emitEvent (this=0x7fff58d2d500, e=0x735990) at /usr/src/debug/kdebase-runtime-4.6.4/knotify/knotify.cpp:230
#32 0x000000000040c8b3 in KNotify::event (this=0x7fff58d2d500, event=<value optimized out>, appname=..., contexts=<value optimized out>, title=<value optimized out>, text=<value optimized out>, image=..., actions=..., timeout=0, winId=62917344) at /usr/src/debug/kdebase-runtime-4.6.4/knotify/knotify.cpp:149
#33 0x000000000040cc00 in KNotifyAdaptor::event (this=0x6b2b00, event=..., fromApp=..., contexts=<value optimized out>, title=..., text=..., image=..., actions=..., timeout=0, winId=62917344) at /usr/src/debug/kdebase-runtime-4.6.4/knotify/knotify.cpp:289
#34 0x000000000040cdfb in KNotifyAdaptor::qt_metacall (this=0x6b2b00, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff58d2c7b0) at /usr/src/debug/kdebase-runtime-4.6.4/build/knotify/knotify.moc:227
#35 0x00007f3179a57568 in QDBusConnectionPrivate::deliverCall (this=0x644e30, object=0x6b2b00, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:941
#36 0x00007f3179a58785 in QDBusConnectionPrivate::activateCall (this=0x644e30, object=0x6b2b00, flags=273, msg=...) at qdbusintegrator.cpp:851
#37 0x00007f3179a58f1e in QDBusConnectionPrivate::activateObject (this=0x644e30, node=..., msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1409
#38 0x00007f3179a59158 in QDBusActivateObjectEvent::placeMetaCall (this=0x6da9f0) at qdbusintegrator.cpp:1523
#39 0x00007f317971437a in QObject::event (this=0x7fff58d2d500, e=<value optimized out>) at kernel/qobject.cpp:1217
#40 0x00007f317a317144 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#41 0x00007f317a31f6fa in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#42 0x00007f317b6cd3c6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#43 0x00007f317970047c in QCoreApplication::notifyInternal (this=0x7fff58d2d530, receiver=0x7fff58d2d500, event=0x6da9f0) at kernel/qcoreapplication.cpp:731
#44 0x00007f3179703c75 in sendEvent (receiver=0x0, event_type=0, data=0x6273e0) at kernel/qcoreapplication.h:215
#45 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6273e0) at kernel/qcoreapplication.cpp:1372
#46 0x00007f317972b093 in sendPostedEvents (s=0x652dc0) at kernel/qcoreapplication.h:220
#47 postEventSourceDispatch (s=0x652dc0) at kernel/qeventdispatcher_glib.cpp:277
#48 0x00007f3176590bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#49 0x00007f31765913b0 in ?? () from /lib64/libglib-2.0.so.0
#50 0x00007f3176591650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#51 0x00007f317972b22f in QEventDispatcherGlib::processEvents (this=0x62ce90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#52 0x00007f317a3bcbae in ?? () from /usr/lib64/libQtGui.so.4
#53 0x00007f31796ff8d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#54 0x00007f31796ffae5 in QEventLoop::exec (this=0x7fff58d2d450, flags=...) at kernel/qeventloop.cpp:201
#55 0x00007f3179703f2b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#56 0x000000000040a12f in main (argc=1, argv=0x7fff58d2d8c8) at /usr/src/debug/kdebase-runtime-4.6.4/knotify/main.cpp:73

Reported using DrKonqi
Comment 1 Harald Sitter 2011-07-26 10:55:09 UTC

*** This bug has been marked as a duplicate of bug 259269 ***