Bug 276236 - Artist info not updated automatically when radio stream changes track
Summary: Artist info not updated automatically when radio stream changes track
Status: RESOLVED DUPLICATE of bug 272243
Alias: None
Product: phonon-backend-gstreamer
Classification: Unclassified
Component: general (show other bugs)
Version: 4.5-git
Platform: Archlinux Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: 4.5.2
Assignee: Harald Sitter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-22 05:35 UTC by Xavion
Modified: 2011-07-18 08:40 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xavion 2011-06-22 05:35:01 UTC
Version:           2.4.1 (using KDE 4.6.3) 
OS:                Linux

I have to click the 'Artist' button at the top of this applet manually, whereas I think this used to happen automatically in previous versions.  This occurs with both the Xine and VLC backends; the GStreamer backend has other problems.

My guess is that the artist info is updated automatically for local track changes.  The applet probably just doesn't recognise when remote streams change the track.  The Wikipedia applet in Banshee changes the artist automatically.

Reproducible: Always
Comment 1 Sven Krohlas 2011-06-26 12:33:56 UTC
WFM on git master. Any more info you can give us? Which stream are you testing with?
Comment 2 Xavion 2011-06-28 07:27:11 UTC
It won't automatically update any of the streams I listen to anymore.  For example, try the ".977 The Hitz Channel" station: http://yp.shoutcast.com/sbin/tunein-station.pls?id=1280356
Comment 3 Myriam Schweingruber 2011-07-18 06:59:41 UTC
Setting status correctly.

Just tested: none of the streams actually show information anymore here.
Comment 4 Valorie Zimmerman 2011-07-18 07:49:35 UTC
Just tested with both gstreamer and vlc backends, both built a couple of days ago from GIT, along with phonon. Gst shows only "streaming data" - no track information whatsoever.

phonon-backend-vlc, however, works perfectly and as expected. At track change, as long as they are correctly tagged by the stream, wikipedia and all labeling changes as it should. I tested with http://yp.shoutcast.com/sbin/tunein-station.pls?id=1280356 and that works perfectly. 

My local classical station gets the name of the track, but incorrectly places the composer in caps before the trackname, thus: BERWALD:Symphony No.1 in G minor "Sinfonie serieuse, so wikipedia finds nothing. Some streams don't do a good job of tagging, sadly.
Comment 5 Myriam Schweingruber 2011-07-18 08:40:08 UTC
Reassigning to phonon then, as it is backend related.

*** This bug has been marked as a duplicate of bug 272243 ***