Bug 276214 - Crash when dbus exits (crash in QDBusAbstractInterfacePrivate dtor)
Summary: Crash when dbus exits (crash in QDBusAbstractInterfacePrivate dtor)
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdecore (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: HI crash
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 280311 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-21 21:41 UTC by Chris K. Jester-Young
Modified: 2020-12-17 10:43 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
New crash information added by DrKonqi (8.60 KB, text/plain)
2011-06-21 21:47 UTC, Chris K. Jester-Young
Details
New crash information added by DrKonqi (3.32 KB, text/plain)
2011-08-15 09:03 UTC, GDR!
Details
New crash information added by DrKonqi (3.89 KB, text/plain)
2011-09-13 21:35 UTC, nicws9
Details
New crash information added by DrKonqi (3.17 KB, text/plain)
2011-12-16 12:43 UTC, Bruno Friedmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris K. Jester-Young 2011-06-21 21:41:14 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-virtual x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- Unusual behavior I noticed:

On occasion, dbus gets into a busy loop, and has to be terminated. When this happens, kded4 and printer-applet both die.

I'm not sure if this is relevant for reproducing the behaviour, but during the dbus busy loop, stracing dbus gives the following output over and over (with different timestamps returned from clock_gettime, of course):

clock_gettime(CLOCK_MONOTONIC, {513039, 593668877}) = 0
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=6, events=POLLIN}, {fd=8, events=POLLIN}, {fd=9, events=POLLIN}, {fd=11, events=POLLIN}, {fd=13, events=POLLIN}, {fd=14, events=POLLIN}, {fd=15, events=POLLIN}, {fd=16, events=POLLIN}, {fd=17, events=POLLIN}, {fd=18, events=POLLIN}, {fd=21, events=POLLIN}, {fd=20, events=POLLIN}, {fd=22, events=POLLIN}, {fd=23, events=POLLIN}, {fd=19, events=POLLIN}, {fd=25, events=POLLIN}, {fd=26, events=POLLIN}, {fd=27, events=POLLIN}, {fd=28, events=POLLIN}, {fd=29, events=POLLIN}, {fd=30, events=POLLIN}, {fd=31, events=POLLIN}, {fd=32, events=POLLIN}, {fd=33, events=POLLIN}, {fd=34, events=POLLIN}, {fd=35, events=POLLIN}, {fd=36, events=POLLIN}, {fd=37, events=POLLIN}, {fd=38, events=POLLIN}, {fd=39, events=POLLIN}, ...], 1018, -1) = 1 ([{fd=3, revents=POLLIN}])
clock_gettime(CLOCK_MONOTONIC, {513039, 596951506}) = 0
accept4(3, 0x7fff3c5e7810, [16], SOCK_CLOEXEC) = -1 EMFILE (Too many open files)
fcntl(-1, F_GETFD)                      = -1 EBADF (Bad file descriptor)

The crash can be reproduced some of the time.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1eb2e9d780 (LWP 1224))]

Thread 2 (Thread 0x7f1e971bb700 (LWP 1285)):
#0  0x00007f1eb0750f03 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f1eadb68104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1eadb689f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1e978adc44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f1eadb8f3e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f1eae227d8c in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#6  0x00007f1eb075e04d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1eb2e9d780 (LWP 1224)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f1eb1b21213 in QObject::~QObject (this=0x209a0c0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:861
#8  0x00007f1eb1b217f9 in QObject::~QObject (this=0x209a0c0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:964
#9  0x00007f1eaf161df0 in ~QDBusAbstractInterfacePrivate (this=0x20a3a20, __in_chrg=<value optimized out>) at qdbusabstractinterface_p.h:87
#10 QDBusAbstractInterfacePrivate::~QDBusAbstractInterfacePrivate (this=0x20a3a20, __in_chrg=<value optimized out>) at qdbusabstractinterface_p.h:87
#11 0x00007f1eb1b21645 in cleanup (this=0x20a3900, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#12 ~QScopedPointer (this=0x20a3900, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#13 QObject::~QObject (this=0x20a3900, __in_chrg=<value optimized out>) at kernel/qobject.cpp:818
#14 0x00007f1eaf143ea9 in QDBusConnectionInterface::~QDBusConnectionInterface (this=0x20a3900, __in_chrg=<value optimized out>) at qdbusconnectioninterface.cpp:179
#15 0x00007f1eb1b1cc14 in QObjectPrivate::deleteChildren (this=0x209a1c0) at kernel/qobject.cpp:1964
#16 0x00007f1eb1b215f4 in QObject::~QObject (this=0x209a0c0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#17 0x00007f1eaf14bc13 in QDBusConnectionPrivate::~QDBusConnectionPrivate (this=0x209a0c0, __in_chrg=<value optimized out>) at qdbusintegrator.cpp:998
#18 0x00007f1eaf14bf49 in QDBusConnectionPrivate::~QDBusConnectionPrivate (this=0x209a0c0, __in_chrg=<value optimized out>) at qdbusintegrator.cpp:1016
#19 0x00007f1eaf1435b3 in ~QDBusDefaultConnection (this=0x7f1eaf3a4c28, __in_chrg=<value optimized out>) at qdbusconnection.cpp:977
#20 QGlobalStaticDeleter<QDBusDefaultConnection>::~QGlobalStaticDeleter (this=0x7f1eaf3a4c28, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1822
#21 0x00007f1eb06b1961 in exit () from /lib/x86_64-linux-gnu/libc.so.6
#22 0x0000000000406dda in _start ()

Reported using DrKonqi
Comment 1 Chris K. Jester-Young 2011-06-21 21:47:51 UTC
Created attachment 61220 [details]
New crash information added by DrKonqi

python2 (1.6) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- Unusual behavior I noticed:

After terminating dbus, the printer-applet crashes too. Included here is the backtrace for printer-applet.

-- Backtrace (Reduced):
#6  QSocketNotifier::setEnabled (this=0x2136ae0, enable=true) at kernel/qsocketnotifier.cpp:293
#7  0x00007f4f658e0489 in pyqtDBusHelper::readSocket (this=0x2148e60, fd=11) at /build/buildd/python-qt4-4.8.3/dbus/dbus.cpp:274
#8  0x00007f4f658e0cd0 in pyqtDBusHelper::qt_metacall (this=0x2148e60, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff0befbda0) at moc_helper.cpp:75
[...]
#10 0x00007f4f70edeb7e in QSocketNotifier::activated (this=<value optimized out>, _t1=11) at .moc/release-shared/moc_qsocketnotifier.cpp:89
#11 0x00007f4f70e9cf4b in QSocketNotifier::event (this=0x2136ae0, e=0x7fff0befc460) at kernel/qsocketnotifier.cpp:317
Comment 2 GDR! 2011-08-15 09:03:36 UTC
Created attachment 62835 [details]
New crash information added by DrKonqi

kded4 ($Id$) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:

This has happened about 5 minutes after restarting dbus. I have provided printer-applet stack trace in a different bug report, here's kded's one.

-- Backtrace (Reduced):
#7  0x00007f1d0f30e213 in QObject::~QObject (this=0x1b25b90, __in_chrg=<value optimized out>) at kernel/qobject.cpp:861
#8  0x00007f1d0f30e7f9 in QObject::~QObject (this=0x1b25b90, __in_chrg=<value optimized out>) at kernel/qobject.cpp:964
#9  0x00007f1d0c94adf0 in ~QDBusAbstractInterfacePrivate (this=0x1b2b660, __in_chrg=<value optimized out>) at qdbusabstractinterface_p.h:87
#10 QDBusAbstractInterfacePrivate::~QDBusAbstractInterfacePrivate (this=0x1b2b660, __in_chrg=<value optimized out>) at qdbusabstractinterface_p.h:87
#11 0x00007f1d0f30e645 in cleanup (this=0x1b2b590, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
Comment 3 Sebastian Sauer 2011-08-18 07:04:36 UTC
bug #276214 (kded4 crashes when dbus exits) and bug #280311 (calligra apps crash when closing & saving changes) report exact the same problem including the same backtrace. Marking confirmed cause now we have different users/developers with different applications having the same crash.
Comment 4 Sebastian Sauer 2011-08-18 07:05:43 UTC
*** Bug 280311 has been marked as a duplicate of this bug. ***
Comment 5 Sebastian Sauer 2011-08-18 07:08:39 UTC
I btw cannot reproduce myself even after intensive testing. So, probably a timing issue where something is destroyed in an unexpected order...
Comment 6 nicws9 2011-09-13 21:35:24 UTC
Created attachment 63632 [details]
New crash information added by DrKonqi

kded4 ($Id$) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:
Saw high CPU usage for dbus-daemon in system monitor. Ran "----@----:/etc/init.d$ sudo ./dbus restart"
- Unusual behavior I noticed: Noticed KDE Launcher was not responding, other applications running very slowly.

-- Backtrace (Reduced):
#7  0x00007fdbbf7ef213 in QObject::~QObject (this=0x1ea20c0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:861
#8  0x00007fdbbf7ef7f9 in QObject::~QObject (this=0x1ea20c0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:964
#9  0x00007fdbbce2bdf0 in ~QDBusAbstractInterfacePrivate (this=0x1eb5060, __in_chrg=<value optimized out>) at qdbusabstractinterface_p.h:87
#10 QDBusAbstractInterfacePrivate::~QDBusAbstractInterfacePrivate (this=0x1eb5060, __in_chrg=<value optimized out>) at qdbusabstractinterface_p.h:87
#11 0x00007fdbbf7ef645 in cleanup (this=0x1ea8050, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
Comment 7 Bruno Friedmann 2011-12-16 12:43:18 UTC
Created attachment 66807 [details]
New crash information added by DrKonqi

calligraplan (2.4 Beta 4) on KDE Platform 4.7.4 (4.7.4) "release 20" using Qt 4.8.0

- What I was doing when the application crashed:
I've worked on a Plan document. Closing Plan ask me if I want to save changes, hit the save button, then the crask appear.

-- Backtrace (Reduced):
#7  0x00007f347ed3b19a in QObject::~QObject (this=0x7df130, __in_chrg=<optimized out>) at kernel/qobject.cpp:853
#8  0x00007f347ed3b959 in QObject::~QObject (this=0x7df130, __in_chrg=<optimized out>) at kernel/qobject.cpp:939
#9  0x00007f347ba60d20 in ~QDBusAbstractInterfacePrivate (this=0x7ca260, __in_chrg=<optimized out>) at qdbusabstractinterface_p.h:88
#10 QDBusAbstractInterfacePrivate::~QDBusAbstractInterfacePrivate (this=0x7ca260, __in_chrg=<optimized out>) at qdbusabstractinterface_p.h:88
#11 0x00007f347ed3b6c0 in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
Comment 8 Justin Zobel 2020-12-17 05:21:35 UTC
Thank you for the crash report.

As it has been a while since this was reported, can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved.

I have set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved/worksforme" when you respond, thank you.
Comment 9 Bruno Friedmann 2020-12-17 10:43:06 UTC
Works with openSUSE Tumbleweed
Linux 5.9.12-1-default x86_64 GNU/Linux
nvidia: 450.80.02
Qt: 5.15.2
KDE Frameworks: 5.76.0
Plasma: 5.20.4 
kmail2 5.15.3 (20.08.3)