Bug 276185 - Restart of kontact not possible
Summary: Restart of kontact not possible
Status: RESOLVED DUPLICATE of bug 222878
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Microsoft Windows
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-21 12:56 UTC by Heiner Markert
Modified: 2011-07-17 10:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiner Markert 2011-06-21 12:56:11 UTC
Version:           unspecified (using Devel) 
OS:                MS Windows

When starting kontact (Kolab E5RC build from http://wiki.kolab.org/Client_windows_kontact) everything works as expected. However, after closing contact (file/exit), it is not possible to restart the application.

Reproducible: Always

Steps to Reproduce:
Start Kontact, close it, try starting it again.

Actual Results:  
nothing (no application window opens up on second start)

Expected Results:  
Kontact should start normally.
Comment 1 Christophe Marin 2011-07-10 16:49:49 UTC
Andre, Allen any clue about this ?
Comment 2 Andre Heinecke 2011-07-11 07:47:48 UTC
If you can reproduce this reliably this is a good thing, it has been reported to me from some users but only as "sometimes" behavior and we have not found the trigger.

It would be very helpful if you could do the following:
1. > Go to you Kontact installation folders /bin directory and start kdebugdialog > and select all debug output there
2. Download DebugView ( http://technet.microsoft.com/en-us/sysinternals/bb896647 )
3. Start Kontact, start debugview then close kontact and attach the log to this bugreport

As workarounds i can offer:
a) Start the taskmanager and kill the kontact process manually
b) In you Kontact/bin installation folder there is a killkde.bat this will also terminate everything.
Comment 3 Andre Heinecke 2011-07-15 07:38:41 UTC
This might be a duplicate of Bug 222878 https://bugs.kde.org/show_bug.cgi?id=222878
Comment 4 Heiner Markert 2011-07-16 19:01:50 UTC
(In reply to comment #2)

Unfortunatly, today I was not able to reproduce the bug anymore. Although I did not use my Windows system since writing the bug, besides installing some security updates, the problem seems to have disappeared. When I wrote the report, I tried to reboot my machine two times, and was able to reproduce the behavior reliably.

When I am able to reproduce, I will send the requested attachment. However, I have no idea what could have changed on my system.
Comment 5 Christophe Marin 2011-07-16 19:30:52 UTC
Thank you for the feedback. Feel free to reopen this report when you get more information
Comment 6 Andre Heinecke 2011-07-17 10:56:58 UTC
Hi, after debugging this myself a bit i do not need your debug output anymore Heiner, thanks but i am pretty sure now that i know what happens (But still not why ;) ). There is a hanging job that maintains a reference to the kontact process and thus will stop it from closing. I am now ~90% sure that this is the same problem described in BUG 222878 so i am marking this as duplicate.

*** This bug has been marked as a duplicate of bug 222878 ***