Bug 275846 - pager settings does not remember the number of rows of virtual desktops
Summary: pager settings does not remember the number of rows of virtual desktops
Status: RESOLVED UNMAINTAINED
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.8.1
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-16 21:51 UTC by illumilore
Modified: 2018-06-08 19:05 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch for 4.7.1 pager (kubuntu kde-workspace-4.7.1 package) (1.92 KB, patch)
2011-10-21 19:22 UTC, migrus123
Details

Note You need to log in before you can comment on or make changes to this bug.
Description illumilore 2011-06-16 21:51:53 UTC
Version:           unspecified (using KDE 4.6.4) 
OS:                Linux

I normally have the number of rows of virtual desktops set to 1 via the pager settings, with 4 total desktops. Every session restart, kde starts acting like there are 2 rows (even though the pager display still shows only one row), so when switching from the 2nd to the 3rd virtual desktop, the cube animation flips back to the left and then down instead of simply to the right. Every session restart I have to go into the pager settings, then change the rows to something else and hit apply, then set it back to one and hit apply to fix this.

Reproducible: Always
Comment 1 migrus123 2011-08-19 23:00:39 UTC
Kubuntu 11.04 (KDE 4.6.2a-0ubuntu5.1)

Having the same problem and the same workaround to toggle the pager setting.

Have a 4x3 virtual desktop setup, that shows as 4x3 in the pager when
logging in but is treated as 6x2 by kwin when moving around (start in
top left, key command to move one down moves one down and 2 right on
the pager).

Changing the pager layout changes (after a delay) the rows setting in
.kde/share/config/plasma-desktop-appletsrc:

[AppletGlobals][plasma_applet_pager]
rows=3

But this file has the correct value when the problem happens. Another detail is that logging out and logging back in does not trigger the problem for me, I have to reboot.

Is 2 rows the default value for kwin? Are settings read by some daemon and not kwin directly, and could there be some problem with it not notifying kwin successfully on a fresh boot?
Comment 2 Tiger 2011-09-02 19:40:11 UTC
(In reply to comment #1)

> Is 2 rows the default value for kwin? Are settings read by some daemon and not
> kwin directly, and could there be some problem with it not notifying kwin
> successfully on a fresh boot?

I have the same behaviour here, and it happens on KDE 4.7
I'm running Gentoo Linux ~amd64
I'll see on next reboot if cleaning /var/tmp/kde-* and /tmp/kde-* (did it after leaving X environement)
I saw a patch for this but it was suposed to be in the 4.7* I recently upgraded to this version because I had this trouble on kde 4.6 and some others one.
Comment 3 Tiger 2011-09-05 17:20:07 UTC
(In reply to comment #2)
> (In reply to comment #1)
> 
> > Is 2 rows the default value for kwin? Are settings read by some daemon and not
> > kwin directly, and could there be some problem with it not notifying kwin
> > successfully on a fresh boot?
> 
> I have the same behaviour here, and it happens on KDE 4.7
> I'm running Gentoo Linux ~amd64
> I'll see on next reboot if cleaning /var/tmp/kde-* and /tmp/kde-* (did it after
> leaving X environement)
> I saw a patch for this but it was suposed to be in the 4.7* I recently upgraded
> to this version because I had this trouble on kde 4.6 and some others one.

Nvm.
It is fixed. I made mistake, I had only some part of KDE 4.7 libs & packages.
 /me points at kde-base/kdebase-startkde
Comment 4 illumilore 2011-09-29 20:26:54 UTC
This is still not fixed in 4.7.1
Comment 5 migrus123 2011-10-21 19:22:18 UTC
Created attachment 64766 [details]
Patch for 4.7.1 pager (kubuntu kde-workspace-4.7.1 package)

Have looked a bit at this now.

At startup the pager calculates the desktop size correctly, but it does so before it has m_desktopLayoutOwner so it can't actually update the layout. Later init() is called, and it then has the m_desktopLayoutOwner so it could update but the code thinks the desktop size was set to the same thing last time so it incorrectly leaves it as-is.

Adding a variable to track if the layout actually was set seems to fix the
problem for me.

In 4.8 this code is changed and kwin handles desktop layout, not the pager, and I think it avoids this problem.
https://projects.kde.org/projects/kde/kde-workspace/repository/revisions/4bf7761307a2453a63d918c60e13c26980727830
Comment 6 Beat Wolf 2011-11-21 22:50:28 UTC
since this seems to be fixed in 4.8, can this report be closed?
Comment 7 Michael Mikowski 2011-12-16 18:21:36 UTC
I have confirmed it is present on KDE 4.7.4 on Kubuntu 11.10 (the latest 4.7.x series as of this writing).  On login, the desktops always defaults to 2 rows even though the pager shows one.  The work around - which I have to do every single day - is to open the pager, change the rows to 2 and apply, then revert back to 1 row and apply.

This is obviously confirmed by many people.  Could it be marked as such?  Until it is *confirmed fixed* in 4.8, closing it seems premature.

Might I also suggest we default to 1 row?  I find it much more usable - the Mac has changed to a single row and now people who never used virtual desktops before have adopted them.
Comment 8 smkozasa 2011-12-27 19:22:20 UTC
I can confirm this bug in Kubuntu 11.10 Oneiric. It did NOT happen with 11.04 natty and previous versions. My system is up-to-date, but my  KDE version seems to be 4.7.3, although Mr. Mikowski has reported 4.7.4. I use 3 rows (lines) and 1 column. I mean that my 3 desktops are in a single COLUMN, one above or below the other.

BUT my problem happens with the COLUMNS, not the rows. Every login I have to change back to 1 column, since I prefer a vertical panel to the left.

I suggest it defaults to 1 column and 3 to 4 rows (lines), much more logic to switch desktop with the mouse wheel and to use a vertical panel.
Comment 9 Danni Coy 2012-01-04 13:51:17 UTC
can confirm this is an issue with 4.8rc 1 
pager is set to 1 column but defaults back to 2 after reboot.
Comment 10 Olaf Lenz 2012-02-03 08:50:45 UTC
Confirmed on an up-to-date Sabayon with KDE 4.7.4. Most annoying.
Comment 11 smkozasa 2012-02-03 11:05:42 UTC
I can also confirm that Kubuntu has upgraded my KDE to 4.7.4 and still the bug persists.
Comment 12 Claer 2012-02-03 11:38:44 UTC
I'm using KDE 4.8.0 on gentoo (~x86) and the problem still persists
Comment 13 illumilore 2012-03-08 18:46:52 UTC
Bug seems fixed for me in 4.8, although a bunch of other new bugs were created after the upgrade, of course...
Comment 14 stefan.bauer 2012-04-23 09:27:38 UTC
I can confirm this bug with KDE 4.8.1 in combination with openbox as windowmanager.

I'd like to have a 1 column 4 row setup, but on every session start, I get 4 columns 1 row. The config dialog says "0 rows" when I open it. Setting the value to 4 gives me the layout I want.

Please consider the usage of window managers other than kwin when fixing this bug.
Comment 15 stefan.bauer 2012-04-23 09:28:31 UTC
*** This bug has been confirmed by popular vote. ***
Comment 16 Coacher 2014-01-29 10:42:02 UTC
I can confirm this bug with KDE SC 4.12.1 and openbox-3.5.2 on Gentoo amd64.

If I choose normal KDE session, then number of rows (2) is preserved.
If I choose KDE/Openbox session, then number of rows is reset to 0.
Comment 17 Coacher 2014-01-29 11:14:48 UTC
(In reply to comment #16)
> I can confirm this bug with KDE SC 4.12.1 and openbox-3.5.2 on Gentoo amd64.
> 
> If I choose normal KDE session, then number of rows (2) is preserved.
> If I choose KDE/Openbox session, then number of rows is reset to 0.

Hmm, it seems non-Kwin WMs, i.e. EWMH-compliant, like Openbox are not supported due to this change: https://bugs.kde.org/show_bug.cgi?id=277965#c7
Comment 18 Nate Graham 2018-06-08 19:05:55 UTC
Hello!

This bug report was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this bug is already resolved in Plasma 5.

Accordingly, we hope you understand why we must close this bug report. If the issue described  here is still present in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham