Bug 275818 - K3b crashes after auto dismounting a DVD FS before opening "Copy Medium" option
Summary: K3b crashes after auto dismounting a DVD FS before opening "Copy Medium" option
Status: RESOLVED DUPLICATE of bug 187066
Alias: None
Product: k3b
Classification: Applications
Component: general (show other bugs)
Version: 1.91.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michał Małek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-16 15:19 UTC by Barnendu Goswami
Modified: 2011-09-07 20:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Barnendu Goswami 2011-06-16 15:19:16 UTC
Application: k3b (1.91.0)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.34-020634-generic i686
Distribution: Ubuntu 10.04.2 LTS

-- Information about the crash:
DVD had been mounted and folders traversed, when K3b started and "Tools">"Copy Medium" chosen.

At that point the DVD was auto/forced dismounted, and just as the dialogue appeared or was about to appear, K3b crashed and brought up the error reporting wizard.

 -- Backtrace:
Application: K3b (k3b), signal: Segmentation fault
[Current thread is 1 (Thread 0xb37fc710 (LWP 2067))]

Thread 3 (Thread 0xadddfb70 (LWP 2328)):
#0  0xb3bf6e16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0xb53876fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0xb538c825 in QTimerInfoList::updateCurrentTime (this=0xb05043b4) at kernel/qeventdispatcher_unix.cpp:340
#3  0xb538c86a in QTimerInfoList::timerWait (this=0xb05043b4, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0xb538a818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xadddf0cc) at kernel/qeventdispatcher_glib.cpp:136
#5  0xb538a8a5 in timerSourcePrepare (source=0x0, timeout=0xb3bfaff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0xb3b67aca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0xb3b67ee9 in ?? () from /lib/libglib-2.0.so.0
#8  0xb3b684b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0xb538a60f in QEventDispatcherGlib::processEvents (this=0x8ca1150, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0xb535d059 in QEventLoop::processEvents (this=0xadddf290, flags=) at kernel/qeventloop.cpp:149
#11 0xb535d4aa in QEventLoop::exec (this=0xadddf290, flags=...) at kernel/qeventloop.cpp:201
#12 0xb52595a8 in QThread::exec (this=0x85f2c08) at thread/qthread.cpp:487
#13 0xb533cc1b in QInotifyFileSystemWatcherEngine::run (this=0x85f2c08) at io/qfilesystemwatcher_inotify.cpp:248
#14 0xb525c32e in QThreadPrivate::start (arg=0x85f2c08) at thread/qthread_unix.cpp:248
#15 0xb51ca96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0xb4507a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xad5deb70 (LWP 3315)):
#0  0xb5256d8c in QBasicAtomicInt::testAndSetOrdered (this=0xad5de0f4) at ../../include/QtCore/../../src/corelib/arch/qatomic_i386.h:144
#1  QBasicAtomicInt::testAndSetRelease (this=0xad5de0f4) at ../../include/QtCore/../../src/corelib/arch/qatomic_i386.h:271
#2  QMutex::unlock (this=0xad5de0f4) at thread/qmutex.cpp:383
#3  0xb7649837 in K3b::Core::unblockDevice(K3b::Device::Device*) () from /usr/lib/libk3blib.so.6
#4  0xb76be2af in ?? () from /usr/lib/libk3blib.so.6
#5  0xb765b13b in ?? () from /usr/lib/libk3blib.so.6
#6  0xb525c32e in QThreadPrivate::start (arg=0xb05043e8) at thread/qthread_unix.cpp:248
#7  0xb51ca96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0xb4507a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb37fc710 (LWP 2067)):
[KCrash Handler]
#6  0xb73b7a08 in KFileItem::isDir (this=0xbfb264a8) at ../../kio/kio/kfileitem.cpp:975
#7  0xb7554575 in KDirOperator::Private::_k_slotExpandToUrl (this=0x94f4080, index=...) at ../../kfile/kdiroperator.cpp:2558
#8  0xb755a22a in KDirOperator::qt_metacall (this=0x94eef90, _c=QMetaObject::InvokeMetaMethod, _id=69, _a=0xbfb265e8) at ./kdiroperator.moc:261
#9  0xb5363c9a in QMetaObject::metacall (object=0x94eef90, cl=3216139432, idx=96, argv=0xbfb265e8) at kernel/qmetaobject.cpp:237
#10 0xb53723d5 in QMetaObject::activate (sender=0x8754d50, m=0x81f2d44, local_signal_index=0, argv=0xbfb265e8) at kernel/qobject.cpp:3293
#11 0xb73a2323 in KDirModel::expand (this=0x8754d50, _t1=...) at ./kdirmodel.moc:104
#12 0xb73a5a58 in KDirModelPrivate::_k_slotNewItems (this=0x94f3c60, directoryUrl=..., items=...) at ../../kio/kio/kdirmodel.cpp:441
#13 0xb73a88b7 in KDirModel::qt_metacall (this=0x8754d50, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0xbfb26914) at ./kdirmodel.moc:88
#14 0xb5363c9a in QMetaObject::metacall (object=0x8754d50, cl=3216139432, idx=26, argv=0xbfb26914) at kernel/qmetaobject.cpp:237
#15 0xb53723d5 in QMetaObject::activate (sender=0x8754b80, m=0xb7517fbc, local_signal_index=10, argv=0xbfb26914) at kernel/qobject.cpp:3293
#16 0xb7388e99 in KDirLister::itemsAdded (this=0x8754b80, _t1=..., _t2=...) at ./kdirlister.moc:274
#17 0xb738a096 in KDirLister::Private::emitItems (this=0x94f4218) at ../../kio/kio/kdirlister.cpp:2359
#18 0xb73966c5 in KDirListerCache::slotUpdateResult (this=0x83f3ac0, j=0x8a3f228) at ../../kio/kio/kdirlister.cpp:1688
#19 0xb739e227 in KDirListerCache::qt_metacall (this=0x83f3ac0, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0xbfb26c38) at ./kdirlister_p.moc:108
#20 0xb5363c9a in QMetaObject::metacall (object=0x83f3ac0, cl=3216139432, idx=15, argv=0xbfb26c38) at kernel/qmetaobject.cpp:237
#21 0xb53723d5 in QMetaObject::activate (sender=0x8a3f228, m=0xb56c7c88, local_signal_index=3, argv=0xbfb26c38) at kernel/qobject.cpp:3293
#22 0xb55591e3 in KJob::result (this=0x8a3f228, _t1=0x8a3f228) at ./kjob.moc:194
#23 0xb5559548 in KJob::emitResult (this=0x8a3f228) at ../../kdecore/jobs/kjob.cpp:312
#24 0xb736ac60 in KIO::SimpleJob::slotFinished (this=0x8a3f228) at ../../kio/kio/job.cpp:517
#25 0xb736adce in KIO::ListJob::slotFinished (this=0x8a3f228) at ../../kio/kio/job.cpp:2544
#26 0xb736e9de in KIO::ListJob::qt_metacall (this=0x8a3f228, _c=QMetaObject::InvokeMetaMethod, _id=43, _a=0xbfb26e9c) at ./jobclasses.moc:818
#27 0xb5363c9a in QMetaObject::metacall (object=0x8a3f228, cl=3216139432, idx=43, argv=0xbfb26e9c) at kernel/qmetaobject.cpp:237
#28 0xb53723d5 in QMetaObject::activate (sender=0x8545bd8, m=0xb7519f44, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3293
#29 0xb74352a7 in KIO::SlaveInterface::finished (this=0x8545bd8) at ./slaveinterface.moc:171
#30 0xb74385cd in KIO::SlaveInterface::dispatch (this=0x8545bd8, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#31 0xb7435763 in KIO::SlaveInterface::dispatch (this=0x8545bd8) at ../../kio/kio/slaveinterface.cpp:91
#32 0xb7428c28 in KIO::Slave::gotInput (this=0x8545bd8) at ../../kio/kio/slave.cpp:324
#33 0xb7428e33 in KIO::Slave::qt_metacall (this=0x8545bd8, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbfb271ac) at ./slave.moc:82
#34 0xb5363c9a in QMetaObject::metacall (object=0x8545bd8, cl=3216139432, idx=30, argv=0xbfb271ac) at kernel/qmetaobject.cpp:237
#35 0xb53723d5 in QMetaObject::activate (sender=0x8577b20, m=0xb7516820, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3293
#36 0xb7332bd7 in KIO::Connection::readyRead (this=0x8577b20) at ./connection.moc:92
#37 0xb7334f8e in KIO::ConnectionPrivate::dequeue (this=0x85e58d8) at ../../kio/kio/connection.cpp:82
#38 0xb73350be in KIO::Connection::qt_metacall (this=0x8577b20, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x8a0c418) at ./connection.moc:79
#39 0xb5363c9a in QMetaObject::metacall (object=0x8577b20, cl=3216139432, idx=5, argv=0x8a0c418) at kernel/qmetaobject.cpp:237
#40 0xb536e336 in QMetaCallEvent::placeMetaCall (this=0x95a51e8, object=0x8577b20) at kernel/qobject.cpp:561
#41 0xb536f3fe in QObject::event (this=0x8577b20, e=0x95a51e8) at kernel/qobject.cpp:1248
#42 0xb48044dc in QApplicationPrivate::notify_helper (this=0x82388d0, receiver=0x8577b20, e=0x95a51e8) at kernel/qapplication.cpp:4300
#43 0xb480b05e in QApplication::notify (this=0xbfb2a290, receiver=0x8577b20, e=0x95a51e8) at kernel/qapplication.cpp:3704
#44 0xb5a7540a in KApplication::notify (this=0xbfb2a290, receiver=0x8577b20, event=0x95a51e8) at ../../kdeui/kernel/kapplication.cpp:302
#45 0xb535ea3b in QCoreApplication::notifyInternal (this=0xbfb2a290, receiver=0x8577b20, event=0x95a51e8) at kernel/qcoreapplication.cpp:704
#46 0xb5361473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x820f710) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#47 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x820f710) at kernel/qcoreapplication.cpp:1345
#48 0xb53615dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#49 0xb538aadf in QCoreApplication::sendPostedEvents (s=0x8245f10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#50 postEventSourceDispatch (s=0x8245f10) at kernel/qeventdispatcher_glib.cpp:276
#51 0xb3b645e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#52 0xb3b682d8 in ?? () from /lib/libglib-2.0.so.0
#53 0xb3b684b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#54 0xb538a5d5 in QEventDispatcherGlib::processEvents (this=0x820f2a8, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#55 0xb48c4135 in QGuiEventDispatcherGlib::processEvents (this=0x820f2a8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#56 0xb535d059 in QEventLoop::processEvents (this=0xbfb27a60, flags=) at kernel/qeventloop.cpp:149
#57 0xb535d4aa in QEventLoop::exec (this=0xbfb27a60, flags=...) at kernel/qeventloop.cpp:201
#58 0xb4d434f3 in QDialog::exec (this=0x9564c00) at dialogs/qdialog.cpp:546
#59 0x0818794a in _start ()

This bug may be a duplicate of or related to bug 187066.

Possible duplicates by query: bug 262181, bug 260577.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-09-07 20:11:37 UTC

*** This bug has been marked as a duplicate of bug 187066 ***