Bug 275766 - Advanced color selector cannot pick colors from additional columns
Summary: Advanced color selector cannot pick colors from additional columns
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Dockers (show other bugs)
Version: git master (please specify the git hash!)
Platform: Compiled Sources Linux
: NOR normal
Target Milestone: ---
Assignee: Adam C
URL:
Keywords:
: 276014 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-15 23:07 UTC by pentalis
Modified: 2011-07-11 20:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshots displaying the displaced and ghost swatch effects, they occur simultaneously. (33.33 KB, image/png)
2011-06-15 23:07 UTC, pentalis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pentalis 2011-06-15 23:07:34 UTC
Created attachment 61039 [details]
Screenshots displaying the displaced and ghost swatch effects, they occur simultaneously.

The advanced color selector docker cannot pick colors from swatches on the 2nd, 3rd or 4th column unless there is enough colors on the swatch list to completely fill the columns.

The selector will let the user pick colors from "transparent" places (areas without swatch) in the first column, as if the swatches were located in a ghost column. It will also show the incorrect color when clicking on actual swatches, as if they were displaced.

Both effects are shown in the attachment.


How to reproduce:
--Make a new image.
--Configure the advanced color selector to display 2 or more columns of swatches (in the Color Patches menu).
--Paint with different colors.
--Try to pick colors from the swatches on the 2nd column: it won't work.
--Try to pick colors from the swatches on the 1st column: the wrong color will be picked.
--Try to pick colors from transparent areas beyond the swatches on the 1st column (see screenshot): a color will be selected (belonging to one of the columns).


Expected result:
--Swatches pick the colors they display and no colors are picked from areas without swatches.
Comment 1 Adam C 2011-06-19 13:46:09 UTC
*** Bug 276014 has been marked as a duplicate of this bug. ***
Comment 2 Adam C 2011-07-11 20:57:44 UTC
> Git commit 2f8a541f316add52e92e8032a125c87ba4e72108 by Adam Celarek.
> Committed on 11/07/2011 at 22:55.
> Pushed by adamc into branch 'master'.
>  
> fix bug, where color patches with autoscroll didn't work