Bug 275687 - Artifacts when scrolling in album GUI
Summary: Artifacts when scrolling in album GUI
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Albums-MainView (show other bugs)
Version: 2.3.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-15 08:38 UTC by Frederic Grelot
Modified: 2013-11-27 23:17 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.0.0


Attachments
buggy view (217.57 KB, image/png)
2011-06-15 08:38 UTC, Frederic Grelot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Grelot 2011-06-15 08:38:42 UTC
Created attachment 61006 [details]
buggy view

Version:           1.9.0 (using KDE 4.6.3) 
OS:                Linux

See attached screenshot : When I am in Album GUI, browsing my photos, and whenever I scroll **while the mouse is over one of the photos**, the blue rectangle that surround the pictures appears somewhat everywhere.
If the mouse cursor is not over one of the photos (for example, if it is over the scroll bar itself), everything is fine.
The only way to get a clear view again is to scroll enough to make the buggy part disappear, then go back to that part (with the cursor outside the area of course).

Reproducible: Always

Steps to Reproduce:
As said before : mouse over one of the photo, scroll.



I'm running Fedora 15, with Gnome 3 (gnome-shell enabled).
lspci :
01:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 9500M GS] (rev a1)
I'm using the nouveau driver.
I didn't tried with the binary nvidia driver, tell me if it is needed (although I would prefer not to install it...)
Comment 1 caulier.gilles 2011-06-15 08:42:57 UTC
I never see this dysfunction before. Sound like a problem with your video driver.

Gilles Caulier
Comment 2 Frederic Grelot 2011-06-15 09:48:41 UTC
Well, I quite agree with you and I think this has something to see with the video driver (which is why I posted this information).
However, it is really the only place I have seen this on my PC, it does never NOT happen in digikam, and it does never happen anywhere else...
Still, I am not using that many KDE applications, since I'm under Gnome3/Gnome-shell, maybe you have an idea of an other application I could test, which would use the same kind of component as digikam? That way, I could fill an other bug, either for nouveau, KDE, or QT...

Thanks for everything else anyway, and I hope this will help!

Frederic.
Comment 3 Frederic Grelot 2011-06-15 20:48:27 UTC
Still, it has to do with the way this component is used in Album GUI: there is no problem in the window where I can import pictures from an SD card (whereas there are thumbnails), nor in the left navigation bar of the editor...
Comment 4 Frederic Grelot 2011-07-25 21:48:08 UTC
I understand it has not been worked out if I'm the only one to see it, but I can say that the bug is still there for me with 2.0.0-rc.
What is strange is that there is no problem with the editor's thumbbar, or the scrolling view when importing pictures.
It happens only with the album view, either like in the attachement of the first message, or even with the preview panel open : in this case, I have to move my mouse over the pictures of the scrolling bar (with the thumbnails, on top) to get them right...
Comment 5 pochini 2011-10-22 22:07:59 UTC
Exactly the same problem here.
I believe this is a quite old bug. Before my update to kdelibs-4.6.5 (I used 4.3.x IIRC) the bug was present, but it was much less annoying because its only effect was to not delete the frame around a thumbnail after the mouse pointer moved away. As Fredefic wrote, it happened (and happens) in the album window only.
I have a powermac dual-G4 with ATI card.
Comment 6 caulier.gilles 2011-12-14 09:27:20 UTC
Frederic,

I never reproduce this problem here.

It still valid using digiKam 2.x serie ?

Gilles Caulier
Comment 7 Frederic Grelot 2011-12-14 10:36:24 UTC
Unfortunately (for digikam, not for me...), I changed my computer inbetween : I trashed my Nvidia card for an AMD, and I haven't seen the problem since.
I highly suspect this is related to the card and/or driver, so I can't say for sure the bug can be closed (I saw it with the first 2.x versions, before changing computer).
Maybe driver updates that happened since then have fixed it...

I change it to NEEDSINFO/WORKSFORME, so that if anybody else sees it, he can see it here (in particular pochini in comment #5).

Frederic.
Comment 8 pochini 2011-12-14 21:09:03 UTC
I have an ATI card and the problem still exists in 2.4.1. It has something to do with the frame around the thumbnails. If I keep the mouse pointer on the space between them it scrolls without corrupting the screen.
Since I'm the only known earthling who still have this problem I guess I have to debug this myself. Can someone tell me where is the code which manages that part of the GUI ?
Comment 10 Mark Pearson 2012-01-06 03:17:21 UTC
I have exactly the same problem with digiKam version 2.3.0 and KDE 4.6.5

I have noticed that any scrolling activity (using the mousewheel or scrollbar) while the mouse pointer is over the actual content (client) area of the album thumbnails widget causes GUI artefacts.

Conversely, there are NO artefacts when scrolling with the mouse pointer outside of the content area - e.g. using the mousewheel while the pointer is over the scrollbar or grabbing the scrollbar and moving the mouse pointer up and down while it is outside of the widget altogether.

I am running Digikam on a Macbook Pro with an ATI Mobility Radeon X1600.
Comment 11 caulier.gilles 2013-11-25 16:51:54 UTC
Mark,

It still reproducible with digiKam 3.5.0 ?

Gilles Caulier
Comment 12 Mark Pearson 2013-11-26 10:05:12 UTC
I am currently using Digikam 3.1.0 on KDE 4.10.5 on a Dell XPS 15z which has an NVIDIA video card, so my hardware platform, KDE version and Digikam version have changed since commenting on this bug last time. However, I have not seen this bug for quite some time.
Comment 13 caulier.gilles 2013-11-26 13:01:01 UTC
Ok, thanks for the feedback...

Gilles Caulier
Comment 14 pochini 2013-11-27 23:17:35 UTC
I haven't the powermac anymore. With my new pc the bug does not half-draw a couple of rows of thumbnails (as in Frederic's screenshot), but it causes the frame around them to stay after the page has been scrolled, as I wrote in comment #5. I tried to figure out what happens without success. Perhaps I'll try again.