Bug 275323 - Amarok frozen, Plasma crashed
Summary: Amarok frozen, Plasma crashed
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-10 07:31 UTC by Kevin
Modified: 2011-06-10 22:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin 2011-06-10 07:31:52 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
Amarok had just frozen while attempting to listen to online music, so I was quitting it and plasma crashed.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb772aad0 (LWP 1733))]

Thread 4 (Thread 0xb557eb70 (LWP 1735)):
#0  0x0280236b in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00969616 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x018790e1 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01879524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01404577 in QEventDispatcherGlib::processEvents (this=0x85503d8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x013d6289 in QEventLoop::processEvents (this=0xb557e280, flags=...) at kernel/qeventloop.cpp:149
#6  0x013d6522 in QEventLoop::exec (this=0xb557e280, flags=...) at kernel/qeventloop.cpp:201
#7  0x012e02a0 in QThread::exec (this=0x8550d58) at thread/qthread.cpp:492
#8  0x013b7fdb in QInotifyFileSystemWatcherEngine::run (this=0x8550d58) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x012e2da2 in QThreadPrivate::start (arg=0x8550d58) at thread/qthread_unix.cpp:320
#10 0x027ffe99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x0095b73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xae559b70 (LWP 1737)):
#0  0x00d95416 in __kernel_vsyscall ()
#1  0x0094cf76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0188984b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x018791af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01879524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x01404577 in QEventDispatcherGlib::processEvents (this=0x85c7110, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x013d6289 in QEventLoop::processEvents (this=0xae559280, flags=...) at kernel/qeventloop.cpp:149
#7  0x013d6522 in QEventLoop::exec (this=0xae559280, flags=...) at kernel/qeventloop.cpp:201
#8  0x012e02a0 in QThread::exec (this=0x85c5a80) at thread/qthread.cpp:492
#9  0x013b7fdb in QInotifyFileSystemWatcherEngine::run (this=0x85c5a80) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x012e2da2 in QThreadPrivate::start (arg=0x85c5a80) at thread/qthread_unix.cpp:320
#11 0x027ffe99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0095b73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xad557b70 (LWP 1742)):
#0  0x01889840 in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x018791af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x0187992b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x04b56304 in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#4  0x018a22df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x027ffe99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x0095b73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb772aad0 (LWP 1733)):
[KCrash Handler]
#7  0x00f18454 in QString (this=0x82d0048, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0x82d0048, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x00f1e352 in KIconLoaderPrivate::makeCacheKey (this=0x82d0034, name=..., group=KIconLoader::Desktop, overlays=..., size=16, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x00f25398 in KIconLoader::loadIcon (this=0x8a1e378, _name=..., group=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x00f1cd76 in KIconEngine::pixmap (this=0x86b9980, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x04102ca2 in QIcon::pixmap (this=0xbf86adc0, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0x0245c9b8 in Oxygen::Style::drawMenuItemControl (this=0x8259e40, option=0xbf86ad74, painter=0xbf86aedc, widget=0x8c9fdc0) at ../../../kstyles/oxygen/oxygenstyle.cpp:4661
#14 0x024395d2 in Oxygen::Style::drawControl (this=0x8259e40, element=QStyle::CE_MenuItem, option=0xbf86ad74, painter=0xbf86aedc, widget=0x8c9fdc0) at ../../../kstyles/oxygen/oxygenstyle.cpp:1080
#15 0x044da1cd in QMenu::paintEvent (this=0x8c9fdc0, e=0xbf86b504) at widgets/qmenu.cpp:2181
#16 0x040a518e in QWidget::event (this=0x8c9fdc0, event=0xbf86b504) at kernel/qwidget.cpp:8405
#17 0x044df4d7 in QMenu::event (this=0x8c9fdc0, e=0xbf86b504) at widgets/qmenu.cpp:2415
#18 0x0404cd24 in QApplicationPrivate::notify_helper (this=0x8231ba8, receiver=0x8c9fdc0, e=0xbf86b504) at kernel/qapplication.cpp:4462
#19 0x0405197b in QApplication::notify (this=0x8228570, receiver=0x8c9fdc0, e=0xbf86b504) at kernel/qapplication.cpp:4427
#20 0x00f773ca in KApplication::notify (this=0x8228570, receiver=0x8c9fdc0, event=0xbf86b504) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x013d70bb in QCoreApplication::notifyInternal (this=0x8228570, receiver=0x8c9fdc0, event=0xbf86b504) at kernel/qcoreapplication.cpp:731
#22 0x040a1f0c in sendSpontaneousEvent (this=0x8ca0f00, pdev=0x8ca3734, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x8bed1f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 QWidgetPrivate::drawWidget (this=0x8ca0f00, pdev=0x8ca3734, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x8bed1f0) at kernel/qwidget.cpp:5492
#24 0x0427d908 in QWidgetBackingStore::sync (this=0x8bed1f0) at painting/qbackingstore.cpp:1333
#25 0x0427dcca in QWidgetBackingStore::sync (this=0x8bed1f0, exposedWidget=0x8c9fdc0, exposedRegion=...) at painting/qbackingstore.cpp:1130
#26 0x04097782 in QWidgetPrivate::syncBackingStore (this=0x8ca0f00, region=...) at kernel/qwidget.cpp:1857
#27 0x040d4a16 in QETWidget::translatePaintEvent (this=0x8c9fdc0, event=0xbf86bd4c) at kernel/qapplication_x11.cpp:5448
#28 0x040d5a5d in QApplication::x11ProcessEvent (this=0x8228570, event=0xbf86bd4c) at kernel/qapplication_x11.cpp:3578
#29 0x04100b84 in x11EventSourceDispatch (s=0x8237a08, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#30 0x01878aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0x01879270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0x01879524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0x0140453c in QEventDispatcherGlib::processEvents (this=0x81daaa8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#34 0x04100775 in QGuiEventDispatcherGlib::processEvents (this=0x81daaa8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x013d6289 in QEventLoop::processEvents (this=0xbf86c014, flags=...) at kernel/qeventloop.cpp:149
#36 0x013d6522 in QEventLoop::exec (this=0xbf86c014, flags=...) at kernel/qeventloop.cpp:201
#37 0x013daecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#38 0x0404a8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#39 0x00a205a5 in kdemain (argc=1, argv=0xbf86c224) at ../../../../plasma/desktop/shell/main.cpp:118
#40 0x080485cb in main (argc=1, argv=0xbf86c224) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 275138.

Possible duplicates by query: bug 275310, bug 275246, bug 275227, bug 275138, bug 275086.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-06-10 22:05:06 UTC

*** This bug has been marked as a duplicate of bug 258706 ***