Bug 275275 - Akonadi imap crash [KMime::Content::hasContent, Akonadi::SerializerPluginMail::parts, Akonadi::ItemSerializer::parts]
Summary: Akonadi imap crash [KMime::Content::hasContent, Akonadi::SerializerPluginMail...
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: triaged
: 289692 289929 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-09 12:08 UTC by Robet Piasek
Modified: 2018-10-27 02:29 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.38 KB, text/plain)
2012-02-11 14:48 UTC, Lastique
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robet Piasek 2011-06-09 12:08:44 UTC
Application: akonadi_imap_resource (0.1)
KDE Platform Version: 4.6.3 (4.6.3) (Compiled from sources)
Qt Version: 4.7.3
Operating System: Linux 2.6.39-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

When akonadi was syncing IMAP account I turned off WIFI and connected the cable. At this point it crashed. Tried that few times and can reproduce most of the time, but not always.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Akonadi Resource (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3fd52b5760 (LWP 32010))]

Thread 3 (Thread 0x7f3fc1414700 (LWP 32012)):
#0  0x00007f3fd05f093e in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f3fcfa78575 in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f3fcfa789fd in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f3fd4729e96 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f3fd46fe322 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007f3fd46fe564 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007f3fd46146a4 in QThread::exec() () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007f3fd33b6323 in KIMAP::SessionThread::run() () from /usr/lib64/libkimap.so.4
#8  0x00007f3fd4616ef5 in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#9  0x00007f3fd05ecd4c in start_thread () from /lib64/libpthread.so.0
#10 0x00007f3fd0d3540d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f3fbbdf9700 (LWP 32016)):
#0  0x00007f3fd0d2c5e3 in poll () from /lib64/libc.so.6
#1  0x00007f3fcfa784cd in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f3fcfa789fd in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f3fd4729e96 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f3fd46fe322 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007f3fd46fe564 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007f3fd46146a4 in QThread::exec() () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007f3fd33b6323 in KIMAP::SessionThread::run() () from /usr/lib64/libkimap.so.4
#8  0x00007f3fd4616ef5 in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#9  0x00007f3fd05ecd4c in start_thread () from /lib64/libpthread.so.0
#10 0x00007f3fd0d3540d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f3fd52b5760 (LWP 32010)):
[KCrash Handler]
#6  0x00007f3fd2a1b4aa in KMime::Content::hasContent() const () from /usr/lib64/libkmime.so.4
#7  0x00007f3fbb3f35fa in Akonadi::SerializerPluginMail::parts(Akonadi::Item const&) const () from /usr/lib64/kde4/akonadi_serializer_mail.so
#8  0x00007f3fd4dd63a2 in Akonadi::ItemSerializer::parts(Akonadi::Item const&) () from /usr/lib64/libakonadi-kde.so.4
#9  0x00007f3fd4dc31b9 in Akonadi::Item::loadedPayloadParts() const () from /usr/lib64/libakonadi-kde.so.4
#10 0x00007f3fd4dc7dac in Akonadi::ItemCreateJob::ItemCreateJob(Akonadi::Item const&, Akonadi::Collection const&, QObject*) () from /usr/lib64/libakonadi-kde.so.4
#11 0x00007f3fd4ddcc35 in Akonadi::ItemSync::Private::createLocalItem(Akonadi::Item const&) () from /usr/lib64/libakonadi-kde.so.4
#12 0x00007f3fd4dddcfb in Akonadi::ItemSync::Private::processItems() () from /usr/lib64/libakonadi-kde.so.4
#13 0x00007f3fd4dde069 in Akonadi::ItemSync::Private::execute() () from /usr/lib64/libakonadi-kde.so.4
#14 0x00007f3fd4dde614 in Akonadi::ItemSync::setFullSyncItems(QList<Akonadi::Item> const&) () from /usr/lib64/libakonadi-kde.so.4
#15 0x00007f3fd4dff2cc in Akonadi::ResourceBase::itemsRetrieved(QList<Akonadi::Item> const&) () from /usr/lib64/libakonadi-kde.so.4
#16 0x000000000045ba09 in RetrieveItemsTask::onHeadersReceived(QString const&, QMap<long long, long long> const&, QMap<long long, long long> const&, QMap<long long, QList<QByteArray> > const&, QMap<long long, boost::shared_ptr<KMime::Message> > const&) ()
#17 0x000000000045c2a0 in RetrieveItemsTask::qt_metacall(QMetaObject::Call, int, void**) ()
#18 0x00007f3fd4713637 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/qt4/libQtCore.so.4
#19 0x00007f3fd33a18a4 in KIMAP::FetchJob::headersReceived(QString const&, QMap<long long, long long> const&, QMap<long long, long long> const&, QMap<long long, QList<QByteArray> > const&, QMap<long long, boost::shared_ptr<KMime::Message> > const&) () from /usr/lib64/libkimap.so.4
#20 0x00007f3fd33a20b9 in KIMAP::FetchJob::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkimap.so.4
#21 0x00007f3fd4713637 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/qt4/libQtCore.so.4
#22 0x00007f3fd4712e69 in QObject::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#23 0x00007f3fd3ae6334 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#24 0x00007f3fd3aeaeba in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#25 0x00007f3fd1c39d86 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#26 0x00007f3fd46fef5b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#27 0x00007f3fd472c6ee in QTimerInfoList::activateTimers() () from /usr/lib64/qt4/libQtCore.so.4
#28 0x00007f3fd4729768 in idleTimerSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/qt4/libQtCore.so.4
#29 0x00007f3fcfa77f7e in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#30 0x00007f3fcfa78768 in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#31 0x00007f3fcfa789fd in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f3fd4729e3f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#33 0x00007f3fd3b8c51e in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#34 0x00007f3fd46fe322 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#35 0x00007f3fd46fe564 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#36 0x00007f3fd47029cb in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#37 0x00007f3fd4dfdcc6 in Akonadi::ResourceBase::init(Akonadi::ResourceBase*) () from /usr/lib64/libakonadi-kde.so.4
#38 0x0000000000422d38 in main ()

Reported using DrKonqi
Comment 1 Robet Piasek 2011-06-09 12:11:23 UTC
It seems network connectivity change has nothing to do with it. It just randomly crashed few more times with same backtrace as above.
Comment 2 Christophe Giboudeaux 2011-07-13 15:01:36 UTC
(In reply to comment #1)
> It seems network connectivity change has nothing to do with it. It just
> randomly crashed few more times with same backtrace as above.

If this crash is still reproducible, please rebuild kdepimlibs and kdepim-runtime in debug mode to get a better backtrace.
Comment 3 Christophe Giboudeaux 2011-12-28 00:01:03 UTC
*** Bug 289692 has been marked as a duplicate of this bug. ***
Comment 4 Christophe Giboudeaux 2011-12-28 00:01:14 UTC
*** Bug 289929 has been marked as a duplicate of this bug. ***
Comment 5 Christophe Giboudeaux 2011-12-28 00:02:35 UTC
from bug 289692

I have been experiencing this crash since updating to 4.7.2  The migration to
Kmail2 was troublesome.  Only one imap account is causing this error.

The crash can be reproduced every time.

-- 

from bug 289929

I don't know what is happening.  This really is getting annoying.  I fire
Kontact/Kmail and without any prompting I receive this crash.  Can I repeat it?
 No.  Does it repeat? Yes.  Randomly.  This is not the place to add rants, I
know.  But this implementation of Kmail or Akonadi really is poor.  It casts a
very bad light on all of the Open Source community.  It makes all of us
lobbying and supporting Open Source look like fools for using something that
simply does not work.

The crash can be reproduced every time.
Comment 6 Christophe Giboudeaux 2011-12-28 00:03:15 UTC
As this seems reproducible for you, please install the debug package for kdepimlibs to get a better backtrace
Comment 7 Lastique 2012-02-11 14:48:38 UTC
Created attachment 68700 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.8) on KDE Platform 4.8.00 (4.8.0 "release 2" using Qt 4.8.0

My akonadi IMAP resource crashed in background. I suspect, there were connectivity issues involved (possibly, a socket operation timed out) because I have a torrent client active.

-- Backtrace (Reduced):
#6  Akonadi::ItemSync::setFullSyncItems (this=0x0, items=...) at /usr/src/debug/kdepimlibs-4.8.0/akonadi/itemsync.cpp:145
#7  0x00007f97264d7e52 in Akonadi::ResourceBase::itemsRetrieved (this=<optimized out>, items=...) at /usr/src/debug/kdepimlibs-4.8.0/akonadi/resourcebase.cpp:901
[...]
#10 0x00007f97249f8b44 in KIMAP::FetchJob::headersReceived (this=<optimized out>, _t1=<optimized out>, _t2=<optimized out>, _t3=<optimized out>, _t4=<optimized out>, _t5=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.0/build/kimap/fetchjob.moc:115
#11 0x00007f9724a1bcf8 in KIMAP::FetchJobPrivate::emitPendings (this=0x7c2820) at /usr/src/debug/kdepimlibs-4.8.0/kimap/fetchjob.cpp:57
#12 0x00007f9724a1348b in KIMAP::FetchJob::handleResponse (this=0x8c2030, response=...) at /usr/src/debug/kdepimlibs-4.8.0/kimap/fetchjob.cpp:236
Comment 8 Martin Bříza 2012-07-17 11:29:35 UTC
This bug is also reported in the Red Hat Bugzilla for Fedora 16 (KDE SC 4.7.4) on https://bugzilla.redhat.com/show_bug.cgi?id=794785 .
Comment 9 Kevin Ottens 2013-11-16 07:27:18 UTC
The IMAP resource has a new maintainer, reassigning to him.
Comment 10 Andrew Crouthamel 2018-09-25 03:45:48 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 11 Andrew Crouthamel 2018-10-27 02:29:23 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!