Bug 275234 - Can't use an interest rate with three decimal places when editing a loan
Summary: Can't use an interest rate with three decimal places when editing a loan
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: SVN
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
: 284059 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-08 21:26 UTC by Cristian Oneț
Modified: 2011-10-17 06:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Edit the loan and try to enter an interest rate with three decimal places. (5.88 KB, application/x-kmymoney)
2011-06-08 21:27 UTC, Cristian Oneț
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cristian Oneț 2011-06-08 21:26:19 UTC
Version:           SVN trunk (using KDE 4.6.3) 
OS:                Linux

I've tried to update a loan with variable interest rate but it seems that the precesion is 2 when editing the loan.

Reproducible: Always

Steps to Reproduce:
Edit the loan and enter an interest rate with three decimal places.

Actual Results:  
On the final page the rate will be displayed rounded to two decimal places.

Expected Results:  
On the final page the same rate should be displayed.

OS: Linux (x86_64) release 2.6.37-gentoo-r4
Compiler: x86_64-pc-linux-gnu-gcc
Comment 1 Cristian Oneț 2011-06-08 21:27:53 UTC
Created attachment 60793 [details]
Edit the loan and try to enter an interest rate with three decimal places.
Comment 2 Cristian Oneț 2011-06-08 21:36:05 UTC
SVN commit 1235734 by conet:

BUG: 275234
Allow entering an interest rate with three decimal places when editing the loan just like when creating it.

 M  +1 -0      keditloanwizard.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1235734
Comment 3 Cristian Oneț 2011-10-17 06:57:44 UTC
*** Bug 284059 has been marked as a duplicate of this bug. ***