Bug 275204 - kword:msword2003: Very small textboxes and no text is displayed sometimes
Summary: kword:msword2003: Very small textboxes and no text is displayed sometimes
Status: VERIFIED FIXED
Alias: None
Product: calligrawords
Classification: Unclassified
Component: doc (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-08 14:01 UTC by keerthi
Modified: 2011-06-24 05:29 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
testdata (69.00 KB, application/octet-stream)
2011-06-08 14:01 UTC, keerthi
Details
screenshot in calligrastage. (130.53 KB, image/x-png)
2011-06-08 14:05 UTC, keerthi
Details
screenshot in msoffice. (107.06 KB, application/x-zip-compressed)
2011-06-08 14:18 UTC, keerthi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description keerthi 2011-06-08 14:01:06 UTC
Created attachment 60780 [details]
testdata

Version: git checkout 8288143b7c1f9f9005209b55b651875219b0e9d6
        (Using KDE 4.5.5)                
     OS: Kubuntu 10.10

Test data is in doc format.
Open the same document in Calligra Words and check for the display of text.

Expected outcome:
All the text should be rendered properly.

Actual outcome:
Only able to see heading of the document.
Please check the screenshots attached.

Frequency:
Always.
Comment 1 keerthi 2011-06-08 14:05:21 UTC
Created attachment 60781 [details]
screenshot in calligrastage.
Comment 2 keerthi 2011-06-08 14:18:43 UTC
Created attachment 60782 [details]
screenshot in msoffice.
Comment 3 Sebastian Sauer 2011-06-08 22:02:04 UTC
Thank you very much for the report keerthi. The original problem, that the text was not visible, was fixed meanwgile in Calligra Words from git-master.

But there is still a problem with the document. MSWord displays 2 columns while we only display one column.
Comment 4 Sebastian Sauer 2011-06-08 22:05:25 UTC
Actually the problem still persists but can only be reproduced sometimes. Sometimes the text is correct (except it's all in one column rather then two) while sometimes no text is displayed.
Comment 5 Sebastian Sauer 2011-06-08 22:44:49 UTC
Fix for the problem is for review at the calligra-devel mailinglist. Waiting for feedback now.
Comment 6 Sebastian Sauer 2011-06-11 20:39:53 UTC
Fixed with d68df89a466b6af933aca43adac677b1e1961396
Comment 7 keerthi 2011-06-24 05:29:18 UTC
Verified in fc64fbad1f4847add90ceb6f303b2e383743cfd6.