Bug 274932 - plasma suddendly crashed
Summary: plasma suddendly crashed
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-04 19:51 UTC by erik6350
Modified: 2011-06-05 15:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (21.21 KB, text/plain)
2011-06-05 03:20 UTC, Damian
Details
New crash information added by DrKonqi (21.21 KB, text/plain)
2011-06-05 03:20 UTC, Damian
Details
New crash information added by DrKonqi (21.21 KB, text/plain)
2011-06-05 03:20 UTC, Damian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description erik6350 2011-06-04 19:51:44 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.3 (4.6.3)
Qt Version: 4.7.3
Operating System: Linux 2.6.39-1.slh.1-aptosid-686 i686
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
- What I was doing when the application crashed:

- I have had some programms like kontact and korganizer opened
- I have modified the kde toolbar
- I have killed korgac with ksysguard and other programms (iTalc), because I've recognized massive slowdowns


- Unusual behavior I noticed:

massive slowdowns

-- Backtrace:
Application: Plasma-Desktop-Umgebung (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb213a720 (LWP 3240))]

Thread 2 (Thread 0xaf35ab70 (LWP 3241)):
#0  0xb7781424 in __kernel_vsyscall ()
#1  0xb7648f06 in poll () from /lib/i686/cmov/libc.so.6
#2  0xb3115f5b in g_poll () from /lib/libglib-2.0.so.0
#3  0xb310596f in ?? () from /lib/libglib-2.0.so.0
#4  0xb3105ce4 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb64a8317 in QEventDispatcherGlib::processEvents (this=0x8695db8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6478f9d in QEventLoop::processEvents (this=0xaf35a2a0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb64791e1 in QEventLoop::exec (this=0xaf35a2a0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb637beeb in QThread::exec (this=0x86de058) at thread/qthread.cpp:492
#9  0xb6459a4d in QInotifyFileSystemWatcherEngine::run (this=0x86de058) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb637ed53 in QThreadPrivate::start (arg=0x86de058) at thread/qthread_unix.cpp:320
#11 0xb3207c39 in start_thread () from /lib/i686/cmov/libpthread.so.0
#12 0xb76568ee in clone () from /lib/i686/cmov/libc.so.6

Thread 1 (Thread 0xb213a720 (LWP 3240)):
[KCrash Handler]
#7  0xb6aa5755 in QString (this=0x8550061, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0x8550061, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0xb6aabf18 in KIconLoaderPrivate::makeCacheKey (this=0x855004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0xb6ab3c94 in KIconLoader::loadIcon (this=0x908ce08, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0xb6aaa7f4 in KIconEngine::pixmap (this=0x937dab0, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0xb5a5e7e4 in QIcon::pixmap (this=0x922b0b4, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0xb7450365 in Plasma::IconWidgetPrivate::decoration (this=0x922b010, option=0x83d8338, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#14 0xb745743d in Plasma::IconWidget::paint (this=0x94560d0, painter=0xbfc2b804, option=0x83d8338, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1128
#15 0xaf4700ba in SystemTray::DBusSystemTrayWidget::paint (this=0x94560d0, painter=0xbfc2b804, option=0x83d8338, widget=0x0) at ../../../../../plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#16 0xb6026b35 in _q_paintItem (item=<value optimized out>, painter=0xbfc2b804, option=0x83d8338, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#17 0xb60279de in _q_paintIntoCache (pix=0xbfc2bd28, item=0x94560d8, pixmapExposed=..., itemToPixmap=..., renderHints=) at graphicsview/qgraphicsscene.cpp:4352
#18 0xb6040dcc in QGraphicsScenePrivate::drawItemHelper (this=0x83d81e8, item=0x94560d8, painter=0xbfc2cbc8, option=0x83d8338, widget=0x8a99f80, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4673
#19 0xb60419c3 in QGraphicsScenePrivate::draw (this=0x83d81e8, item=0x94560d8, painter=0xbfc2cbc8, viewTransform=0xbfc2c8dc, transformPtr=0xbfc2bff0, exposedRegion=0x8a97a08, widget=0x8a99f80, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#20 0xb604269e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x83d81e8, item=0x94560d8, painter=0xbfc2cbc8, viewTransform=0xbfc2c8dc, exposedRegion=0x8a97a08, widget=0x8a99f80, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4836
#21 0xb60417f7 in QGraphicsScenePrivate::draw (this=0x83d81e8, item=0x86000a0, painter=0xbfc2cbc8, viewTransform=0xbfc2c8dc, transformPtr=0xbfc2c480, exposedRegion=0x8a97a08, widget=0x8a99f80, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#22 0xb604269e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x83d81e8, item=0x86000a0, painter=0xbfc2cbc8, viewTransform=0xbfc2c8dc, exposedRegion=0x8a97a08, widget=0x8a99f80, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4836
#23 0xb6042faf in QGraphicsScenePrivate::drawItems (this=0x83d81e8, painter=0xbfc2cbc8, viewTransform=0xbfc2c8dc, exposedRegion=0x8a97a08, widget=0x8a99f80) at graphicsview/qgraphicsscene.cpp:4718
#24 0xb605f4e6 in QGraphicsView::paintEvent (this=0x8668ea8, event=0x0) at graphicsview/qgraphicsview.cpp:3469
#25 0xb5a015d9 in QWidget::event (this=0x8668ea8, event=0xbfc2d284) at kernel/qwidget.cpp:8405
#26 0xb5e02815 in QFrame::event (this=0x8668ea8, e=0xbfc2d284) at widgets/qframe.cpp:557
#27 0xb5e94921 in QAbstractScrollArea::viewportEvent (this=0x8668ea8, e=0xbfc2d284) at widgets/qabstractscrollarea.cpp:1043
#28 0xb606089c in QGraphicsView::viewportEvent (this=0x8668ea8, event=0xbfc2d284) at graphicsview/qgraphicsview.cpp:2864
#29 0xb5e97076 in viewportEvent (this=0x8a988c0, o=0x8a99f80, e=0xbfc2d284) at widgets/qabstractscrollarea_p.h:100
#30 eventFilter (this=0x8a988c0, o=0x8a99f80, e=0xbfc2d284) at widgets/qabstractscrollarea_p.h:116
#31 QAbstractScrollAreaFilter::eventFilter (this=0x8a988c0, o=0x8a99f80, e=0xbfc2d284) at widgets/qabstractscrollarea_p.h:115
#32 0xb647a116 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x836ff78, receiver=0x8a99f80, event=0xbfc2d284) at kernel/qcoreapplication.cpp:846
#33 0xb59a7012 in notify_helper (this=0x836ff78, receiver=0x8a99f80, e=0xbfc2d284) at kernel/qapplication.cpp:4463
#34 QApplicationPrivate::notify_helper (this=0x836ff78, receiver=0x8a99f80, e=0xbfc2d284) at kernel/qapplication.cpp:4439
#35 0xb59ac488 in QApplication::notify (this=0x836ff78, receiver=0x8a99f80, e=0xbfc2d284) at kernel/qapplication.cpp:4432
#36 0xb6b0bcf1 in KApplication::notify (this=0x8358308, receiver=0x8a99f80, event=0xbfc2d284) at ../../kdeui/kernel/kapplication.cpp:311
#37 0xb6479f7e in QCoreApplication::notifyInternal (this=0x8358308, receiver=0x8a99f80, event=0xbfc2d284) at kernel/qcoreapplication.cpp:731
#38 0xb59fe30c in sendSpontaneousEvent (this=0x8a99f98, pdev=0x8a958cc, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a973c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#39 QWidgetPrivate::drawWidget (this=0x8a99f98, pdev=0x8a958cc, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a973c0) at kernel/qwidget.cpp:5492
#40 0xb59ff034 in QWidgetPrivate::paintSiblingsRecursive (this=0x8a976b8, pdev=0x8a958cc, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a973c0) at kernel/qwidget.cpp:5699
#41 0xb59fe068 in QWidgetPrivate::drawWidget (this=0x8a976b8, pdev=0x8a958cc, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a973c0) at kernel/qwidget.cpp:5545
#42 0xb59ff034 in QWidgetPrivate::paintSiblingsRecursive (this=0x8a969e0, pdev=0x8a958cc, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a973c0) at kernel/qwidget.cpp:5699
#43 0xb59fe068 in QWidgetPrivate::drawWidget (this=0x8a969e0, pdev=0x8a958cc, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x8a973c0) at kernel/qwidget.cpp:5545
#44 0xb5be507e in QWidgetBackingStore::sync (this=0x8a973c0) at painting/qbackingstore.cpp:1333
#45 0xb59f3b5b in QWidgetPrivate::syncBackingStore (this=0x8a969e0) at kernel/qwidget.cpp:1842
#46 0xb5a02185 in QWidget::event (this=0x86cd628, event=0x8e414e0) at kernel/qwidget.cpp:8552
#47 0xb7396169 in Plasma::Dialog::event (this=0x86cd628, event=0x8e414e0) at ../../plasma/dialog.cpp:544
#48 0xb59a7044 in notify_helper (this=0x836ff78, receiver=0x86cd628, e=0x8e414e0) at kernel/qapplication.cpp:4467
#49 QApplicationPrivate::notify_helper (this=0x836ff78, receiver=0x86cd628, e=0x8e414e0) at kernel/qapplication.cpp:4439
#50 0xb59ac488 in QApplication::notify (this=0x836ff78, receiver=0x86cd628, e=0x8e414e0) at kernel/qapplication.cpp:4432
#51 0xb6b0bcf1 in KApplication::notify (this=0x8358308, receiver=0x86cd628, event=0x8e414e0) at ../../kdeui/kernel/kapplication.cpp:311
#52 0xb6479f7e in QCoreApplication::notifyInternal (this=0x8358308, receiver=0x86cd628, event=0x8e414e0) at kernel/qcoreapplication.cpp:731
#53 0xb647d6d8 in sendEvent (receiver=0x86cd628, event_type=77, data=0x83117a8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#54 QCoreApplicationPrivate::sendPostedEvents (receiver=0x86cd628, event_type=77, data=0x83117a8) at kernel/qcoreapplication.cpp:1372
#55 0xb647d89c in QCoreApplication::sendPostedEvents (receiver=0x86cd628, event_type=77) at kernel/qcoreapplication.cpp:1265
#56 0xb60378e6 in dispatchPendingUpdateRequests (this=0x83d81e8) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#57 QGraphicsScenePrivate::_q_processDirtyItems (this=0x83d81e8) at graphicsview/qgraphicsscene.cpp:510
#58 0xb6037cfb in QGraphicsScene::qt_metacall (this=0x8405540, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x8f99678) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#59 0xb7388d02 in Plasma::Corona::qt_metacall (this=0x8405540, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x8f99678) at ./corona.moc:109
#60 0xb7733612 in DesktopCorona::qt_metacall (this=0x8405540, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x8f99678) at ./desktopcorona.moc:101
#61 0xb648036d in metacall (object=0x8405540, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x8f99678) at kernel/qmetaobject.cpp:237
#62 QMetaObject::metacall (object=0x8405540, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x8f99678) at kernel/qmetaobject.cpp:232
#63 0xb648ad25 in QMetaCallEvent::placeMetaCall (this=0x921f050, object=0x8405540) at kernel/qobject.cpp:535
#64 0xb649223f in QObject::event (this=0x8405540, e=0x921f050) at kernel/qobject.cpp:1217
#65 0xb603e600 in QGraphicsScene::event (this=0x8405540, event=0x921f050) at graphicsview/qgraphicsscene.cpp:3544
#66 0xb59a7044 in notify_helper (this=0x836ff78, receiver=0x8405540, e=0x921f050) at kernel/qapplication.cpp:4467
#67 QApplicationPrivate::notify_helper (this=0x836ff78, receiver=0x8405540, e=0x921f050) at kernel/qapplication.cpp:4439
#68 0xb59ac3d2 in QApplication::notify (this=0x921f050, receiver=0x8405540, e=0x921f050) at kernel/qapplication.cpp:4214
#69 0xb6b0bcf1 in KApplication::notify (this=0x8358308, receiver=0x8405540, event=0x921f050) at ../../kdeui/kernel/kapplication.cpp:311
#70 0xb6479f7e in QCoreApplication::notifyInternal (this=0x8358308, receiver=0x8405540, event=0x921f050) at kernel/qcoreapplication.cpp:731
#71 0xb647d6d8 in sendEvent (receiver=0x0, event_type=0, data=0x83117a8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#72 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x83117a8) at kernel/qcoreapplication.cpp:1372
#73 0xb647d89c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#74 0xb64a7e84 in sendPostedEvents (s=0x8373700) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#75 postEventSourceDispatch (s=0x8373700) at kernel/qeventdispatcher_glib.cpp:277
#76 0xb3105252 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#77 0xb3105a30 in ?? () from /lib/libglib-2.0.so.0
#78 0xb3105ce4 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#79 0xb64a82b7 in QEventDispatcherGlib::processEvents (this=0x83124e8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#80 0xb5a5c14a in QGuiEventDispatcherGlib::processEvents (this=0x83124e8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#81 0xb6478f9d in QEventLoop::processEvents (this=0xbfc2ebe4, flags=...) at kernel/qeventloop.cpp:149
#82 0xb64791e1 in QEventLoop::exec (this=0xbfc2ebe4, flags=...) at kernel/qeventloop.cpp:201
#83 0xb647d94a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#84 0xb59a4ea4 in QApplication::exec () at kernel/qapplication.cpp:3741
#85 0xb773ac9b in kdemain (argc=1, argv=0xbfc2edf4) at ../../../../plasma/desktop/shell/main.cpp:120
#86 0x0804857b in main (argc=1, argv=0xbfc2edf4) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 258706.

Possible duplicates by query: bug 274898, bug 274864, bug 274830, bug 274781, bug 274698.

Reported using DrKonqi
Comment 1 Damian 2011-06-05 03:20:33 UTC
Created attachment 60639 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.3 (4.6.3) using Qt 4.7.2

- What I was doing when the application crashed:

I opened the menu then the plasma shell just crashed

-- Backtrace (Reduced):
#6  0x00007f0a5230b6ef in QString (this=0x2bc005c, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x2bc005c, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007f0a523110fb in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007f0a52317e13 in KIconLoader::loadIcon (this=0x28b4b10, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007f0a5230fda9 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
Comment 2 Damian 2011-06-05 03:20:34 UTC
Created attachment 60640 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.3 (4.6.3) using Qt 4.7.2

- What I was doing when the application crashed:

I opened the menu then the plasma shell just crashed

-- Backtrace (Reduced):
#6  0x00007f0a5230b6ef in QString (this=0x2bc005c, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x2bc005c, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007f0a523110fb in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007f0a52317e13 in KIconLoader::loadIcon (this=0x28b4b10, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007f0a5230fda9 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
Comment 3 Damian 2011-06-05 03:20:34 UTC
Created attachment 60641 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.3 (4.6.3) using Qt 4.7.2

- What I was doing when the application crashed:

I opened the menu then the plasma shell just crashed

-- Backtrace (Reduced):
#6  0x00007f0a5230b6ef in QString (this=0x2bc005c, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x2bc005c, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007f0a523110fb in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007f0a52317e13 in KIconLoader::loadIcon (this=0x28b4b10, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007f0a5230fda9 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
Comment 4 Dario Andres 2011-06-05 15:41:22 UTC
[Comment from a bug triager]
The bug is fixed for KDE SC 4.6.4. The issue was being tracked at bug 258706, merging.
Thanks

*** This bug has been marked as a duplicate of bug 258706 ***