Bug 274788 - After deleting a category some schedules could be left with references to the deleted category
Summary: After deleting a category some schedules could be left with references to the...
Status: RESOLVED DUPLICATE of bug 274789
Alias: None
Product: kmymoney
Classification: Applications
Component: general (show other bugs)
Version: SVN
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-02 22:50 UTC by Cristian Oneț
Modified: 2011-06-02 22:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cristian Oneț 2011-06-02 22:50:48 UTC
Version:           SVN trunk (using KDE 4.6.3) 
OS:                Linux



Reproducible: Always

Steps to Reproduce:
With the attached file
1. Check out that there is a schedule refering to the 'Automobil:Combustibil' category
2. Double click on the 'Automobil:Combustibil' category in the Categories view
3. In the ledger that shows the transactions in 'Automobil:Combustibil' select all the transactions and move them to 'Automobil:Fuel'
4. Delete the 'Automobil:Combustibil' and choose to move references to 'Automobil:Fuel'
5. Try to open the schedule or save the file
3. 

Actual Results:  
The schedule will be left behind with a reference to an inexistent account.

Expected Results:  
The schedule's reference should have been updated.

OS: Linux (x86_64) release 2.6.37-gentoo-r4
Compiler: x86_64-pc-linux-gnu-gcc
Comment 1 Cristian Oneț 2011-06-02 22:53:25 UTC
Stupid BUG in konqueror made me file the bug twice arghh.

*** This bug has been marked as a duplicate of bug 274789 ***