Bug 274755 - Fade out on Stop is delayed
Summary: Fade out on Stop is delayed
Status: RESOLVED NOT A BUG
Alias: None
Product: phonon-backend-gstreamer
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.5.0
Platform: Ubuntu Linux
: NOR normal
Target Milestone: 4.5.2
Assignee: Harald Sitter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-02 14:56 UTC by Kai Uwe Broulik
Modified: 2012-07-30 20:21 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2011-06-02 14:56:23 UTC
Version:           2.4.1 (using KDE 4.6.3) 
OS:                Linux

I have set my Fade out on Stop to 500ms. When I press Stop, it takes a second for the fade to start.
It should instantly start fading when I press stop, not after a second or longer.
This makes me disable this feature everytime since I cannot stand this behavior.

Reproducible: Always
Comment 1 Myriam Schweingruber 2011-06-02 22:21:24 UTC
Which Phonon backend do you use?
Comment 2 Kai Uwe Broulik 2011-06-02 22:25:23 UTC
The great working *cough* Gstreamer. But it has been that way since I started using Amarok, so it’s no problem of Gstreamer. I use Amarok since 2.0 / KDE 4.2
Comment 3 Torrie Fischer 2011-06-03 12:02:03 UTC
And what version of the amazing GStreamer backend might you be using?
Comment 4 Kai Uwe Broulik 2011-06-03 14:30:02 UTC
libgstreamer0.10-0 (0.10.32-3-ubuntu3)
But as I said, this behavior has been there since ever and not just with Gstreamer, it is the same when using Xine.
Comment 5 Torrie Fischer 2011-06-03 15:12:57 UTC
Sorry if I wasn't clear, but I mean the Phonon GStreamer backend. Phonon-GStreamer can use any version of libgstreamer.
Comment 6 Kai Uwe Broulik 2011-06-03 15:30:40 UTC
Funny version number :D
phonon-backend-gstreamer 4:4.7.0really4.5.0-0ubuntu2.1
Comment 7 Myriam Schweingruber 2011-07-18 06:52:22 UTC
Reassigning.
Comment 8 Torrie Fischer 2011-09-19 13:36:19 UTC
The VolumeFaderEffect class was tweaked in 4.5.90.

Additionally, I've noticed that Pulseaudio sometimes buffers a *lot* of data, causing the fade out to take a second or so before it hits the soundcard. Thats something I'm working on soon but if you can test the 4.5.90 release and see if anything is any better, that'd be much appreciated.
Comment 9 Kai Uwe Broulik 2011-09-20 11:05:19 UTC
But what has Phonon’s buffer to do with fade? When I adjust the volume, it instantly gets changed ;) Can’t the fade out effect be handled via volume control or something?
Comment 10 Myriam Schweingruber 2012-02-19 12:21:32 UTC
Is this still valid with Phonon-backend-gstreamer 4.6?
Comment 11 Myriam Schweingruber 2012-07-30 20:21:43 UTC
Closing for lack of feedback. Please feel free to reopen this report if you can reproduce this with the gstreamer backend version 4.6.1 or later.