Bug 274684 - Cycle diagram is not rendered properly.
Summary: Cycle diagram is not rendered properly.
Status: VERIFIED FIXED
Alias: None
Product: calligracommon
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-01 14:40 UTC by keerthi
Modified: 2012-05-28 08:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test Data_PPT (32.50 KB, application/vnd.ms-powerpoint)
2011-06-01 14:40 UTC, keerthi
Details
Screen shot in Calligra stage (190.61 KB, image/x-png)
2011-06-01 14:52 UTC, keerthi
Details
screenshot in MS Office (91.55 KB, application/x-zip-compressed)
2011-06-01 14:54 UTC, keerthi
Details
Test Data for venn&Target diagrams (14.12 KB, application/x-zip-compressed)
2011-06-01 14:56 UTC, keerthi
Details
Screen shot in Calligra stage_Venn&Target (325.76 KB, application/x-zip-compressed)
2011-06-01 14:59 UTC, keerthi
Details
Output from ppt filter, which is displayed correctly in OOo (4.59 KB, application/vnd.oasis.opendocument.presentation)
2011-06-07 12:18 UTC, LukasT
Details

Note You need to log in before you can comment on or make changes to this bug.
Description keerthi 2011-06-01 14:40:24 UTC
Created attachment 60537 [details]
Test Data_PPT

Version: git checkout 0a5c60c868f770035565fe36ecf1ee0408f48f90
        (Using KDE 4.5.5)                
     OS: Kubuntu 10.10

Test data is in ppt 2003 format.
Open the same document in Calligra Stage and check the display of Cycle diagram.

Expected outcome:
Cycle diagram should be displayed properly.

Actual outcome:
Diagram is not displayed properly i.e, all the arrows are merged

Please check the screenshots attached.

Frequency:
Always.
Comment 1 keerthi 2011-06-01 14:52:22 UTC
Created attachment 60538 [details]
Screen shot in Calligra stage
Comment 2 keerthi 2011-06-01 14:54:55 UTC
Created attachment 60539 [details]
screenshot in MS Office
Comment 3 keerthi 2011-06-01 14:56:38 UTC
Created attachment 60540 [details]
Test Data for venn&Target diagrams
Comment 4 keerthi 2011-06-01 14:59:03 UTC
Created attachment 60541 [details]
Screen shot in Calligra stage_Venn&Target
Comment 5 keerthi 2011-06-01 15:01:19 UTC
Venn and Target diagrams also not rendered properly.
Comment 6 LukasT 2011-06-07 11:57:35 UTC
Git commit 9a2730dd43ee694215ee9ba0d8704effa5a6042c by Lukáš Tvrdý.
Committed on 07/06/2011 at 11:52.
Pushed by lukast into branch 'master'.

Render the cycle diagram correctly

Circular Arrow shape returns the adjustedValue,
adjustedValue2 16 bit shifted. adjustedValue3 is not shifted.

CCBUG:274684

M  +16   -1    filters/libmso/shapes2.cpp     

http://commits.kde.org/calligra/9a2730dd43ee694215ee9ba0d8704effa5a6042c
Comment 7 LukasT 2011-06-07 12:16:20 UTC
Venn diagram was fixed with commit e652e2b6c4e9cf4dee7e4b359b192dee26c084df

Target diagram is still not displayed correctly. The problem is in the rendering engine, not in the ppt filter. The attached odp output from filter (using koconverter) is displayed correctly in OOo.
Comment 8 LukasT 2011-06-07 12:18:10 UTC
Created attachment 60738 [details]
Output from ppt filter, which is displayed correctly in OOo
Comment 9 LukasT 2011-06-07 13:53:53 UTC
For target diagram we have different bug https://bugs.kde.org/show_bug.cgi?id=270848
Comment 10 keerthi 2011-06-09 14:08:21 UTC
Verified on 
8288143b7c1f9f9005209b55b651875219b0e9d6.