Bug 274674 - Dolphin hangs on opening a mounted network folder (autofs), which is not reachable
Summary: Dolphin hangs on opening a mounted network folder (autofs), which is not reac...
Status: RESOLVED DUPLICATE of bug 184062
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.6
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-01 12:11 UTC by Diederik van der Boor
Modified: 2013-07-07 18:37 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diederik van der Boor 2011-06-01 12:11:02 UTC
Version:           1.6.1 (using KDE 4.6.3) 
OS:                Linux

When dolphin opens a network mount folder (some /mnt/network/servername), it hangs when the network server is unreachable.

In this specific case, the server existed on a different subnet (192.* instead of 10.*)

Reproducible: Didn't try

Steps to Reproduce:
* Create an autofs setup.

/etc/auto.master:
------------------

+auto.master
/mnt/nas9000    /etc/auto.nas9000  --timeout=15

/etc/auto.nas9000:
-------------------

diederik     -fstype=cifs,credentials=/etc/auto.nas9000.credentials,uid=diederik,gid=users,noperm,dir_mode=0755,file_mode=0644  ://nas9000/diederik

/etc/auto.nas9000.credentials:
-------------------------------

username=....
password=...

* Start it:

/etc/init.d/autofs start

* Navigate to the folder in Dolphin

Actual Results:  
Dolphin hangs

Expected Results:  
Dolphin showing a loading indicator in the folder, as long as needed, before the content is either available, or the request timed out.

OS: Linux (i686) release 2.6.37.6-0.5-desktop
Compiler: gcc
Comment 1 S. Burmeister 2012-04-21 12:24:22 UTC
Dup of bug 184062 ?
Comment 2 Ilya Potapov 2012-05-27 18:45:37 UTC
I experience same one and i think it is dup of #184062
Comment 3 Dawit Alemayehu 2013-07-07 18:37:30 UTC

*** This bug has been marked as a duplicate of bug 184062 ***