Bug 274414 - Dolphin freezes when mounted (remote) samba fs is not available
Summary: Dolphin freezes when mounted (remote) samba fs is not available
Status: RESOLVED DUPLICATE of bug 316655
Alias: None
Product: kio
Classification: Unclassified
Component: general (show other bugs)
Version: 4.6
Platform: Archlinux Packages Linux
: NOR normal with 43 votes (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-29 11:37 UTC by Yotam Bar-On
Modified: 2015-03-25 13:48 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yotam Bar-On 2011-05-29 11:37:44 UTC
Version:           unspecified
OS:                Linux

Sometimes, the remote share-server is down. When the server is down, dolphin freezes then crashes when trying to view a shared directory.


Reproducible: Always

Steps to Reproduce:
0. Set up a samba share (at 10.1).
1. Set up your samba-mount using fstab:
# //10.0.0.1/share /mnt/share cifs sername=demouser,password=1234,rw,iocharset=utf8,file_mode=0777,dir_mode=0777,noperm     0       0
2. Re-mount fstab (so the samba share will be mounted).
3. Verify that your samba share works correctly (navigate to /mnt/share/).
4. Open dolphin, and add "/mnt/share/" to the short-cuts panel to the left.
5. Close dolphin.
6. Shut the samba share down.
7. Try to re-open Dolphin. 

Actual Results:  
Dolphin will appear frozen, and after a few seconds it will crash.

Expected Results:  
Dolphin should be opened correctly.
When the samba share is unavailable, dolphin should not crash, it should simply inform the user that the share server is down.

Description for reproducing platform:
* Arch Linux
* KDE 4.6.2
* The samba share runs in a LAN.
* Samba is mounted via fstab.
Comment 1 Dawit Alemayehu 2013-08-22 05:09:09 UTC
kio_smb does not mount remote shares. If you manually mounted and the application froze then it is either an application issue or a more general KIO or kdelibs issue. Moving to kio general for now.
Comment 2 Ganton 2015-01-24 17:46:07 UTC
It looks like a duplicate of
https://bugs.kde.org/show_bug.cgi?id=316655
Comment 3 Dawit Alemayehu 2015-03-24 12:37:38 UTC

*** This bug has been marked as a duplicate of bug 316655 ***