Bug 274174 - Notifications are displayed over full-screen windows while animating
Summary: Notifications are displayed over full-screen windows while animating
Status: RESOLVED DUPLICATE of bug 158262
Alias: None
Product: kwin
Classification: Plasma
Component: effects-window-management (show other bugs)
Version: 4.8.0
Platform: Archlinux Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-26 09:25 UTC by Ovidiu D. Niţan
Modified: 2012-03-05 10:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ovidiu D. Niţan 2011-05-26 09:25:30 UTC
Version:           unspecified (using KDE 4.6.3) 
OS:                Linux

The notifications aren't shown when watching a full-screen video (par example) - that's a good thing, because we don't want to be disturbed by them while we concentrate on the movie's action. The problem is that they become visible when they're hiding - more exactly, when the sliding animation is performed. I tried to deactivate the sliding effect, but the bug still occurs because of the fading effect. The only way to fix this issues is to deactivate all animation effects.

Reproducible: Always

Steps to Reproduce:
1. Watch a movie in fullscreen mode
2. Make a notification to appear (e.g. by running "sleep 3 && notify-osd "test")

Actual Results:  
The notification's pop-up appears while it's performing the hiding animation.

Expected Results:  
The notification popups shouldn't be visible at all

I'm using the NVIDIA's proprietary driver, version 270.41.19. The Qt's version is 4.7.3.
Comment 1 Ovidiu D. Niţan 2011-05-26 15:12:50 UTC
Actually, it seems that any window which is closing appears on top of the other windows while the closing animation effect is perfomed. So this is a bug related to KWin, not to Plasma...
Comment 2 Alvaro Fernando García 2011-11-11 02:32:11 UTC
Cannot reproduce.

Version: KDE SC 4.7.3 using Qt 4.7.4
OS: Arch Linux (kernel 3.1.0-4)

Video players used: smplayer, dragon player

The issue doesn't happen using the default settings (fresh user account).
Comment 3 Ovidiu D. Niţan 2012-03-04 18:20:34 UTC
Bug still present in KDE 4.8.0

Alvaro Fernando García:
- Make sure that "Sliding popups" effect is activated in Desktop Effects
- Play a video
- Run, in terminal, "sleep 5 && notify-send test"
- Fullscreen the video

The notification should appear over the window. Here's a video describing this issue:
http://dl.dropbox.com/u/1191805/notify.ogv

As you see on the video, on 00:07 the notification popup is visible while it's hiding. I'm also changing this to KWin because it seems to be a issue related to it (with BeGeneric animations, this bug still appears).
Comment 4 Martin Flöser 2012-03-05 05:19:25 UTC
It's on my 4.9 TODO list. Hopefully I get to it

*** This bug has been marked as a duplicate of bug 158262 ***
Comment 5 Ovidiu D. Niţan 2012-03-05 10:07:30 UTC
(In reply to comment #4)
> It's on my 4.9 TODO list. Hopefully I get to it
> 
> *** This bug has been marked as a duplicate of bug 158262 ***

Nice to hear that :) Sorry for the duplicate bug