Bug 273635 - akonadi crash for no apparent reason
Summary: akonadi crash for no apparent reason
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-19 13:36 UTC by p92
Modified: 2011-09-17 12:58 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (10.52 KB, text/plain)
2011-06-04 10:59 UTC, p92
Details

Note You need to log in before you can comment on or make changes to this bug.
Description p92 2011-05-19 13:36:14 UTC
Application: akonadi_imap_resource (0.1)
KDE Platform Version: 4.6.3 (4.6.3)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-02063802-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
akonadi crash for no apparent reason

I use kmail with imap accounts. Mail is regularly and automatically checked.

- Unusual behavior I noticed:

-- Backtrace:
Application: Akonadi Resource (akonadi_imap_resource), signal: Segmentation fault
__lll_lock_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:136
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S
[Current thread is 1 (Thread 0x7f6dd3f63780 (LWP 4958))]

Thread 4 (Thread 0x7f6daffff700 (LWP 3221)):
#0  0x00007f6dcfc19f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f6dce56e104 in g_main_context_poll (context=0x2411ca0, block=<value optimized out>, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.28.6/./glib/gmain.c:3404
#2  g_main_context_iterate (context=0x2411ca0, block=<value optimized out>, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.28.6/./glib/gmain.c:3086
#3  0x00007f6dce56e639 in g_main_context_iteration (context=0x2411ca0, may_block=1) at /build/buildd/glib2.0-2.28.6/./glib/gmain.c:3154
#4  0x00007f6dd33d2446 in QEventDispatcherGlib::processEvents (this=0x23caf20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f6dd33a6882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f6dd33a6abc in QEventLoop::exec (this=0x7f6dafffede0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f6dd32bd924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007f6dd2049a23 in ?? () from /usr/lib/libkimap.so.4
#9  0x00007f6dd32c0175 in QThreadPrivate::start (arg=0x7f6db8074fd0) at thread/qthread_unix.cpp:320
#10 0x00007f6dcf4d1d8c in start_thread (arg=0x7f6daffff700) at pthread_create.c:304
#11 0x00007f6dcfc2704d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f6db4ff9700 (LWP 6676)):
[KCrash Handler]
#6  _int_malloc (av=0x7f6dcfed01c0, bytes=<value optimized out>) at malloc.c:4439
#7  0x00007f6dcfbbd31e in __libc_malloc (bytes=65536) at malloc.c:3660
#8  0x00007f6dd32c2218 in QByteArray::realloc (this=0x22e9d98, alloc=65504) at tools/qbytearray.cpp:1428
#9  0x00007f6dd32c2339 in QByteArray::resize (this=0x22e9d98, size=32768) at tools/qbytearray.cpp:1396
#10 0x00007f6dd2335364 in reserve (this=0x235fba0) at ../../include/QtCore/private/../../../src/corelib/tools/qringbuffer_p.h:158
#11 QAbstractSocketPrivate::readFromSocket (this=0x235fba0) at socket/qabstractsocket.cpp:1158
#12 0x00007f6dd23359e3 in QAbstractSocketPrivate::canReadNotification (this=0x235fba0) at socket/qabstractsocket.cpp:614
#13 0x00007f6dd2323581 in QReadNotifier::event (this=<value optimized out>, e=<value optimized out>) at socket/qnativesocketengine.cpp:1103
#14 0x00007f6dd27689e4 in QApplicationPrivate::notify_helper (this=0x1cfa9f0, receiver=0x23cfbd0, e=0x7f6db4ff8be0) at kernel/qapplication.cpp:4462
#15 0x00007f6dd276d3aa in QApplication::notify (this=<value optimized out>, receiver=0x23cfbd0, e=0x7f6db4ff8be0) at kernel/qapplication.cpp:4341
#16 0x00007f6dd0afe196 in KApplication::notify (this=0x7fff9d78fc20, receiver=0x23cfbd0, event=0x7f6db4ff8be0) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007f6dd33a749c in QCoreApplication::notifyInternal (this=0x7fff9d78fc20, receiver=0x23cfbd0, event=0x7f6db4ff8be0) at kernel/qcoreapplication.cpp:731
#18 0x00007f6dd33d1da9 in sendEvent (source=0x2458730) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 socketNotifierSourceDispatch (source=0x2458730) at kernel/qeventdispatcher_glib.cpp:110
#20 0x00007f6dce56dbcd in g_main_dispatch (context=0x20475d0) at /build/buildd/glib2.0-2.28.6/./glib/gmain.c:2440
#21 g_main_context_dispatch (context=0x20475d0) at /build/buildd/glib2.0-2.28.6/./glib/gmain.c:3013
#22 0x00007f6dce56e3a8 in g_main_context_iterate (context=0x20475d0, block=<value optimized out>, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.28.6/./glib/gmain.c:3091
#23 0x00007f6dce56e639 in g_main_context_iteration (context=0x20475d0, may_block=1) at /build/buildd/glib2.0-2.28.6/./glib/gmain.c:3154
#24 0x00007f6dd33d23ef in QEventDispatcherGlib::processEvents (this=0x22e9db0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#25 0x00007f6dd33a6882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007f6dd33a6abc in QEventLoop::exec (this=0x7f6db4ff8de0, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007f6dd32bd924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#28 0x00007f6dd2049a23 in ?? () from /usr/lib/libkimap.so.4
#29 0x00007f6dd32c0175 in QThreadPrivate::start (arg=0x7f6db80710a0) at thread/qthread_unix.cpp:320
#30 0x00007f6dcf4d1d8c in start_thread (arg=0x7f6db4ff9700) at pthread_create.c:304
#31 0x00007f6dcfc2704d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#32 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6daf7fe700 (LWP 6677)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x00007f6dd32c079e in wait (this=<value optimized out>, mutex=0x7f6db80132a0, time=30000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x7f6db80132a0, time=30000) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f6dd32b5218 in QThreadPoolThread::run (this=0x7f6db00198a0) at concurrent/qthreadpool.cpp:140
#4  0x00007f6dd32c0175 in QThreadPrivate::start (arg=0x7f6db00198a0) at thread/qthread_unix.cpp:320
#5  0x00007f6dcf4d1d8c in start_thread (arg=0x7f6daf7fe700) at pthread_create.c:304
#6  0x00007f6dcfc2704d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6dd3f63780 (LWP 4958)):
#0  __lll_lock_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:136
#1  0x00007f6dcf4d45b4 in _L_lock_944 () from /lib/x86_64-linux-gnu/libpthread.so.0
#2  0x00007f6dcf4d43ca in __pthread_mutex_lock (mutex=0x240ff18) at pthread_mutex_lock.c:61
#3  0x00007f6dce56f925 in g_main_context_wakeup (context=0x240ff10) at /build/buildd/glib2.0-2.28.6/./glib/gmain.c:3756
#4  0x00007f6dd33aa43b in QCoreApplication::postEvent (receiver=0x7f6db8090a20, event=0x7f6db808a7e0, priority=0) at kernel/qcoreapplication.cpp:1194
#5  0x00007f6dd33afff0 in QMetaMethod::invoke (this=<value optimized out>, object=0x7f6db8090a20, connectionType=Qt::QueuedConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1618
#6  0x00007f6dd33b0ba8 in QMetaObject::invokeMethod (obj=0x7f6db8090a20, member=<value optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1151
#7  0x00007f6dd204a030 in ?? () from /usr/lib/libkimap.so.4
#8  0x00007f6dd204a329 in ?? () from /usr/lib/libkimap.so.4
#9  0x00007f6dd2045ff9 in KIMAP::Session::~Session() () from /usr/lib/libkimap.so.4
#10 0x00007f6dd2046029 in KIMAP::Session::~Session() () from /usr/lib/libkimap.so.4
#11 0x00007f6dd33b9c14 in QObjectPrivate::deleteChildren (this=0x7f6db810bb70) at kernel/qobject.cpp:1964
#12 0x00007f6dd33be5f4 in QObject::~QObject (this=0x7f6db807e3a0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#13 0x00000000004178e9 in _start ()

Possible duplicates by query: bug 257258.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-05-19 13:51:53 UTC
>#7  0x00007f6dd204a030 in ?? () from /usr/lib/libkimap.so.4
>#8  0x00007f6dd204a329 in ?? () from /usr/lib/libkimap.so.4

If the crash is easily reproducible, please install the debug package for kdepimlibs and paste a better backtrace.
Comment 2 p92 2011-06-04 10:59:28 UTC
Created attachment 60604 [details]
New crash information added by DrKonqi

akonadi_imap_resource (0.1) on KDE Platform 4.6.3 (4.6.3) using Qt 4.7.2

- What I was doing when the application crashed:

I cannot reproduce at will, but this morning it crashed again so now I have the debug symbols installed :) 

- Unusual behavior I noticed:

-- Backtrace (Reduced):
#6  _int_malloc (av=0x7f16cb2a41c0, bytes=<value optimized out>) at malloc.c:4439
#7  0x00007f16caf9131e in __libc_malloc (bytes=65536) at malloc.c:3660
#8  0x00007f16ce696218 in QByteArray::realloc (this=0x1c07368, alloc=65504) at tools/qbytearray.cpp:1428
#9  0x00007f16ce696339 in QByteArray::resize (this=0x1c07368, size=32768) at tools/qbytearray.cpp:1396
#10 0x00007f16cd709364 in reserve (this=0x1c29eb0) at ../../include/QtCore/private/../../../src/corelib/tools/qringbuffer_p.h:158
Comment 3 Christophe Marin 2011-07-13 15:08:00 UTC
Pasting inline 

Thread 1 (Thread 0x7f16cf337780 (LWP 14006)):
#0  __lll_lock_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:136
#1  0x00007f16ca8a85b4 in _L_lock_944 () from /lib/x86_64-linux-gnu/libpthread.so.0
#2  0x00007f16ca8a83ca in __pthread_mutex_lock (mutex=0x1d10ad8) at pthread_mutex_lock.c:61
#3  0x00007f16c9943925 in g_main_context_wakeup () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f16ce77e43b in QCoreApplication::postEvent (receiver=0x7f16b40f0bb0, event=0x7f16b41963a0, priority=0) at kernel/qcoreapplication.cpp:1194
#5  0x00007f16ce783ff0 in QMetaMethod::invoke (this=<value optimized out>, object=0x7f16b40f0bb0, connectionType=Qt::QueuedConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1618
#6  0x00007f16ce784ba8 in QMetaObject::invokeMethod (obj=0x7f16b40f0bb0, member=<value optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1151
#7  0x00007f16cd41e030 in invokeMethod (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qobjectdefs.h:424
#8  KIMAP::SessionThread::~SessionThread (this=<value optimized out>, __in_chrg=<value optimized out>) at ../../kimap/sessionthread.cpp:51
#9  0x00007f16cd41e329 in KIMAP::SessionThread::~SessionThread (this=0x7f16b40f0bb0, __in_chrg=<value optimized out>) at ../../kimap/sessionthread.cpp:56
#10 0x00007f16cd419ff9 in KIMAP::Session::~Session (this=0x7f16b4195530, __in_chrg=<value optimized out>) at ../../kimap/session.cpp:67
#11 0x00007f16cd41a029 in KIMAP::Session::~Session (this=0x7f16b4195530, __in_chrg=<value optimized out>) at ../../kimap/session.cpp:68
#12 0x00007f16ce78dc14 in QObjectPrivate::deleteChildren (this=0x7f16b40fbcb0) at kernel/qobject.cpp:1964
#13 0x00007f16ce7925f4 in QObject::~QObject (this=0x7f16b41a5720, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#14 0x00000000004178e9 in ImapAccount::~ImapAccount (this=0x7f16b41a5720, __in_chrg=<value optimized out>) at ../../../resources/imap/imapaccount.cpp:121
#15 0x00007f16ce78f4c8 in QObject::event (this=0x7f16b41a5720, e=<value optimized out>) at kernel/qobject.cpp:1209
Comment 4 Kevin Ottens 2011-09-17 12:58:00 UTC
Is it still happening for you with 4.7.x? I've been unable to reproduce that one, it just works for me.

In case you still experience this please feel free to reopen. In such a case, we would need much more information like the actual IMAP server used and so on.