Bug 273609 - Firefox crashes when searching various sites
Summary: Firefox crashes when searching various sites
Status: RESOLVED NOT A BUG
Alias: None
Product: konqueror
Classification: Unclassified
Component: nspluginviewer (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 276063 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-19 05:55 UTC by tony_kerr
Modified: 2011-07-14 21:03 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tony_kerr 2011-05-19 05:55:00 UTC
Application: nspluginviewer ()
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed: Browsing, no other apps running

- Custom settings of the application:

Application: nspluginviewer ()
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Backtrace:
Application: nspluginviewer (nspluginviewer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77cd710 (LWP 6237))]

Thread 4 (Thread 0xb49c1b70 (LWP 6243)):
#0  0x00ac5416 in __kernel_vsyscall ()
#1  0x00ea048c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x009c43fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4c31087 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#4  0xb4d436b5 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#5  0xb4c3118d in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#6  0xb4c31816 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#7  0x00e9be99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x009b673e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xb29c0b70 (LWP 6244)):
#0  0x00ac5416 in __kernel_vsyscall ()
#1  0x00ea048c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x009c43fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4c31087 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#4  0xb4d436b5 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#5  0xb4c3118d in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#6  0xb4c31816 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#7  0x00e9be99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x009b673e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb079cb70 (LWP 6247)):
#0  0x00ac5416 in __kernel_vsyscall ()
#1  0x00ea0834 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x009c4454 in pthread_cond_timedwait () from /lib/i386-linux-gnu/libc.so.6
#3  0x050ea3e5 in wait (this=0x988d9fc, mutex=0x988d9f8, time=30000) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x988d9fc, mutex=0x988d9f8, time=30000) at thread/qwaitcondition_unix.cpp:160
#5  0x050dd8f1 in QThreadPoolThread::run (this=0x988db48) at concurrent/qthreadpool.cpp:140
#6  0x050e9da2 in QThreadPrivate::start (arg=0x988db48) at thread/qthread_unix.cpp:320
#7  0x00e9be99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x009b673e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb77cd710 (LWP 6237)):
[KCrash Handler]
#7  0xb4dc78ab in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#8  0xb4ef87f7 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#9  0xb4c18c36 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#10 0xb4c200cc in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#11 0x08051765 in NSPluginInstance::NPDestroyStream (this=0x97f8028, stream=0x9898de8, reason=0) at ../../../nsplugins/viewer/nsplugin.cpp:1189
#12 0x08053b48 in NSPluginStreamBase::finish (this=0x988f000, err=false) at ../../../nsplugins/viewer/nsplugin.cpp:1817
#13 0x08054e74 in NSPluginInstance::javascriptResult (this=0x97f8028, id=0, result=...) at ../../../nsplugins/viewer/nsplugin.cpp:1124
#14 0x080614ab in InstanceAdaptor::qt_metacall (this=0x97f8158, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbf97e34c) at instanceadaptor.moc:129
#15 0x0012cacd in QDBusConnectionPrivate::deliverCall (this=0x96f3160, object=0x97f8158, msg=..., metaTypes=..., slotIdx=6) at qdbusintegrator.cpp:942
#16 0x0012dbb2 in QDBusConnectionPrivate::activateCall (this=0x96f3160, object=0x97f8158, flags=273, msg=...) at qdbusintegrator.cpp:845
#17 0x0012e1ac in QDBusConnectionPrivate::activateObject (this=0x96f3160, node=..., msg=..., pathStartPos=11) at qdbusintegrator.cpp:1430
#18 0x0012e62a in QDBusActivateObjectEvent::placeMetaCall (this=0x988f050) at qdbusintegrator.cpp:1524
#19 0x051f33b7 in QObject::event (this=0x97f8028, e=0x988f050) at kernel/qobject.cpp:1226
#20 0x01030d24 in QApplicationPrivate::notify_helper (this=0x96b01d8, receiver=0x97f8028, e=0x988f050) at kernel/qapplication.cpp:4462
#21 0x010358ce in QApplication::notify (this=0xbf97ee08, receiver=0x97f8028, e=0x988f050) at kernel/qapplication.cpp:3862
#22 0x00ca73ca in KApplication::notify (this=0xbf97ee08, receiver=0x97f8028, event=0x988f050) at ../../kdeui/kernel/kapplication.cpp:311
#23 0x051de0bb in QCoreApplication::notifyInternal (this=0xbf97ee08, receiver=0x97f8028, event=0x988f050) at kernel/qcoreapplication.cpp:731
#24 0x051e1c79 in sendEvent (receiver=0x0, event_type=0, data=0x9663f38) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9663f38) at kernel/qcoreapplication.cpp:1372
#26 0x051e1e0d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#27 0x0520b3c4 in sendPostedEvents (s=0x96afde8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#28 postEventSourceDispatch (s=0x96afde8) at kernel/qeventdispatcher_glib.cpp:277
#29 0x00363aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0x00364270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0x00364524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0x0520b53c in QEventDispatcherGlib::processEvents (this=0x9663a90, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#33 0x010e4775 in QGuiEventDispatcherGlib::processEvents (this=0x9663a90, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x051dd289 in QEventLoop::processEvents (this=0xbf97ec74, flags=...) at kernel/qeventloop.cpp:149
#35 0x051dd522 in QEventLoop::exec (this=0xbf97ec74, flags=...) at kernel/qeventloop.cpp:201
#36 0x051e1ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#37 0x0102e8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#38 0x0805adca in main (argc=) at ../../../nsplugins/viewer/viewer.cpp:144

Report to https://bugs.kde.org

The crash can be reproduced every time.

-- Backtrace:
Application: nspluginviewer (nspluginviewer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78c7710 (LWP 6568))]

Thread 4 (Thread 0xb4abbb70 (LWP 6574)):
#0  0x00879416 in __kernel_vsyscall ()
#1  0x0085848c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x00a6f3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4d2b087 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#4  0xb4e3d6b5 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#5  0xb4d2b18d in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#6  0xb4d2b816 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#7  0x00853e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x00a6173e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xb2abab70 (LWP 6575)):
#0  0x00879416 in __kernel_vsyscall ()
#1  0x0085848c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x00a6f3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4d2b087 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#4  0xb4e3d6b5 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#5  0xb4d2b18d in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#6  0xb4d2b816 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#7  0x00853e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x00a6173e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb08b2b70 (LWP 6578)):
#0  0x00879416 in __kernel_vsyscall ()
#1  0x00858834 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x00a6f454 in pthread_cond_timedwait () from /lib/i386-linux-gnu/libc.so.6
#3  0x041b43e5 in wait (this=0x9cb4524, mutex=0x9cb4520, time=30000) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x9cb4524, mutex=0x9cb4520, time=30000) at thread/qwaitcondition_unix.cpp:160
#5  0x041a78f1 in QThreadPoolThread::run (this=0x9ca1978) at concurrent/qthreadpool.cpp:140
#6  0x041b3da2 in QThreadPrivate::start (arg=0x9ca1978) at thread/qthread_unix.cpp:320
#7  0x00853e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x00a6173e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb78c7710 (LWP 6568)):
[KCrash Handler]
#7  0xb4ec18ab in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#8  0xb4ff27f7 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#9  0xb4d12c36 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#10 0xb4d1a0cc in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#11 0x08051765 in NSPluginInstance::NPDestroyStream (this=0x9c126e8, stream=0x9ca8768, reason=0) at ../../../nsplugins/viewer/nsplugin.cpp:1189
#12 0x08053b48 in NSPluginStreamBase::finish (this=0x9caaff0, err=false) at ../../../nsplugins/viewer/nsplugin.cpp:1817
#13 0x08054e74 in NSPluginInstance::javascriptResult (this=0x9c126e8, id=0, result=...) at ../../../nsplugins/viewer/nsplugin.cpp:1124
#14 0x080614ab in InstanceAdaptor::qt_metacall (this=0x9c12818, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfae6cac) at instanceadaptor.moc:129
#15 0x00247acd in QDBusConnectionPrivate::deliverCall (this=0x9b69160, object=0x9c12818, msg=..., metaTypes=..., slotIdx=6) at qdbusintegrator.cpp:942
#16 0x00248bb2 in QDBusConnectionPrivate::activateCall (this=0x9b69160, object=0x9c12818, flags=273, msg=...) at qdbusintegrator.cpp:845
#17 0x002491ac in QDBusConnectionPrivate::activateObject (this=0x9b69160, node=..., msg=..., pathStartPos=11) at qdbusintegrator.cpp:1430
#18 0x0024962a in QDBusActivateObjectEvent::placeMetaCall (this=0x9caaf30) at qdbusintegrator.cpp:1524
#19 0x042bd3b7 in QObject::event (this=0x9c126e8, e=0x9caaf30) at kernel/qobject.cpp:1226
#20 0x017a9d24 in QApplicationPrivate::notify_helper (this=0x9b261d8, receiver=0x9c126e8, e=0x9caaf30) at kernel/qapplication.cpp:4462
#21 0x017ae8ce in QApplication::notify (this=0xbfae7768, receiver=0x9c126e8, e=0x9caaf30) at kernel/qapplication.cpp:3862
#22 0x00f633ca in KApplication::notify (this=0xbfae7768, receiver=0x9c126e8, event=0x9caaf30) at ../../kdeui/kernel/kapplication.cpp:311
#23 0x042a80bb in QCoreApplication::notifyInternal (this=0xbfae7768, receiver=0x9c126e8, event=0x9caaf30) at kernel/qcoreapplication.cpp:731
#24 0x042abc79 in sendEvent (receiver=0x0, event_type=0, data=0x9ad9f38) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9ad9f38) at kernel/qcoreapplication.cpp:1372
#26 0x042abe0d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#27 0x042d53c4 in sendPostedEvents (s=0x9b25de8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#28 postEventSourceDispatch (s=0x9b25de8) at kernel/qeventdispatcher_glib.cpp:277
#29 0x003c1aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0x003c2270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0x003c2524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0x042d553c in QEventDispatcherGlib::processEvents (this=0x9ad9a90, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#33 0x0185d775 in QGuiEventDispatcherGlib::processEvents (this=0x9ad9a90, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x042a7289 in QEventLoop::processEvents (this=0xbfae75d4, flags=...) at kernel/qeventloop.cpp:149
#35 0x042a7522 in QEventLoop::exec (this=0xbfae75d4, flags=...) at kernel/qeventloop.cpp:201
#36 0x042abecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#37 0x017a78e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#38 0x0805adca in main (argc=) at ../../../nsplugins/viewer/viewer.cpp:144

Reported using DrKonqi
Comment 1 Tommi Tervo 2011-05-19 07:45:26 UTC
Which flash plugin do you use? type

about:plugins

to address bar.

Did you mix Firefox and Konqueror?
Comment 2 Martin Koller 2011-06-24 20:40:14 UTC
The crash seems to be inside the flash-plugin, which is not a KDE product
Comment 3 Christophe Giboudeaux 2011-07-14 21:03:27 UTC
*** Bug 276063 has been marked as a duplicate of this bug. ***