Bug 273363 - Rating in statistics doesn't show halves of score
Summary: Rating in statistics doesn't show halves of score
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collection Browser (show other bugs)
Version: 2.5.0
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-15 20:09 UTC by karaluh
Modified: 2012-07-03 19:03 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.6


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description karaluh 2011-05-15 20:09:48 UTC
Version:           2.4.1
OS:                Linux

2.4.1 regression.

Reproducible: Always

Steps to Reproduce:
Have album with only one track. Give this track 3,5 rating. Edit track information for the whole album. 

Actual Results:  
The album has 3,0 rating.

Expected Results:  
The album has 3,5 rating.

OS: Linux (i686) release 2.6.38-9-generic
Compiler: cc
Comment 1 karaluh 2011-05-15 20:32:37 UTC
Ok, it's not entirely like this. Rounding algorithm was changed in 2.4.1. For example album with ratings:
3
3,5
4
4
3,5
5
3
4
has now rating 3,5, in all previous versions it had 4, which is mathematically more correct.
Comment 2 Myriam Schweingruber 2011-05-15 22:52:11 UTC
Not a regression, but a duplicate of an old bug you reported yourself :)

*** This bug has been marked as a duplicate of bug 268246 ***
Comment 3 karaluh 2011-05-16 08:50:20 UTC
That's not a duplicate. Both are my reports and both are about different
issues. The 268246 one is about incorrectly saving ratings to files, this one is about incorrectly calculating album rating.
Comment 4 Ralf Engels 2011-07-01 14:32:18 UTC
For clarification:
With "album rating" you mean the rating that is displayed on the first page of the edit-track-details dialog?
Comment 5 Myriam Schweingruber 2011-07-18 06:46:22 UTC
Karaluh, could you please answer? Without your feedback there is not much we can do here.
Comment 6 karaluh 2011-07-18 07:24:08 UTC
Sorry, I forgot about the notification e-mail. Yes, this is the rating indeed. I was refering to it as "album rating" because it is how I use this info.
Comment 7 Myriam Schweingruber 2011-07-18 08:30:12 UTC
Thank you for the feedback.
Comment 8 Ralf Engels 2011-07-20 09:11:17 UTC
Seems to work for me.
Can you check it with the latest version and try to give me a more detailed instruction how to reproduce?
Comment 9 karaluh 2011-08-11 12:45:28 UTC
Bug still present in 2.4.3. Take 8 tracks, rate 5 of them 3,5 and the rest 3. When you see the track details for all the tracks, the rating is 3, but it should be 3,5 instead.
Comment 10 Ralf Engels 2011-08-11 13:17:01 UTC
Ok.

(5 * 3,5 + 3 * 3) / 8 = 3,3125

That is displayed as 3 stars. So it's always rounding down.

Is that what you are complaining about?
Comment 11 karaluh 2011-08-16 13:29:02 UTC
Yes, that would be the problem.
Comment 12 Aakash 2011-12-31 03:54:35 UTC
In Amarok 2.5 I am getting the same results as Comment #9. Though not sure whether it is a "bug" or the way it should really be.
Comment 13 Myriam Schweingruber 2011-12-31 12:50:17 UTC
Setting status to confirmed.
Comment 14 Matěj Laitl 2012-07-03 19:03:20 UTC
Git commit 6014811fda5a1ea71b4576630a7b8ae2e3754e4c by Matěj Laitl.
Committed on 03/07/2012 at 18:12.
Pushed by laitl into branch 'master'.

TagDialog: correct rounding for rating

I still wonder how observant our users are. :-)
FIXED-IN: 2.6

M  +1    -0    ChangeLog
M  +2    -1    src/dialogs/TagDialog.cpp

http://commits.kde.org/amarok/6014811fda5a1ea71b4576630a7b8ae2e3754e4c